LMDE doesn't see 2nd SATA hard drive [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

LMDE doesn't see 2nd SATA hard drive [SOLVED]

Postby runbei on Sat Oct 23, 2010 12:30 am

sudo fdisk -l finds my second SATA hard disk ok:

Code: Select all
l): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x91f72d24

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *           1         984     7897056    b  W95 FAT32
Partition 1 has different physical/logical endings:
     phys=(982, 254, 63) logical=(983, 36, 12)



But it isn't mounted at startup. I've used LM for 3 years but am not terribly savvy under the hood. Here's my fstab file. Any way to get sdb to mount at startup? (Worked fine in main edition.) Thanks!

Code: Select all
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda2 during installation
UUID=d970ccc1-40a1-4aed-bc41-0eb3dd61c3d7 /               ext3    errors=remount-ro 0       1
# /home was on /dev/sda4 during installation
UUID=de840bed-f8a0-4eb2-87b9-f9f262dbf257 /home           ext3    defaults        0       2
/dev/sda3       none            swap    sw              0       0
# swap was on /dev/sdb2 during installation
UUID=2cd9eab5-036c-49c9-8a63-25dc9cfc7ec5 none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
Last edited by runbei on Mon Oct 25, 2010 9:41 am, edited 2 times in total.
runbei
Level 3
Level 3
 
Posts: 173
Joined: Fri Jul 25, 2008 12:49 am
Location: Mountain View, CA

Linux Mint is funded by ads and donations.
 

Re: LMDE doesn't see my second SATA hard drive

Postby caf4926 on Sat Oct 23, 2010 12:36 am

Is that the full fdisk result?
Where is the partition info
Image
Mint 16 Cinnamon_64
User avatar
caf4926
Level 7
Level 7
 
Posts: 1786
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: LMDE doesn't see my second SATA hard drive

Postby runbei on Sat Oct 23, 2010 1:08 am

caf4926 wrote:Is that the full fdisk result?
Where is the partition info


Thanks for the reply - I corrected the listing to include the full fdisk result. Would be grateful for any help, as I keep all data on that drive.
runbei
Level 3
Level 3
 
Posts: 173
Joined: Fri Jul 25, 2008 12:49 am
Location: Mountain View, CA

Re: LMDE doesn't see my second SATA hard drive

Postby caf4926 on Sat Oct 23, 2010 1:19 am

The way Mint handles disks where no fstab entry exists is the user manually calls the mount at access.

You could do this:

Code: Select all
sudo mkdir /STORE

where STORE is the name of the directory you want to mount to, call it what you like. This will create a directory at /

I make an assumption that your login/user name is runbei,so replace as required for the next bit

Code: Select all
sudo chown -R runbei /STORE


Now add a line to fstab

Code: Select all
/dev/sdc1 /STORE vfat users,gid=users,umask=0002,utf8 0 0

reboot
Image
Mint 16 Cinnamon_64
User avatar
caf4926
Level 7
Level 7
 
Posts: 1786
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: LMDE doesn't see my second SATA hard drive

Postby altair4 on Sat Oct 23, 2010 7:11 am

Now add a line to fstab

Code: Select all
/dev/sdc1 /STORE vfat users,gid=users,umask=0002,utf8 0 0

In order for that to actually work in LMDE ( or in standard Mint ) you are going to have to include yourself in the "users" group ( the "gid=users" option in fstab ). To add yourself in the users group:
Code: Select all
sudo gpasswd -a runbei users

Then logout and login again.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6275
Joined: Tue Feb 03, 2009 10:27 am

Re: LMDE doesn't see my second SATA hard drive

Postby runbei on Sat Oct 23, 2010 10:49 am

Thanks a bunch - won't be able to try these suggestions until tonight, but will post results and mark "solved" if it works. Appreciate the help!
runbei
Level 3
Level 3
 
Posts: 173
Joined: Fri Jul 25, 2008 12:49 am
Location: Mountain View, CA

Re: LMDE doesn't see my second SATA hard drive

Postby runbei on Mon Oct 25, 2010 9:42 am

runbei wrote:Thanks a bunch - won't be able to try these suggestions until tonight, but will post results and mark "solved" if it works. Appreciate the help!


It worked - thanks a bunch.
runbei
Level 3
Level 3
 
Posts: 173
Joined: Fri Jul 25, 2008 12:49 am
Location: Mountain View, CA

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 3 guests