Attention: Moderator please delete this

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Attention: Moderator please delete this

Postby crborga on Wed Nov 03, 2010 9:27 pm

Moderator please delete topic
Last edited by crborga on Tue May 29, 2012 11:59 pm, edited 7 times in total.
Image
crborga
Level 2
Level 2
 
Posts: 99
Joined: Wed Oct 27, 2010 10:09 am
Location: South Carolina, USA

Linux Mint is funded by ads and donations.
 

Re: HOWTO: Install Burg Boot Loader

Postby Aging Technogeek on Wed Nov 03, 2010 9:44 pm

You do not have to compile anything to install Burg. Go to this site http://code.google.com/p/burg/wiki/InstallUbuntu, add the ppa to your sources.list and install Burg using the procedure outlined.
Image

Registered Linux User 483387
User avatar
Aging Technogeek
Level 13
Level 13
 
Posts: 4605
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: HOWTO: Install Burg Boot Loader

Postby crborga on Wed Nov 03, 2010 9:55 pm

Aging Technogeek wrote:You do not have to compile anything to install Burg. Go to this site http://code.google.com/p/burg/wiki/InstallUbuntu, add the ppa to your sources.list and install Burg using the procedure outlined.

I used that repository as a source only because I read Ubuntu package are not compadible with LMDE. I'm not sure if the binaries work fine but I didn't want to risk it.
Image
crborga
Level 2
Level 2
 
Posts: 99
Joined: Wed Oct 27, 2010 10:09 am
Location: South Carolina, USA

Re: HOWTO: Compile and Install Burg Boot Loader

Postby Aging Technogeek on Thu Nov 04, 2010 4:24 am

I have installed Burg in LMDE via apt-get using the binary ppa



and procedure (for installation in Lucid Lynx) listed in my post above with no problems. In spite of what some posts here say, there are a few Ubuntu apps that are compatible with Debian. This seems to be one of them.
Image

Registered Linux User 483387
User avatar
Aging Technogeek
Level 13
Level 13
 
Posts: 4605
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: HOWTO: Compile and Install Burg Boot Loader

Postby crborga on Thu Nov 04, 2010 9:14 am

Aging Technogeek wrote:I have installed Burg in LMDE via apt-get using the binary ppa



and procedure (for installation in Lucid Lynx) listed in my post above with no problems. In spite of what some posts here say, there are a few Ubuntu apps that are compatible with Debian. This seems to be one of them.


Well i guess this is here for those who want to compile to make sure it works right.
Image
crborga
Level 2
Level 2
 
Posts: 99
Joined: Wed Oct 27, 2010 10:09 am
Location: South Carolina, USA

Re: HOWTO: Compile and Install Burg Boot Loader

Postby azathoth on Thu Nov 04, 2010 9:58 am

crborga wrote:
Aging Technogeek wrote:I have installed Burg in LMDE via apt-get using the binary ppa



and procedure (for installation in Lucid Lynx) listed in my post above with no problems. In spite of what some posts here say, there are a few Ubuntu apps that are compatible with Debian. This seems to be one of them.


Well i guess this is here for those who want to compile to make sure it works right.


Yeah, I'd tread carefully with anything from the beelzubuntu repos, even if it works initially. If and when Canonical decides to change something they do not worry about and do not test for Debian compatibility. Might work out well in the long haul, might not. A bootloader gone wrong is usually an easy fix, but using their repos certainly isn't a great habit to get into. :wink:
arch | kernel26-lqx | kde 4.7.0 & xfce 4.8.1(tiling)
"Sacred cows make the best hamburger." ~ Mark Twain
MyLast.fm
User avatar
azathoth
Level 3
Level 3
 
Posts: 130
Joined: Thu Aug 05, 2010 7:09 am
Location: Portland, Oregon

Re: HOWTO: Compile and Install Burg Boot Loader

Postby Aging Technogeek on Thu Nov 04, 2010 1:20 pm

azathoth,

I think you are confusing things. Burg is not a product of Canonical. It is provided by the same people who provide Grub to Ubuntu, Fedora and many other distros.

The ppa is not from or in the Ubuntu repos, it s downloaded from Launchpad. It is the same ppa that crborga recommends downloading to compile Burg. The only difference is he uses the source code file and I recommend adding the binary file to your sources list.

I just feel that compiling something that is already compiled and offered in a binary package from the same source is unnecessary work.
Image

Registered Linux User 483387
User avatar
Aging Technogeek
Level 13
Level 13
 
Posts: 4605
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: HOWTO: Compile and Install Burg Boot Loader

Postby jeffreyC on Thu Nov 04, 2010 9:25 pm

I do wonder if Lucid is the most compatible with Debian Squeeze/testing.

On other forums I have seen posts saying that Lucid packages were too old and Maverick too new.
Get Dropbox and an extra 250 mb http://db.tt/wAizqw0
jeffreyC
Level 4
Level 4
 
Posts: 318
Joined: Mon Jun 07, 2010 9:34 pm

Re: HOWTO: Compile and Install Burg Boot Loader

Postby crborga on Fri Nov 05, 2010 3:58 pm

jeffreyC wrote:I do wonder if Lucid is the most compatible with Debian Squeeze/testing.

On other forums I have seen posts saying that Lucid packages were too old and Maverick too new.


not sure but it's working perfectly using the method above for me
Image
crborga
Level 2
Level 2
 
Posts: 99
Joined: Wed Oct 27, 2010 10:09 am
Location: South Carolina, USA

Re: HOWTO: Compile and Install Burg Boot Loader

Postby Adidi on Mon Jul 18, 2011 7:41 am

Hi all,

With debian/testing repository I can't compil burg because of gcc 4.6 bug (i think):

Code: Select all
/home/adidi/burg/burg-1.98+20100623/efiemu/main.c: In function ‘grub_efiemu_prepare’:
/home/adidi/burg/burg-1.98+20100623/efiemu/main.c:288:14: erreur: variable ‘err’ set but not used [-Werror=unused-but-set-variable]
cc1: all warnings being treated as errors

make[1]: *** [efiemu_mod-efiemu_main.o] Erreur 1
make[1]: quittant le répertoire « /home/adidi/burg/burg-1.98+20100623/build/burg-common »
make: *** [build/burg-common] Erreur 2
dpkg-buildpackage: erreur: debian/rules build a produit une erreur de sortie de type 2



Any idea to pass out?
Adidi
Level 1
Level 1
 
Posts: 1
Joined: Mon Jul 18, 2011 7:13 am

Re: HOWTO: Compile and Install Burg Boot Loader

Postby alirezaimi on Thu Sep 01, 2011 1:04 pm

Hi
I have this error when i want fakeroot:
Code: Select all
cd .. && fakeroot dpkg-buildpackage && cd ~/burg/burg-themes-1.98+20100623 && fakeroot dpkg-buildpackage


error:
Code: Select all
alireza@alireza-lap ~/burg/burg-1.98+20100623 $fakeroot dpkg-buildpackage && cd ~/burg/burg-themes-1.98+20100623 && fakeroot dpkg-buildpackage
pkg-buildpackage: export CFLAGS from dpkg-buildflags (origin: vendor): -g -O2
dpkg-buildpackage: export CPPFLAGS from dpkg-buildflags (origin: vendor):
dpkg-buildpackage: export CXXFLAGS from dpkg-buildflags (origin: vendor): -g -O2
dpkg-buildpackage: export FFLAGS from dpkg-buildflags (origin: vendor): -g -O2
dpkg-buildpackage: export LDFLAGS from dpkg-buildflags (origin: vendor):
dpkg-buildpackage: source package burg
dpkg-buildpackage: source version 1.98+20100623-1
dpkg-buildpackage: source changed by Bean <bean@ubuntu.localdomain>
dpkg-buildpackage: host architecture amd64
 dpkg-source --before-build burg-1.98+20100623
 debian/rules clean
/usr/share/cdbs/1/rules/simple-patchsys.mk:31: WARNING:  simple-patchsys.mk is deprecated - please use source format 3.0 (quilt) instead
debian/rules:39: *** missing separator.  Stop.
dpkg-buildpackage: error: debian/rules clean gave error exit status 2


why??
alirezaimi
Level 2
Level 2
 
Posts: 64
Joined: Tue Feb 08, 2011 5:18 am

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 4 guests