[Solved] Login screen: disable user list

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

[Solved] Login screen: disable user list

Postby tacoz on Thu Dec 30, 2010 1:47 am

The main edition made this real easy... how do I disable showing users on the login screen?
i.e. force user to type in name and pwd
Thanks!

EDIT: the following do not work
(a) in the configuration editor | /apps/gdm/simple-greeter | disable_user_list = true
(b) edit /etc/gdm3/greeter.gconf-defaults and changing
Code: Select all
#/apps/gdm/simple-greeter/disable_user_list      false
to
Code: Select all
/apps/gdm/simple-greeter/disable_user_list      true
when machine restarts, 'greeter.gconf-defaults' returns to its original state.
Last edited by tacoz on Thu Dec 30, 2010 4:12 am, edited 1 time in total.
tacoz
Level 2
Level 2
 
Posts: 86
Joined: Wed Aug 12, 2009 12:38 am
Location: Zoolooland

Linux Mint is funded by ads and donations.
 

Re: Login screen: disable user list

Postby ShexNivis on Thu Dec 30, 2010 3:53 am

Do you have the file called: /usr/share/linuxmint/adjustments/gdm3/greeter.gconf-defaults
if you do try putting that line there.

If you don't have that file check if you have /usr/share/gdm/greeter-config/20_debian
If you do try putting that line there.

if you got none of those files post the content of /usr/share/gdm/greeter-config/

If it doesn't work take the line off from the file you added and wait for someone else's suggestion.

by the way the line I'm talking about is: '/apps/gdm/simple-greeter/disable_user_list true'
best torrent client ever: http://www.tixati.com
User avatar
ShexNivis
Level 3
Level 3
 
Posts: 109
Joined: Mon Sep 21, 2009 10:25 pm

Re: Login screen: disable user list

Postby tacoz on Thu Dec 30, 2010 4:11 am

Thanks ShexNivis!
But I solved it and kinda came to your solution anyway:

(a) it bothered me that /etc/gdm3/greeter.gconf-default was being replaced, so I did a search to find what would be doing that
(b) found some interesting stuff that Debian should be doing but is not doing cos the Mint sysdev guys have put in these 'adjustments' for whatever reasons; the first clue was in the README located in /etc/linuxmint/adjustments
(c) from there I found that '15-gdm3.overwrite' was the key cos it contained
Code: Select all
/usr/share/linuxmint/adjustments/gdm3/greeter.gconf-defaults /etc/gdm3/greeter.gconf-defaults
(d) so it was simply a matter of editing the first linuxmint greeter file cos it replaces the gdm3 one
(e) and yay... it provides what I want!
tacoz
Level 2
Level 2
 
Posts: 86
Joined: Wed Aug 12, 2009 12:38 am
Location: Zoolooland

Re: [Solved] Login screen: disable user list

Postby ShexNivis on Thu Dec 30, 2010 4:15 am

just out of curiosity is your system updated? installed with first iso or the new(last week) one? and also did you apply levels 4 and 5 updates?
if you don't mind telling me that of course.
best torrent client ever: http://www.tixati.com
User avatar
ShexNivis
Level 3
Level 3
 
Posts: 109
Joined: Mon Sep 21, 2009 10:25 pm

Re: [Solved] Login screen: disable user list

Postby tacoz on Thu Dec 30, 2010 4:25 am

When the 64-bit LMDE was released a few days ago, I was up for doing a fresh installation... and yes, currently there are no updates outstanding.

Code: Select all
> apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
tacoz
Level 2
Level 2
 
Posts: 86
Joined: Wed Aug 12, 2009 12:38 am
Location: Zoolooland

Re: [Solved] Login screen: disable user list

Postby ShexNivis on Thu Dec 30, 2010 4:28 am

weird that my installation doesn't have any adjustments for gdm.
anyway glad that you got it solved : )
best torrent client ever: http://www.tixati.com
User avatar
ShexNivis
Level 3
Level 3
 
Posts: 109
Joined: Mon Sep 21, 2009 10:25 pm

Re: [Solved] Login screen: disable user list

Postby tacoz on Thu Dec 30, 2010 4:35 am

Interesting... so you don't have the /etc/linuxmint/adjustments folder?
Then let me ask you the same question, was your system installed with the first iso or the new one?
tacoz
Level 2
Level 2
 
Posts: 86
Joined: Wed Aug 12, 2009 12:38 am
Location: Zoolooland

Re: [Solved] Login screen: disable user list

Postby ShexNivis on Thu Dec 30, 2010 4:40 am

tacoz wrote:Interesting... so you don't have the /etc/linuxmint/adjustments folder?
Then let me ask you the same question, was your system installed with the first iso or the new one?


Yes, first iso.

I do have it.
Code: Select all
ls -l /etc/linuxmint/adjustments
total 20
-rw-r--r-- 1 root root  101 Ago  1 07:39 10-mintsystem-synaptic.overwrite
-rw-r--r-- 1 root root 2465 Jul 31 14:39 15-firefox.overwrite
-rw-r--r-- 1 root root  139 Jul 31 14:39 15-gnome-sound.overwrite
-rw-r--r-- 1 root root  632 Jul 31 14:39 15-opera.overwrite
-rw-r--r-- 1 root root  598 Ago  1 07:39 README


How ever I don't have /usr/share/linuxmint/adjustments
Code: Select all
ls -l /usr/share/linuxmint
total 16
drwxr-xr-x 87 root root 4096 Dez  2 17:51 locale
-rw-r--r--  1 root root 2610 Nov  3  2009 logo.png
drwxr-xr-x  4 root root 4096 Dez  2 01:56 mintinstall
drwxr-xr-x  4 root root 4096 Ago 16 09:14 mint-search-addon
best torrent client ever: http://www.tixati.com
User avatar
ShexNivis
Level 3
Level 3
 
Posts: 109
Joined: Mon Sep 21, 2009 10:25 pm

Re: [Solved] Login screen: disable user list

Postby tacoz on Thu Dec 30, 2010 4:52 am

Fascinating... I wonder why the Mint devs made this slight change?
my folder has one extra file that yours doesn't... specific to gdm3...
Code: Select all
 ls -l /etc/linuxmint/adjustments
total 24
-rw-r--r-- 1 root root  101 Aug  1 12:39 10-mintsystem-synaptic.overwrite
-rw-r--r-- 1 root root 2465 Nov 25 14:12 15-firefox.overwrite
-rw-r--r-- 1 root root   95 Nov 26 15:45 15-gdm3.overwrite
-rw-r--r-- 1 root root  139 Nov 25 14:12 15-gnome-sound.overwrite
-rw-r--r-- 1 root root  632 Nov 25 14:12 15-opera.overwrite
-rw-r--r-- 1 root root  598 Aug  1 12:39 README
weird... but at least anyone else reading this will know where to look when it comes to messing around with gdm3 greeter settings
tacoz
Level 2
Level 2
 
Posts: 86
Joined: Wed Aug 12, 2009 12:38 am
Location: Zoolooland

Re: [Solved] Login screen: disable user list

Postby ShexNivis on Thu Dec 30, 2010 4:55 am

for anyone that come across this some other info on gdm greeter can be found at viewtopic.php?f=141&t=60853
best torrent client ever: http://www.tixati.com
User avatar
ShexNivis
Level 3
Level 3
 
Posts: 109
Joined: Mon Sep 21, 2009 10:25 pm

Re: [Solved] Login screen: disable user list

Postby tacoz on Thu Dec 30, 2010 5:08 am

There is a proper way to make changes to our gdm3 greeeter, documented and confirmed working by me on a clean debian system. Mint users can also use the documented method to make changes, however, after a system restart the changes are lost and the changes made to the file have been overwritten.


Sweet! Thanks for that last topic link. Boy... did oOarthurOo do some forensics there or what! I see he nailed the fact that the Mint devs are making 'adjustments' and so we can't fully follow Debian documented stuff... yet!
tacoz
Level 2
Level 2
 
Posts: 86
Joined: Wed Aug 12, 2009 12:38 am
Location: Zoolooland

Re: [Solved] Login screen: disable user list

Postby SaintDanBert on Sat Jan 14, 2012 2:19 am

I bow to expertise far beyond my own ... however, I'm dashed if I discover in all of this thread and its associated discussion links how anyone thinks "Login screen: disable user list" is solved.

In past editions, I'd open the users and groups applet and set/clear a check box and the list of names would appear or vanish. Looks like I now must load a "theme" somehow and some where and several pages of thread reading later I still do not have a clue.

I have Linux Mint-12 on a laptop. I don't want a list of usernames on the login screen. Instead, I want folks to enter a username then a password to login. That means that they need to know two details rather than be handed one and try to guess the other.

Can anyone tell me how to disable the user list on the login screen?
All government spending, regardless of the motives, uses YOUR money!
Any government extensive enough to give you anything that you want is also
powerful enough to take everything that you have.
User avatar
SaintDanBert
Level 3
Level 3
 
Posts: 155
Joined: Sat Feb 20, 2010 4:04 pm
Location: Austin, TX USA

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Google [Bot] and 6 guests