LMDE BREAKAGES - tracking TESTING

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Re: LMDE BREAKAGES - read here first - Update 30 april 2011

Postby barko on Thu May 05, 2011 4:22 am

gimba30 wrote:
ukbrian wrote:Nah don't stand, sit back and chill :)

Now I have a real problem, the sound recorder don't work, I just get this error but synaptic don't recognize any of the utils mentioned :(


Had the same error. Try installing gstreamer0.10-gconf (0.10.28-3). It worked for me.


Thanks for that info. It worked for me too. :) Even better, now Totem works as it should too.
User avatar
barko
Level 2
Level 2
 
Posts: 92
Joined: Mon Dec 27, 2010 10:44 am
Location: Postojna, Slovenia

Linux Mint is funded by ads and donations.
 

Re: LMDE BREAKAGES - read here first - Update 30 april 2011

Postby ukbrian on Thu May 05, 2011 4:26 am

@gimba30
Had the same error. Try installing gstreamer0.10-gconf (0.10.28-3). It worked for me

Image Nice one friend, all up and running. :D
So it's not a bug they have just omitted to included "gstreamer0.10-gconf" in the updates.
Image

My instincts are good, it was right for a levels 1-3 guy to ask the friendly headbangers group for advice. :lol:

edit
Does the missing gstreamer thingy apply do level 5 folk or just level 3?
Would it be worth including in the first post?
User avatar
ukbrian
Level 4
Level 4
 
Posts: 276
Joined: Thu Jul 29, 2010 6:03 am
Location: Cheltenham, UK

Re: LMDE BREAKAGES - read here first - Update 30 april 2011

Postby Fornhamfred on Fri May 06, 2011 2:38 pm

I have previously posted my display problems with both the new kernals after full update. I have found that at grub only the two latest kernals are displayed and not 2.6.32.5-686, which works with my hardware. As far as I am aware no kernals are removed at update but how can I change grub to allow me to boot from the older kernal?

I have tried to boot Ubuntu 11.04 with kernal 2.6.38-8 but that just hangs after the initial screen giving a choice of live cd or install.
Fornhamfred
Level 6
Level 6
 
Posts: 1131
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: LMDE BREAKAGES - read here first - Update 30 april 2011

Postby ukbrian on Fri May 06, 2011 3:47 pm

Sorry Fornhamfred I lack the knowledge to help you with your kernel problems but if you do a reinstall the updates are well screwed at the moment, it's only offering 125 updates :? and gives this error, I tried with 4 different mirrors.
Image
I also noticed the "download package files" screen form with Mint Update needs a little more work done on it. http://lin.me.uk/pics/errors/download-package-files.avi
Nothing urgent but I would think the devs would want to put it right, it just don't resize right, I would also suggest making the next screen form, "Installing Updates" resizable to.
User avatar
ukbrian
Level 4
Level 4
 
Posts: 276
Joined: Thu Jul 29, 2010 6:03 am
Location: Cheltenham, UK

Re: LMDE BREAKAGES - read here first - Update 30 april 2011

Postby Wahlgren on Fri May 06, 2011 4:44 pm

ukbrian wrote:Image


Also have this error, but didn't try different mirrors. Just wait patiently for it to go away...

Edit: "My understanding is that it happens when you try to do an update while the repository itself is in the process of being updated". Found that answer at another forum.
User avatar
Wahlgren
Level 1
Level 1
 
Posts: 5
Joined: Sun May 01, 2011 8:55 am
Location: Sweden

LDME breakages - Update 13th May 2011 - older Nvidia cards

Postby john2 on Fri May 13, 2011 8:11 am

After updating on 13th May 2011, the PC booted to a black screen. The problem was that the Nvidia driver had been updated, but the latest ones don't work with some legacy cards (mine is a GeForce FX5200). The solution is to boot to a command line (as root), then do
Code: Select all
apt-get install nvidia-kernel-legacy-173xx-dkms

Put the package in 'Ignored packages' in MU, which should stop it being updated again.
john2
Level 1
Level 1
 
Posts: 5
Joined: Wed May 11, 2011 10:39 am

Re: LMDE BREAKAGES - read here first - Update 30 april 2011

Postby zerozero on Fri May 13, 2011 8:35 am

Thanks john2 for reporting this issue 8)
and first post updated :)
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - read here first - Update 13 may 2011

Postby ChromeMukuro on Fri May 13, 2011 6:35 pm

i performed updates today, and after doing so audio no longer works. i attempt to turn the volume up and no sound is produced; and after a few seconds a notification (the standard one that comes up when changing the volume) tells me the volume has been changed to 0 (ie it looks like i did it but i most definitely did not.) has anyone else encountered anything similar?
avatar by aramynthya

...don’t mourn your luck that’s failing now...
~The God Abandons Anthony
User avatar
ChromeMukuro
Level 2
Level 2
 
Posts: 52
Joined: Mon Oct 25, 2010 6:17 pm

Re: LMDE BREAKAGES - read here first - Update 13 may 2011

Postby wangsuda on Sat May 14, 2011 7:24 am

Latest round of updates removes xchat (not a problem for me, as I never use it). I believe it has to do with updating libperl from 5.10 to 5.10.1 because when I tried to install xchat, this is the error message I received:
Depends: libperl5.10 (>=5.10.1) but it is not installable
"I like my software rough." - Brett Larson, ICT instructor
Registered Linux User #487360
User avatar
wangsuda
Level 3
Level 3
 
Posts: 106
Joined: Sun Apr 03, 2011 11:42 pm
Location: Bangkok, TH

Re: LMDE BREAKAGES - read here first - Update 13 may 2011

Postby zerozero on Sat May 14, 2011 7:32 am

yep! you just beat to it 8)

xchat was removed in the perl upgrade (5.10 to 5.12)

Code: Select all
Commit Log for Sat May 14 12:18:21 2011


Removed the following packages:
libperl5.10
xchat

Upgraded the following packages:
alsa-base (1.0.23+dfsg-3) to 1.0.23+dfsg-4
e2fslibs (1.41.12-2) to 1.41.12-4
e2fsprogs (1.41.12-2) to 1.41.12-4
exim4-config (4.75-2) to 4.76-1
imagemagick (8:6.6.0.4-3) to 8:6.6.0.4-3+b1
libalgorithm-diff-xs-perl (0.04-1) to 0.04-1+b1
libaprutil1 (1.3.9+dfsg-5) to 1.3.10+dfsg-2
libaprutil1-dbd-sqlite3 (1.3.9+dfsg-5) to 1.3.10+dfsg-2
libaprutil1-ldap (1.3.9+dfsg-5) to 1.3.10+dfsg-2
libapt-pkg-perl (0.1.24+b1) to 0.1.24+b2
libc-bin (2.11.2-11) to 2.13-4
libc-dev-bin (2.11.2-11) to 2.13-4
libc6 (2.11.2-11) to 2.13-4
libc6-dev (2.11.2-11) to 2.13-4
libcairo-perl (1.070-2) to 1.070-2+b1
libcomerr2 (1.41.12-2) to 1.41.12-4
libglib-perl (2:1.223-1) to 2:1.223-1+b1
libgnome2-canvas-perl (1.002-2) to 1.002-2+b1
libgnome2-perl (1.042-2) to 1.042-2+b1
libgnome2-vfs-perl (1.081-1) to 1.081-1+b1
libgtk2-perl (2:1.223-1) to 2:1.223-1+b1
libhtml-parser-perl (3.68-1) to 3.68-1+b1
libldap-2.4-2 (2.4.25-1) to 2.4.25-1+b1
liblist-moreutils-perl (0.25~02-1) to 0.25~02-1+b1
liblocale-gettext-perl (1.05-6) to 1.05-6+b1
libmagickcore3 (8:6.6.0.4-3) to 8:6.6.0.4-3+b1
libmagickwand3 (8:6.6.0.4-3) to 8:6.6.0.4-3+b1
libnet-dbus-perl (0.33.6-2) to 0.33.6-2+b1
libnet-libidn-perl (0.12.ds-1+b1) to 0.12.ds-1+b2
libnet-ssleay-perl (1.36-2) to 1.36-2+b1
libpango-perl (1.221-2) to 1.221-2+b1
libpurple-bin (2.7.11-1) to 2.7.11-2
libpurple0 (2.7.11-1) to 2.7.11-2
libsnmp-base (5.4.3~dfsg-2) to 5.4.3~dfsg-2.2
libsnmp15 (5.4.3~dfsg-2) to 5.4.3~dfsg-2.2
libss2 (1.41.12-2) to 1.41.12-4
libsub-name-perl (0.05-1) to 0.05-1+b1
libsvga1 (1:1.4.3-30) to 1:1.4.3-31
libtext-charwidth-perl (0.04-6) to 0.04-6+b1
libtext-iconv-perl (1.7-2) to 1.7-2+b1
libuuid-perl (0.02-4) to 0.02-4+b1
libvte9 (1:0.24.3-2) to 1:0.24.3-2+b1
libxml-parser-perl (2.36-1.1+b1) to 2.36-1.1+b2
libzbar0 (0.10+doc-4) to 0.10+doc-6+b1
locales (2.11.2-11) to 2.13-4
perl (5.10.1-20) to 5.12.3-6
perl-base (5.10.1-20) to 5.12.3-6
perl-modules (5.10.1-20) to 5.12.3-6
pidgin (2.7.11-1) to 2.7.11-2
pidgin-data (2.7.11-1) to 2.7.11-2
python-vte (1:0.24.3-2) to 1:0.24.3-2+b1
vim-common (2:7.3.154+hg~74503f6ee649-2) to 2:7.3.154+hg~74503f6ee649-2+b1
vim-tiny (2:7.3.154+hg~74503f6ee649-2) to 2:7.3.154+hg~74503f6ee649-2+b1
x11-utils (7.6+1) to 7.6+2

Installed the following packages:
libclass-isa-perl (0.36-1)
libperl5.12 (5.12.3-6)
libpod-plainer-perl (1.03-1)
libswitch-perl (2.16-1)


edit: just saw now xchat depends on libperl5.10, so it's up to the devs now to rebuild it against the new perl 5.12
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - read here first - Update 13 may 2011

Postby narendra.d on Sat May 14, 2011 12:14 pm

Did a apt-get upgrade and apt-get dist-upgrade just now and have a error and broken packages:

Code: Select all
Error: E: /var/cache/apt/archives/linux-image-2.6.38-2-amd64_2.6.38-5_amd64.deb: subprocess new post-removal script returned error exit status 1


Broken packages: 17 packages

Code: Select all
/usr/bin/perl: symbol lookup error: /usr/lib/perl5/auto/Gtk2/Gtk2.so: undefined symbol: Perl_sv_utf8_upgrade_flags_grow
(Reading database ... 147823 files and directories currently installed.)
Preparing to replace linux-image-2.6.38-2-amd64 2.6.38-3 (using .../linux-image-2.6.38-2-amd64_2.6.38-5_amd64.deb) ...
debconf: unable to initialize frontend: Gnome
debconf: (Unable to load Gnome -- is libgnome2-perl installed?)
debconf: falling back to frontend: Dialog
debconf: unable to initialize frontend: Dialog
debconf: (TERM is not set, so the dialog frontend is not usable.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (Can't locate Term/ReadLine.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at /usr/share/perl5/Debconf/FrontEnd/Readline.pm line 7.)
debconf: falling back to frontend: Teletype
Unpacking replacement linux-image-2.6.38-2-amd64 ...
debconf: unable to initialize frontend: Gnome
debconf: (Unable to load Gnome -- is libgnome2-perl installed?)
debconf: falling back to frontend: Dialog
debconf: unable to initialize frontend: Dialog
debconf: (TERM is not set, so the dialog frontend is not usable.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (Can't locate Term/ReadLine.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at /usr/share/perl5/Debconf/FrontEnd/Readline.pm line 7.)
debconf: falling back to frontend: Teletype
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 2.6.38-2-amd64 /boot/vmlinuz-2.6.38-2-amd64
run-parts: executing /etc/kernel/postrm.d/zz-extlinux 2.6.38-2-amd64 /boot/vmlinuz-2.6.38-2-amd64
P: Checking for EXTLINUX directory... found.
P: Writing config for /boot/vmlinuz-2.6.38-2-amd64.dpkg-tmp...
P: Writing config for /boot/vmlinuz-2.6.38-2-amd64...
P: Updating /boot/extlinux/linux.cfg...
E: /usr/share/syslinux/debian/extlinux: No such file or directory
run-parts: /etc/kernel/postrm.d/zz-extlinux exited with return code 1
Failed to process /etc/kernel/postrm.d at /var/lib/dpkg/info/linux-image-2.6.38-2-amd64.postrm line 235.
dpkg: warning: subprocess old post-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
debconf: unable to initialize frontend: Gnome
debconf: (Unable to load Gnome -- is libgnome2-perl installed?)
debconf: falling back to frontend: Dialog
debconf: unable to initialize frontend: Dialog
debconf: (TERM is not set, so the dialog frontend is not usable.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (Can't locate Term/ReadLine.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at /usr/share/perl5/Debconf/FrontEnd/Readline.pm line 7.)
debconf: falling back to frontend: Teletype
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 2.6.38-2-amd64 /boot/vmlinuz-2.6.38-2-amd64
run-parts: executing /etc/kernel/postrm.d/zz-extlinux 2.6.38-2-amd64 /boot/vmlinuz-2.6.38-2-amd64
P: Checking for EXTLINUX directory... found.
P: Writing config for /boot/vmlinuz-2.6.38-2-amd64.dpkg-tmp...
P: Writing config for /boot/vmlinuz-2.6.38-2-amd64...
E: /usr/share/syslinux/debian/extlinux: No such file or directory
run-parts: /etc/kernel/postrm.d/zz-extlinux exited with return code 1
Failed to process /etc/kernel/postrm.d at /var/lib/dpkg/tmp.ci/postrm line 235.
dpkg: error processing /var/cache/apt/archives/linux-image-2.6.38-2-amd64_2.6.38-5_amd64.deb (--unpack):
 subprocess new post-removal script returned error exit status 1
configured to not write apport reports
                                      debconf: unable to initialize frontend: Gnome
debconf: (Unable to load Gnome -- is libgnome2-perl installed?)
debconf: falling back to frontend: Dialog
debconf: unable to initialize frontend: Dialog
debconf: (TERM is not set, so the dialog frontend is not usable.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (Can't locate Term/ReadLine.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at /usr/share/perl5/Debconf/FrontEnd/Readline.pm line 7.)
debconf: falling back to frontend: Teletype
debconf: unable to initialize frontend: Gnome
debconf: (Unable to load Gnome -- is libgnome2-perl installed?)
debconf: falling back to frontend: Dialog
debconf: unable to initialize frontend: Dialog
debconf: (TERM is not set, so the dialog frontend is not usable.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (Can't locate Term/ReadLine.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at /usr/share/perl5/Debconf/FrontEnd/Readline.pm line 7.)
debconf: falling back to frontend: Teletype
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 2.6.38-2-amd64 /boot/vmlinuz-2.6.38-2-amd64
run-parts: executing /etc/kernel/postrm.d/zz-extlinux 2.6.38-2-amd64 /boot/vmlinuz-2.6.38-2-amd64
P: Checking for EXTLINUX directory... found.
P: Writing config for /boot/vmlinuz-2.6.38-2-amd64...
P: Updating /boot/extlinux/linux.cfg...
E: /usr/share/syslinux/debian/extlinux: No such file or directory
run-parts: /etc/kernel/postrm.d/zz-extlinux exited with return code 1
Failed to process /etc/kernel/postrm.d at /var/lib/dpkg/tmp.ci/postrm line 235.
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/linux-image-2.6.38-2-amd64_2.6.38-5_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
dpkg: dependency problems prevent configuration of libperl5.12:
 libperl5.12 depends on perl-base (= 5.12.3-6); however:
  Version of perl-base on system is 5.10.1-20.
dpkg: error processing libperl5.12 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libpango-perl:
 libpango-perl depends on perlapi-5.12.3; however:
  Package perlapi-5.12.3 is not installed.
dpkg: error processing libpango-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libdigest-sha1-perl:
 libdigest-sha1-perl depends on perlapi-5.12.3; however:
  Package perlapi-5.12.3 is not installed.
dpkg: error processing libdigest-sha1-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libpurple0:
 libpurple0 depends on libperl5.12 (>= 5.12.3); however:
  Package libperl5.12 is not configured yet.
 libpurple0 depends on perl-base (>= 5.12.3-6); however:
  Version of perl-base on system is 5.10.1-20.
 libpurple0 depends on perlapi-5.12.3; however:
  Package perlapi-5.12.3 is not installed.
dpkg: error processing libpurple0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libapt-pkg-perl:
 libapt-pkg-perl depends on perl-base (>= 5.12.3-6); however:
  Version of perl-base on system is 5.10.1-20.
 libapt-pkg-perl depends on perlapi-5.12.3; however:
  Package perlapi-5.12.3 is not installed.
dpkg: error processing libapt-pkg-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libuuid-perl:
 libuuid-perl depends on perl-base (>= 5.12.3-6); however:
  Version of perl-base on system is 5.10.1-20.
 libuuid-perl depends on perlapi-5.12.3; however:
  Package perlapi-5.12.3 is not installed.
dpkg: error processing libuuid-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libglib-perl:
 libglib-perl depends on perlapi-5.12.3; however:
  Package perlapi-5.12.3 is not installed.
dpkg: error processing libglib-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libsnmp15:
 libsnmp15 depends on libperl5.12 (>= 5.12.3); however:
  Package libperl5.12 is not configured yet.
dpkg: error processing libsnmp15 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libalgorithm-diff-xs-perl:
 libalgorithm-diff-xs-perl depends on perlapi-5.12.3; however:
  Package perlapi-5.12.3 is not installed.
dpkg: error processing libalgorithm-diff-xs-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgtk2-perl:
 libgtk2-perl depends on perlapi-5.12.3; however:
  Package perlapi-5.12.3 is not installed.
 libgtk2-perl depends on libglib-perl (>= 1:1.230); however:
  Package libglib-perl is not configured yet.
 libgtk2-perl depends on libpango-perl (>= 1.220); however:
  Package libpango-perl is not configured yet.
dpkg: error processing libgtk2-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pidgin:
 pidgin depends on libpurple0 (>= 2.7.0); however:
  Package libpurple0 is not configured yet.
 pidgin depends on perl-base (>= 5.12.3-6); however:
  Version of perl-base on system is 5.10.1-20.
 pidgin depends on perlapi-5.12.3; however:
  Package perlapi-5.12.3 is not installed.
dpkg: error processing pidgin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of perl:
 perl depends on perl-base (= 5.12.3-6); however:
  Version of perl-base on system is 5.10.1-20.
dpkg: error processing perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libcairo-perl:
 libcairo-perl depends on perl (>= 5.12.3-6); however:
  Package perl is not configured yet.
 libcairo-perl depends on perlapi-5.12.3; however:
  Package perlapi-5.12.3 is not installed.
dpkg: error processing libcairo-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libhtml-parser-perl:
 libhtml-parser-perl depends on perl (>= 5.12.3-6); however:
  Package perl is not configured yet.
 libhtml-parser-perl depends on perlapi-5.12.3; however:
  Package perlapi-5.12.3 is not installed.
dpkg: error processing libhtml-parser-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libsub-name-perl:
 libsub-name-perl depends on perl (>= 5.12.3-6); however:
  Package perl is not configured yet.
 libsub-name-perl depends on perlapi-5.12.3; however:
  Package perlapi-5.12.3 is not installed.
dpkg: error processing libsub-name-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of liblist-moreutils-perl:
 liblist-moreutils-perl depends on perl (>= 5.12.3-6); however:
  Package perl is not configured yet.
 liblist-moreutils-perl depends on perlapi-5.12.3; however:
  Package perlapi-5.12.3 is not installed.
dpkg: error processing liblist-moreutils-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnet-dbus-perl:
 libnet-dbus-perl depends on perl (>= 5.12.3-6); however:
  Package perl is not configured yet.
 libnet-dbus-perl depends on perlapi-5.12.3; however:
  Package perlapi-5.12.3 is not installed.
dpkg: error processing libnet-dbus-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libtext-charwidth-perl:
 libtext-charwidth-perl depends on perl-base (>= 5.12.3-6); however:
  Version of perl-base on system is 5.10.1-20.
 libtext-charwidth-perl depends on perlapi-5.12.3; however:
  Package perlapi-5.12.3 is not installed.
dpkg: error processing libtext-charwidth-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of perl-modules:
 perl-modules depends on perl (>= 5.12.3-1); however:
  Package perl is not configured yet.
dpkg: error processing perl-modules (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libperl5.12
 libpango-perl
 libdigest-sha1-perl
 libpurple0
 libapt-pkg-perl
 libuuid-perl
 libglib-perl
 libsnmp15
 libalgorithm-diff-xs-perl
 libgtk2-perl
 pidgin
 perl
 libcairo-perl
 libhtml-parser-perl
 libsub-name-perl
 liblist-moreutils-perl
 libnet-dbus-perl
 libtext-charwidth-perl
 perl-modules
Last edited by narendra.d on Sat May 14, 2011 12:36 pm, edited 1 time in total.
narendra.d
Level 2
Level 2
 
Posts: 54
Joined: Thu Mar 24, 2011 9:36 am

Re: LMDE BREAKAGES - read here first - Update 13 may 2011

Postby zerozero on Sat May 14, 2011 12:17 pm

narendra.d,
you must do

Code: Select all
sudo apt-get update && sudo apt-get dist-upgrade


see after this if the issue is solved or not
zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - read here first - Update 13 may 2011

Postby narendra.d on Sat May 14, 2011 12:39 pm

zerozero wrote:narendra.d,
you must do

Code: Select all
sudo apt-get update && sudo apt-get dist-upgrade


see after this if the issue is solved or not


Actually did it the correct way:
Code: Select all
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade


The error log and broken package list is posted in previous post above.
narendra.d
Level 2
Level 2
 
Posts: 54
Joined: Thu Mar 24, 2011 9:36 am

Re: LMDE BREAKAGES - read here first - Update 13 may 2011

Postby zerozero on Sat May 14, 2011 1:33 pm

zerozero
Level 16
Level 16
 
Posts: 6467
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - read here first - Update 13 may 2011

Postby narendra.d on Sat May 14, 2011 9:09 pm

zerozero wrote:narendra.d are you running LMDE-xfce?


No, LMDE Gnome. If I do a sudo apt-get upgrade now I get this message about unmet dependencies. I think it is easy to fix, but I am nt an expert in this. Please advice.

Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libalgorithm-diff-xs-perl : Depends: perlapi-5.12.3
 libapt-pkg-perl : Depends: perl-base (>= 5.12.3-6) but 5.10.1-20 is installed
                   Depends: perlapi-5.12.3
 libcairo-perl : Depends: perlapi-5.12.3
 libdigest-sha1-perl : Depends: perlapi-5.12.3
 libglib-perl : Depends: perlapi-5.12.3
 libgtk2-perl : Depends: perlapi-5.12.3
 libhtml-parser-perl : Depends: perlapi-5.12.3
 liblist-moreutils-perl : Depends: perlapi-5.12.3
 libnet-dbus-perl : Depends: perlapi-5.12.3
 libpango-perl : Depends: perlapi-5.12.3
 libperl5.12 : Depends: perl-base (= 5.12.3-6) but 5.10.1-20 is installed
 libpurple0 : Depends: perl-base (>= 5.12.3-6) but 5.10.1-20 is installed
              Depends: perlapi-5.12.3
 libsub-name-perl : Depends: perlapi-5.12.3
 libtext-charwidth-perl : Depends: perl-base (>= 5.12.3-6) but 5.10.1-20 is installed
                          Depends: perlapi-5.12.3
 libuuid-perl : Depends: perl-base (>= 5.12.3-6) but 5.10.1-20 is installed
                Depends: perlapi-5.12.3
 perl : Depends: perl-base (= 5.12.3-6) but 5.10.1-20 is installed
 pidgin : Depends: perl-base (>= 5.12.3-6) but 5.10.1-20 is installed
          Depends: perlapi-5.12.3
N: Ignoring file 'opera.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
E: Unmet dependencies. Try using -f.
narendra.d
Level 2
Level 2
 
Posts: 54
Joined: Thu Mar 24, 2011 9:36 am

Re: LMDE BREAKAGES - read here first - Update 13 may 2011

Postby cecar on Sun May 15, 2011 4:35 am

X-Chat was removed during update. Not a big issue for me and i guess it can be installed again when the dependencies get fixed. It depends on libperl5.10 but that cant be installed.
cecar
Level 4
Level 4
 
Posts: 364
Joined: Tue Aug 24, 2010 2:47 am
Location: Stenungsund, Sweden

Re: LMDE BREAKAGES - read here first - Update 13 may 2011

Postby Oscar799 on Sun May 15, 2011 4:39 am

There is a fix for the Xchat problem posted here:-

viewtopic.php?f=47&p=422137#p422137
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8808
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: LDME breakages - Update 13th May 2011 - older Nvidia car

Postby hopimet on Sun May 15, 2011 6:13 am

john2 wrote:After updating on 13th May 2011, the PC booted to a black screen. The problem was that the Nvidia driver had been updated, but the latest ones don't work with some legacy cards (mine is a GeForce FX5200). The solution is to boot to a command line (as root), then do
Code: Select all
apt-get install nvidia-kernel-legacy-173xx-dkms

Put the package in 'Ignored packages' in MU, which should stop it being updated again.


Just as an information.
I had the same problem after a dist-upgrade that replaced the Nvidia 173 by the Nvidia 270. After re-installation of the 173 all worked fine again and I decided not to freeze this package update. The 2 or 3 following dist-upgrade didn't propose to remove the Nvidia 173 and to replace it with the 270 again.

Today the dist-upgrade has updated the nvdia-glx-legacy-173xx (and its dependencies) from the version 173.14.28 to 173.14.30. Works fine too.
hopimet
Level 1
Level 1
 
Posts: 22
Joined: Sat May 14, 2011 1:58 am

Re: LMDE BREAKAGES - read here first - Update 13 may 2011

Postby malligt on Sun May 15, 2011 1:35 pm

RE: x-chat

I'm confused as to how I am to proceed with fixing X-chat.

Are we supposed to wait for the Mint LMDE DEV Team to fix this in MU because I have no idea how to proceed or what Oscar777 is telling us to do here.

If someone has a simple step-by-step method to fix this broken X-chat, please instruct me....as I do not understand this:

"xchat is at http://packages.debian.org/wheezy/xchat and xchat-common is at http://packages.debian.org/wheezy/xchat-common. Select the cpu architecture for your machine at the bottom of those pages, download and then open a terminal, cd (change directory) to where you downloaded the two .deb files and do

Code: Select all
sudo dpkg -i xchat*deb



That should install the two packages and you should have a working xchat with all of your pre-existing customizations retained.

If anything here in this thread is not clear, or you want to discuss this more before taking any steps suggested here, install another irc client and go to the irc.spotchat.org server and /join #linuxmint-debian for live one-on-one discussion."

Thank you in advance.
Last edited by malligt on Mon May 16, 2011 8:14 am, edited 1 time in total.
malligt
Level 4
Level 4
 
Posts: 253
Joined: Sat Sep 11, 2010 12:58 pm

Re: LMDE BREAKAGES - read here first - Update 13 may 2011

Postby amina on Sun May 15, 2011 3:00 pm

Hi malligt,

the description basically sais that you should download the deb files with your browser from packages.debian.org.
Follow the links, scroll to the bottom of the page, choose your architecture (click on it's name) and then click on one of the links provided as mirrors. Then you get a normal download prompt and you can save the deb files.

From terminal, you can then install them using the dpkg -i nameofthedebfile command.
So cd to the directory you saved the deb files into, then use the given command
sudo dpkg -i xchat*deb
(* substitutes everything between "xchat" and "deb" so it will install both packages because both have this pattern in their filename).
amina
Level 3
Level 3
 
Posts: 140
Joined: Wed Mar 02, 2011 4:45 am

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 3 guests