GRUB seeing the wrong start-menu

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read this

GRUB seeing the wrong start-menu

Postby feffer on Fri Apr 29, 2011 4:09 pm

I'm using grub-pc to boot 3 OSes: win7, ubuntu and LMDE. The two linuxes were both installed with grub, ubuntu being the last one. This worked fine, everything booted and I added a custom menu to setup the boot order and I preferred. Again this worked fine for some weeks. A few days ago, the LMDE grub-start-menu began appearing at boot instead of the custom one I set up on ubuntu. Everything still boots, but this was not my preference or expectation.

To trouble-shoot this, I did grub-update on each system, and even an apt-get reinstall, but no change. I did notice that grub-pc on LMDE is ver 1.99 and the ubuntu ver is 1.98, but I don't understand enough about grub-pc to know if that matters. Any way to restore my original setup? Any idea why this happened?

thx,
feffer
feffer
Level 3
Level 3
 
Posts: 127
Joined: Mon Jul 07, 2008 7:49 pm

Linux Mint is funded by ads and donations.
 

Re: GRUB seeing the wrong start-menu

Postby DrHu on Fri Apr 29, 2011 4:20 pm

Any way to restore my original setup? Any idea why this happened?

Probably one of the Linux updates, or if you added an OS, and changed partition data..

Not if you didn't, when editing grub to make a custom version, saved the original grub with a new file name, such as grub.cfg_sav
    That is in order to restore what was there initially, you either have to have saved the original file (GRUB2, setup file), or you should just repeat your custom settings again..

http://www.howtogeek.com/howto/43471/ho ... -easy-way/
    something you might want to try out, customizer for grub..
    --not using the command line

Some GRUB2 information to peruse..
http://members.iinet.net/~herman546/p20 ... mands.html
User avatar
DrHu
Level 16
Level 16
 
Posts: 6283
Joined: Wed Jun 17, 2009 8:20 pm

Re: GRUB seeing the wrong start-menu

Postby feffer on Fri Apr 29, 2011 4:41 pm

hmmm, I think I have backups of everything, but I'm still puzzled. I think the grub confusion starts very early in the boot process. Grub used to immediately move to files on sdb1, ubuntu and show the menu configured there. Now it loads files on sbd3, LMDE and shows the menu configured there. All the configuration files are intact, grub is just pointing to a different place than before to start.

I never edit grub.cfg directly, of course, but still, something earlier in the process must be pointing to the grub.cfg on LMDE instead of ubuntu as before. I agree, it could have been caused by an update, but no OS has been added. I'm not sure how I could have inadvertently modified partition data either.

I greatly prefer understanding the process and manually modifying the configuration. And I thought I did, but this blind-sided me!

thx,
feffer
feffer
Level 3
Level 3
 
Posts: 127
Joined: Mon Jul 07, 2008 7:49 pm

Re: GRUB seeing the wrong start-menu

Postby zerozero on Fri Apr 29, 2011 7:39 pm

feffer,
LMDE just had in the last days a grub update (to v.rc1-13) that among other issues brought the one you are talking about (and i also mentioned here viewtopic.php?f=141&t=67502&start=340#p414121 )
User avatar
zerozero
Level 16
Level 16
 
Posts: 6435
Joined: Tue Jul 07, 2009 2:29 pm

Re: GRUB seeing the wrong start-menu

Postby lmintnewb on Fri Apr 29, 2011 7:41 pm

Nevermind mixed up stuff, lol and no delete option. Sure you'll get it sorted though OP. Ya doing better than a lot of people. As recent lmde updates seemed to have messed many folks grub up altogether. At least yours is still booting etc.
Last edited by lmintnewb on Fri Apr 29, 2011 7:48 pm, edited 3 times in total.
lmintnewb
Level 7
Level 7
 
Posts: 1574
Joined: Fri Apr 01, 2011 5:13 pm

Re: GRUB seeing the wrong start-menu

Postby CiaW on Fri Apr 29, 2011 7:42 pm

There was an update to LMDE's grub just a few days ago. When it updated, do you recall if it asked you where to update? Or did you originally let LMDE's grub install to the MBR and subsequently when Ubuntu installed it also installed to the MBR ? If LMDE originally had grub installed on the mbr, when it updated a few days ago it would update the grub on that location, not knowing that you had subsequently installed a different grub in the same place.

If you want to go back to using Ubuntu's grub, you'll probably want to make sure you have the current grub installed on the LMDE partition (grub-install /dev/sdax -- using the pertinent partition number in place of x) and then when you're booted to Ubuntu run the grub-install /dev/sda (or sdb -- as the case may be), with no partition number. That will then install, or re-install Ubuntu's grub to the MBR of that drive.
CiaW
Level 3
Level 3
 
Posts: 170
Joined: Fri Sep 10, 2010 11:39 am
Location: Spokane Wash, USA

Re: GRUB seeing the wrong start-menu

Postby Roken on Fri Apr 29, 2011 9:04 pm

Check grub.conf to make sure that it's using UUID's and not mount points. That should fix your custom grub problems one it points to the UUID.
Kernel Linux Tex 3.2.2-1 (64 bit) xfce , burg
Arch
ATI Radeon HD 4670, 1GB
OSS4
AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked)
8Gb RAM
Image
User avatar
Roken
Level 5
Level 5
 
Posts: 747
Joined: Fri Nov 19, 2010 4:55 pm
Location: Oldham, UK

Re: GRUB seeing the wrong start-menu

Postby feffer on Sat Apr 30, 2011 4:08 pm

OK, thx all. I do check the LMDE issues posts, but evidently not diligently enough :)

Probably I did choose "install everywhere" -- and should have just picked the mint partition. Since, I don't really have a problem other than getting an unexpected grub screen, I just went ahead and added a custom entry file in mint like the one I had in ubuntu (actually just copied it over) and updated grub.

I might try CiaW's suggestion later
If you want to go back to using Ubuntu's grub, you'll probably want to make sure you have the current grub installed on the LMDE partition (grub-install /dev/sdax -- using the pertinent partition number in place of x) and then when you're booted to Ubuntu run the grub-install /dev/sda (or sdb -- as the case may be), with no partition number. That will then install, or re-install Ubuntu's grub to the MBR of that drive.


thx,
feffer
feffer
Level 3
Level 3
 
Posts: 127
Joined: Mon Jul 07, 2008 7:49 pm

Re: GRUB seeing the wrong start-menu

Postby twa on Sun May 01, 2011 2:12 pm

feffer,
did U try with startupmanager ???
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread.
User avatar
twa
Level 4
Level 4
 
Posts: 231
Joined: Fri Sep 17, 2010 8:11 am
Location: Somewhere in the sky

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 3 guests