Activate Visual Effects?

Forums for the Fluxbox Edition
Forum rules
Before you post please read this

Activate Visual Effects?

Postby GNULinux10 on Thu Apr 01, 2010 12:36 pm

Hello,

I'm trying out Linux Mint 8 Fluxbox but I can't activate Normal or Extra visual effects which in turn means I can't run compiz. When I click on either normal or extra it starts searching for available drivers and then a message appears saying that desktop effects could not be enabled.

I have the Nvidia 185 driver installed and activated for sure. I've tried searching for a solution on the net and through these forums but I am drawing a blank here.
GNULinux10
Level 1
Level 1
 
Posts: 3
Joined: Thu Apr 01, 2010 12:27 pm

Linux Mint is funded by ads and donations.
 

Re: Activate Visual Effects?

Postby richyrich on Thu Apr 01, 2010 12:59 pm

Hi, and welcome ! :)

Two things,
first, install compiz-check from the Package Manager.
second, open a terminal, type inxi -G (enter), then compiz-check (enter), then highlight/copy/paste the entire output back here as a reply.

This will show your graphics hardware & installed drivers, and any errors with compiz, richy :)
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: Activate Visual Effects?

Postby Kendall on Thu Apr 01, 2010 5:03 pm

Compiz, like Fluxbox, is a window manager. Essentially turning on Compiz means turning off Fluxbox. I have to recommend avoiding this particular course of action for what should be obvious reasons. There are other ways to enable compositing and visual effects in Fluxbox, but they're kind of obscure. I suggest you start with xcompmgr.
User avatar
Kendall
Level 7
Level 7
 
Posts: 1580
Joined: Mon Nov 16, 2009 12:20 pm
Location: Asheville, NC, USA

Re: Activate Visual Effects?

Postby GNULinux10 on Fri Apr 02, 2010 11:34 am

Thanks for the replies,

This is the requested output:

Code: Select all
gnulinux10@CUSTOM-MACHINE ~ $ inxi -G
Graphics:  Card nVidia G73 [GeForce 7600 GT] X.Org 1.6.4 Res: 1440x900@50.0hz
           GLX Renderer GeForce 7600 GT/PCI/SSE2/3DNOW! GLX Version 2.1.2 NVIDIA 185.18.36
gnulinux10@CUSTOM-MACHINE ~ $ compiz-check

Gathering information about your system...

 Distribution:          Linux Mint 8
http://www.linuxmint.com/rel_helena_fluxbox.php
 Desktop environment:   Unknown
 Graphics chip:         nVidia Corporation G73 [GeForce 7600 GT] (rev a1)
 Driver in use:         nvidia
 Rendering method:      Nvidia

Checking if it's possible to run Compiz on your system...

 Checking for texture_from_pixmap...               [ OK ]
 Checking for non power of two support...          [ OK ]
 Checking for composite extension...               [ OK ]
 Checking for FBConfig...                          [ OK ]
 Checking for hardware/setup problems...           [ OK ]
GNULinux10
Level 1
Level 1
 
Posts: 3
Joined: Thu Apr 01, 2010 12:27 pm

Re: Activate Visual Effects?

Postby richyrich on Fri Apr 02, 2010 4:05 pm

Well, your graphics system is surely capable of running Compiz. But as Kendall pointed out, not in Fluxbox. Don't let that dishearten you, as you can really tweak this baby ! :D

Setting the Menu, panel & titlebar for transparency : (notice the alpha levels)

transparent-menu.jpg
transparent-menu.jpg (116.28 KiB) Viewed 8609 times
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: Activate Visual Effects?

Postby richyrich on Fri Apr 02, 2010 4:07 pm

Take notice of the Titlebar . . 3 Apps running in the same window ! and switch with just one click . . :D

titlebar-1.jpg
titlebar-1.jpg (83.92 KiB) Viewed 8610 times

titlebar-2.jpg
titlebar-2.jpg (99.6 KiB) Viewed 8610 times

titlebar-3.jpg
titlebar-3.jpg (106.7 KiB) Viewed 8610 times
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: Activate Visual Effects?

Postby GNULinux10 on Sat Apr 03, 2010 12:16 pm

Hi,

I've changed my alpha settings now, whats the name of your theme?

It looks pretty damn good to me.
GNULinux10
Level 1
Level 1
 
Posts: 3
Joined: Thu Apr 01, 2010 12:27 pm

Re: Activate Visual Effects?

Postby richyrich on Sat Apr 03, 2010 2:12 pm

In the Appearance settings I'm using the Murina Black theme with Glass Icons. The Fluxbox Style is called Noir .

Here's a couple of sites with themes / icons / styles, etc. for Fluxbox :)

http://box-look.org/index.php?xcontentm ... 3453e6503b

http://tenr.de/styles/

Edit: Oh, and the wallpaper is available in the Mint Artwork wallpapers ! :)
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: Activate Visual Effects?

Postby Bouchii on Thu May 17, 2012 12:49 am

Hi!
I´m having a similar problem, I installed Linux Mint 12, everything is doing fine but I can´t enable visual effects.
I used to have Linux Mint 7 and I never had a problem.

Help please!!!


jean-christophe@Teahupoo ~ $ inxi -G
Graphics: Card: nVidia C73 [GeForce 7100 / nForce 630i]
X.Org 1.10.4 drivers nvidia unloaded: fbdev,vesa,nouveau Resolution 1360x768@50.0hz
GLX Renderer GeForce 7100 / NVIDIA nForce 630i/PCI/SSE2 GLX Version 2.1.2 NVIDIA 173.14.30
jean-christophe@Teahupoo ~ $ compiz-check

Gathering information about your system...

Distribution: Linux Mint 12
http://www.linuxmint.com/rel_lisa.php
Desktop environment: GNOME
Graphics chip: nVidia Corporation C73 [GeForce 7100 / nForce 630i] (rev a2)
Driver in use: nouveau
Rendering method: Nvidia

Checking if it's possible to run Compiz on your system...

Checking for texture_from_pixmap... [ OK ]
Checking for non power of two support... [ OK ]
Checking for composite extension... [ OK ]
Checking for FBConfig... [ OK ]
Checking for hardware/setup problems... [WARN]

Something potential problematic has been detected with your setup:
Warning: Detected driver is not on the whitelist.

Would you like to know more? (Y/n) y

Your driver is not widely known to work with Compiz and thus may be
blacklisted on certain distributions.

You can skip this blacklist -- but keep in mind that you did so.
Do not complain if you encounter any problems with Compiz afterwards.

Do you want to skip blacklist checks by Compiz? (y/N) ^C
Bouchii
Level 1
Level 1
 
Posts: 2
Joined: Sun May 13, 2012 2:31 pm

Re: Activate Visual Effects?

Postby Bouchii on Fri May 18, 2012 7:17 pm

I chose to skip the black list, now I have this


jean-christophe@Teahupoo ~ $ compiz-check

Gathering information about your system...

Distribution: Linux Mint 12
http://www.linuxmint.com/rel_lisa.php
Desktop environment: GNOME
Graphics chip: nVidia Corporation C73 [GeForce 7100 / nForce 630i] (rev a2)
Driver in use: nouveau
Rendering method: Nvidia

Checking if it's possible to run Compiz on your system...

Checking for texture_from_pixmap... [ OK ]
Checking for non power of two support... [ OK ]
Checking for composite extension... [ OK ]
Checking for FBConfig... [ OK ]
Checking for hardware/setup problems... [ OK ]


But I can´t see any compiz effects....
Bouchii
Level 1
Level 1
 
Posts: 2
Joined: Sun May 13, 2012 2:31 pm

Re: Activate Visual Effects?

Postby agasthya on Sat Sep 29, 2012 11:20 pm

I started using linux mint 13 maya with gnome 3.4.1 recently. I downloaded a theme from one of the above mentioned links but I dont know how to get it installed in my system.I followed the steps but there was no ".themes" folder itself . I simply created one and extracted there but still the theme is not shown in the cinnamon settings. So please tell me how to install downloaded themes and icons..Do i have to logout and log in to restart the cinnamon??? please help.
agasthya
Level 1
Level 1
 
Posts: 4
Joined: Thu Sep 27, 2012 9:30 pm

Re: Activate Visual Effects?

Postby Pearleallay44 on Wed Nov 06, 2013 2:13 am

This post really opened my eyes. it is not only eye opening rather very beneficial for the people those who want to do something good in his life.
Pearleallay44
Level 1
Level 1
 
Posts: 1
Joined: Wed Nov 06, 2013 1:56 am

Linux Mint is funded by ads and donations.
 

Return to Fluxbox

Who is online

Users browsing this forum: No registered users and 3 guests