volume shortcut sort of solved

Forum rules
Before you post please read this

volume shortcut sort of solved

Postby paschalis.m on Sun Oct 05, 2008 4:58 pm

Hi,

is there any way to increase and decrease the volume using keyboard?
i tried through the xfce settings (keyboard->shortcuts..) but nothing works.
i want to use alt+pgup & alt+pgdown.
i'm using the latest edition (elyssa).

thanks.
paschalis.m
Level 1
Level 1
 
Posts: 8
Joined: Sun Oct 05, 2008 4:47 pm

Linux Mint is funded by ads and donations.
 

Re: volume shortcut

Postby Husse on Thu Oct 09, 2008 5:19 am

This is posted in the fluxbox section and you write
the xfce settings
so the question is fluxbox or xfce?
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: volume shortcut

Postby paschalis.m on Sun Oct 12, 2008 9:24 am

I'm asking about the fluxbox edition.
Besides fluxbox edition is a mix of fluxbox and xfce if i'm not wrong.
paschalis.m
Level 1
Level 1
 
Posts: 8
Joined: Sun Oct 05, 2008 4:47 pm

Re: volume shortcut

Postby Husse on Sun Oct 12, 2008 12:41 pm

Besides fluxbox edition is a mix of fluxbox and xfce if i'm not wrong.

Not really, but there are some xfce tools to make it more user friendly
This is a part of Mint/Ubuntu that I don't find quite user friendly
It's very hard to do some changes - I want to change the command that opens Tbird in main - but it is only possible to edit which keys to use, not which command (I want to use a special command)
Here in keyboard shortcuts it is possible to edit which application you want to use but not the key...
I only have fluxbox in Virtualbox which limits me a bit
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: volume shortcut

Postby shane on Fri Oct 24, 2008 4:49 pm

Hi,

If you are using Elyssa Fluxbox CE you could try upgrading the mintfb-default-settings package to the version that is in the final release. Then delete the ~/.fluxbox/startup file, log out and log back in... and you should have a volume control applet in the system tray.

If you specifically want to have the keyboard shortcuts, then you can configure the shortcuts in ~/.fluxbox/keys to run some amixer command... Check the amixer man page and this link to configure the shortcuts http://fluxbox-wiki.org/index.php?title ... _shortcuts
User avatar
shane
Level 6
Level 6
 
Posts: 1300
Joined: Sun Feb 25, 2007 11:15 pm

Re: volume shortcut

Postby Husse on Sat Oct 25, 2008 9:50 am

Thanks shane
Keyboard shortcuts is a section I'm not happy with - one of the few :)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: volume shortcut

Postby paschalis.m on Tue Oct 28, 2008 9:26 am

I tried with fluxbox shortcuts but still nothing.
anyway I'm using the volume icon on the panel to increase/decrease volume.
If anyone have found a solution please let me know.

excellent job guys. my favourite distro.
paschalis.m
Level 1
Level 1
 
Posts: 8
Joined: Sun Oct 05, 2008 4:47 pm

Re: volume shortcut

Postby beauvin on Fri Oct 31, 2008 11:53 am

Hello!

shane wrote:If you specifically want to have the keyboard shortcuts, then you can configure the shortcuts in ~/.fluxbox/keys to run some amixer command... Check the amixer man page and this link to configure the shortcuts http://fluxbox-wiki.org/index.php?title ... _shortcuts


I've set the following in ~/.fluxbox/keys as you said but it doesn't work although i've tested the commands in terminal am i doing something wrong?
Code: Select all
Mod1 KP_Up :ExecCommand amixer -q sset Master,0 5%+
Mod1 KP_Down :ExecCommand amixer -q sset Master,0 5%-


Please excuse my awfull english, main language is romanian :D
User avatar
beauvin
Level 2
Level 2
 
Posts: 51
Joined: Fri Oct 31, 2008 11:33 am
Location: Bucureşti, Romania

Re: volume shortcut sort of solved

Postby Brian96 on Tue Nov 11, 2008 6:13 pm

I am interested in this as well. Anybody get it solved? Specifically, I want the volume up, down, and mute multimedia keys on my Dell Latitude D600 to control the volume on my mixer. Works out of the box in Ubuntu 8.04 and Xubuntu 8.10 (can't remember if it worked in Mint proper or not).

I am new to Fluxbox, and because of issues like this, I have tended to stick with Gnome. But, if I can get this issue resolved without major headaches, I think that this could be my distro of choice for my laptop.

Thanks in advance.
Brian96
 

Linux Mint is funded by ads and donations.
 

Return to Others

Who is online

Users browsing this forum: No registered users and 1 guest