Startup/Shutdown sounds

Forum rules
Before you post please read this

Startup/Shutdown sounds

Postby rojodojo19 on Wed Nov 12, 2008 9:39 pm

Hi,
I've looked long and helplessly for a way to turn off the startup and shutdown sound in Linux Mint Fluxbox. I can't seem to find a sound configuration menu anywhere.
Can anyone help me turn them off?
Thx in advance
rojodojo19
 

Linux Mint is funded by ads and donations.
 

Re: Startup/Shutdown sounds

Postby satellite360 on Thu Nov 13, 2008 7:13 am

rojodojo19 wrote:Hi,
I've looked long and helplessly for a way to turn off the startup and shutdown sound in Linux Mint Fluxbox. I can't seem to find a sound configuration menu anywhere.
Can anyone help me turn them off?
Thx in advance

These are defined in your ~/.fluxbox/startup file but are in an area which you should be careful tinkering with. If you simply comment out the startup sound, for example, X will fail to restart. I guess you could try replacing the sound file with an alternative. Like I said though, be prepared for things to break! Hopefully someone else can be more helpful.
In the landscape of Spring there is neither
better nor worse.
The flowering branches grow naturally,
some long, some short.
satellite360
Level 1
Level 1
 
Posts: 8
Joined: Sun Nov 09, 2008 11:02 pm
Location: Beijing, China

Re: Startup/Shutdown sounds

Postby jbb on Wed Apr 15, 2009 11:19 pm

If you read the documentation on http://www.linuxmint.com/rel_felicia_fl ... atsnew.php you will see this:

Configuration options for Mint-FM2 are stored in the file ~/.mint-fm2/mint-fm2.conf. Here you can manually configure whether menu icons are enabled/disabled, the icon theme to be used for the menu and login/logout sounds to be used.
jbb
Level 1
Level 1
 
Posts: 19
Joined: Wed Apr 15, 2009 10:52 pm

Re: Startup/Shutdown sounds

Postby tawan on Wed Apr 15, 2009 11:54 pm

as per the wiki

open Home

Press CTRL+H to show hidden files

open .mint-fm2

open mint-fm2.conf

see how there are lines such as Login: /usr/share/sounds/mintfb-login.wav

you can carefully edit these lines or replace the sound /usr/share/sounds/mintfb-login.wav with a new sound of the same name


disable

Comment out these lines with a '#' or delete them completely
User avatar
tawan
Level 4
Level 4
 
Posts: 405
Joined: Thu Apr 03, 2008 2:45 am

Re: Startup/Shutdown sounds

Postby shane on Fri Apr 17, 2009 1:42 pm

Yes, that is the way to disable the sounds... sorry I didn't mention that explicitly in the wiki. I have just added that.
User avatar
shane
Level 6
Level 6
 
Posts: 1300
Joined: Sun Feb 25, 2007 11:15 pm

Re: Startup/Shutdown sounds

Postby jbaldwin on Tue Mar 02, 2010 9:32 am

so i found the login.wav but when trying to replace it with a wav i prefer i get the following error message"You don't have the right permissions to extract archives in the folder "file:///usr/share/sounds"
jbaldwin
Level 1
Level 1
 
Posts: 1
Joined: Fri Feb 26, 2010 4:36 pm

Re: Startup/Shutdown sounds

Postby shane on Tue Mar 02, 2010 9:49 am

Hi and welcome to our forums!

The proper way to change the login and logout sounds is described in the wiki. If there is a '#' at the start of the line for Login or Logout, remove it.

http://www.linuxmint.com/wiki/index.php ... figuration

P.S. in case you don't know, ~/.mint-fm2 is a hidden folder in your home directory. Open the file browser (Thunar) and hit Ctrl+H to show hidden directories.
User avatar
shane
Level 6
Level 6
 
Posts: 1300
Joined: Sun Feb 25, 2007 11:15 pm

Re: Startup/Shutdown sounds

Postby fluxalex on Tue Mar 02, 2010 11:11 am

I have exactly the opposite problem since there are no sounds at all. I went to see the mint-fm2.conf file and the lines were commented. I've never touched that i.e. it was installed this way. But now that I've removed the '#', there is still no login/logout sounds. I have here "ekiga" and "banshee" running with no sound problems. So I'm also wondering if this could be related to my still unresolved "logout/login" problems, since it has been stated that
If you simply comment out the startup sound, for example, X will fail to restart.
So what can I do about that, besides removing the '#'...
fluxalex
Level 1
Level 1
 
Posts: 25
Joined: Fri Feb 26, 2010 3:56 pm
Location: Silves, Portugal

Re: Startup/Shutdown sounds

Postby shane on Tue Mar 02, 2010 11:30 am

@fluxalex

The default login/logout sounds have been changed since the old release. Replace the settings in mint-fm2.conf with this:

Code: Select all
Login: /usr/share/sounds/linuxmint-login.wav

Logout: /usr/share/sounds/linuxmint-logout.wav


Or alternatively you can put the full path to your preferred sounds. Supported formats are voc, wav, raw or au.

If this does not work, try running this command

Code: Select all
/usr/lib/linuxmint/mint-fm2/sound login


That should give you the login sound. If that doesn't work, post back here.
User avatar
shane
Level 6
Level 6
 
Posts: 1300
Joined: Sun Feb 25, 2007 11:15 pm

Re: Startup/Shutdown sounds

Postby fluxalex on Tue Mar 02, 2010 1:10 pm

I've changed the paths and when logging out there is some sound although it seems not to be played completely but cut in the middle. Executing the command plays the sound perfectly, but logging in, there is still no sound at all.
fluxalex
Level 1
Level 1
 
Posts: 25
Joined: Fri Feb 26, 2010 3:56 pm
Location: Silves, Portugal

Re: Startup/Shutdown sounds

Postby shane on Tue Mar 02, 2010 1:21 pm

My bad... I forgot to mention that you should add that command to the Fluxbox startup file with the other apps that are started at login. Read the file and you will see the section where you can add it. The Fluxbox startup is ~/.fluxbox/startup. Add the command where you feel like in that section and add a '&' at the end of it... like the other commands in that section.
User avatar
shane
Level 6
Level 6
 
Posts: 1300
Joined: Sun Feb 25, 2007 11:15 pm

Re: Startup/Shutdown sounds

Postby fluxalex on Tue Mar 02, 2010 1:44 pm

What is the mintwelcome-launcher doing? I've added the command before this, but I guess the sound is supposed to be part of the "welcome message".
fluxalex
Level 1
Level 1
 
Posts: 25
Joined: Fri Feb 26, 2010 3:56 pm
Location: Silves, Portugal

Re: Startup/Shutdown sounds

Postby Kendall on Tue Mar 02, 2010 1:49 pm

mintwelcome-launcher runs the dialog box that shows up immediately after you install the distro, and it has nothing to do with system sounds.
User avatar
Kendall
Level 7
Level 7
 
Posts: 1580
Joined: Mon Nov 16, 2009 12:20 pm
Location: Asheville, NC, USA

Re: Startup/Shutdown sounds

Postby fluxalex on Tue Mar 02, 2010 2:08 pm

Ohh I remember now :wink: Now I have the "login/logout" sounds working, but it is still that with the "vesa" driver I cannot login after logout, i.e I have to reboot in order to be able to login again. It simply hangs, but after having played the login sound which is the last command in "startup", besides "wbar" and "fusesmb" which I'm running privately :wink:
fluxalex
Level 1
Level 1
 
Posts: 25
Joined: Fri Feb 26, 2010 3:56 pm
Location: Silves, Portugal

Re: Startup/Shutdown sounds

Postby d00med on Sun Nov 28, 2010 8:27 pm

The default login sound is now /usr/share/sounds/LinuxMint/desktop-login.ogg
d00med
Level 4
Level 4
 
Posts: 332
Joined: Fri Nov 26, 2010 9:55 am

Re: Startup/Shutdown sounds

Postby daktari81 on Wed Dec 01, 2010 5:44 pm

For anyone who is trying to flat disable Linux Mint 10's startup sound, uncheck GNOME Login Sound under Startup Applications in the Control Center on the left side of the Menu popup at the bottom left hand corner of the screen. This is in plain newbie language for anyone who needs the breakdown. :roll: lol
daktari81
Level 1
Level 1
 
Posts: 1
Joined: Wed Dec 01, 2010 5:38 pm

Linux Mint is funded by ads and donations.
 

Return to Others

Who is online

Users browsing this forum: No registered users and 1 guest