sound muted on every startup

Forum rules
Before you post please read this

Re: sound muted on every startup

Postby Kendall on Fri Mar 12, 2010 1:13 pm

When I get time I'll do a clean install and start working updates one by one. I keep my system well updated, and I still haven't experienced this yet. Is everyone installing the kernel updates? This is one area I don't know about as I'm currently using the 2.6.34 RC1 kernel instead of the recommended 2.6.31-20.
User avatar
Kendall
Level 7
Level 7
 
Posts: 1580
Joined: Mon Nov 16, 2009 12:20 pm
Location: Asheville, NC, USA

Linux Mint is funded by ads and donations.
 

Re: sound muted on every startup

Postby richyrich on Fri Mar 12, 2010 1:29 pm

I think this is when it started for me. From my history :
Code: Select all
Commit Log for Mon Jan 25 19:08:18 2010


Upgraded the following packages:
decibel-audio-player (1.00-2) to 1.00-2mint1
libcairo2 (1.8.8-2ubuntu1) to 1.8.8-2ubuntu1.1
libpulse0 (1:0.9.19-0ubuntu4) to 1:0.9.19-0ubuntu4.1
mint-fluxbox-default-settings (2.10) to 2.11
mint-info-fluxbox (8.0.4) to 8.0.5
slim (1.3.1-0mint16) to 1.3.1-0mint17
User avatar
richyrich
Level 13
Level 13
 
Posts: 4635
Joined: Mon May 04, 2009 8:31 pm

Re: sound muted on every startup

Postby Mr_Shifty on Fri Mar 12, 2010 6:00 pm

Kendall wrote:I installed Gwibber and found it to be terribly unstable so I promptly removed it afterwards. I did check the sound and it seems that (as mentioned) Gwibber does not seem to be the cause of any sound issues on my end.


I discovered the same instability and promptly removed it from my Mint Fluxbox setup, but it seems rock solid on Mint LXDE RC1 (go figure), and I'm actually using it on a daily basis. I'm guessing like everyone else here is, that it's an update. The timing was just too convenient after I'd installed that list of apps, which had me thinking it was possible that it was one or more of them.

How are you guys installing Swiftfox? If you don't mind me asking.


The same way rgrwtrs is... I downloaded the installer shell script from the Get Swiftfox site and ran it with a sudo from the command line.
User avatar
Mr_Shifty
Level 2
Level 2
 
Posts: 52
Joined: Thu Feb 18, 2010 8:44 pm
Location: Minnesota

Re: sound muted on every startup

Postby Mazhar on Sat Mar 13, 2010 4:10 am

Update:
Last night I booted my linux mint and found: sound is ok (not muted). I did not install or change anything in the last few days. How this problem is solved automatically? strange! :?
Image
User avatar
Mazhar
Level 1
Level 1
 
Posts: 28
Joined: Sun Feb 21, 2010 3:54 am
Location: Bangladesh

Re: sound muted on every startup

Postby Gerard on Sun Mar 14, 2010 7:43 am

Thanks for the solution for the sound muting at startup.

Only one remaining thing, the decibel audio player only shows a scrambled screen, does anybody have an idea how to solve that?

Regards,
Gerard
Gerard
Level 1
Level 1
 
Posts: 12
Joined: Sat Jan 27, 2007 7:13 am

Re: sound muted on every startup

Postby Kendall on Sun Mar 14, 2010 7:22 pm

Gerard wrote:Only one remaining thing, the decibel audio player only shows a scrambled screen, does anybody have an idea how to solve that?

I haven't seen any issues with Decibel, could you post a screenshot.

You may also consider dropping Decibel for another music player, such as Exaile.
User avatar
Kendall
Level 7
Level 7
 
Posts: 1580
Joined: Mon Nov 16, 2009 12:20 pm
Location: Asheville, NC, USA

Re: sound muted on every startup

Postby Gerard on Mon Mar 15, 2010 5:01 am

I did install already an alternative music player, that's easy.
When I get home I will post a screenshot of decibel, basically a black window filled with purple mesh.

What I also noticed is that the volume button on the bar appears to have no effect on the audio volume, but when you use it, there is a small gray pop up window with rounded corners on the top right of the screen. Setting the audio volume appears to work only in the config screen.

Don't take it as a complaint, as I really like this version and it gave an old celeron from 99 its life back.
Gerard
Level 1
Level 1
 
Posts: 12
Joined: Sat Jan 27, 2007 7:13 am

Re: sound muted on every startup

Postby willi on Tue Mar 16, 2010 2:44 pm

rgrwtrs wrote:Had the same problem, what worked for me was to comment out line in the /etc/init.d/alsa-utils file:
# mute_and_zero_levels

mine looked like this
# $1 <control>
# $CARDOPT
# mute_and_zero_level()
{
{ [ "$1" ] && [ "$CARDOPT" ] ; } || bugout
amixer $CARDOPT -q set "$1" "0%" mute 2>&1 | filter_amixer_output || :
return 0



Hello everybody. I do not understand what you did to fix the problem. I have this problem since installing fluxbox on my lappi so I thought it was normal. But it's really a pain in the a.. to unmute it manually. Unluckyly I do not understand what you mean by "comment out line". I dont know what i have to change in this file. Mine exactly looks like what we see in your quote. It would be nice if anybody can post how the file has to look after modification.
Thanks a lot in advance
Willi
willi
Level 1
Level 1
 
Posts: 14
Joined: Thu Feb 18, 2010 5:59 am

Re: sound muted on every startup

Postby remoulder on Tue Mar 16, 2010 3:46 pm

Kendall this was a known bug in karmic, see https://bugs.launchpad.net/ubuntu/+source/alsa-utils/+bug/352732, but seems to have been fixed in alsa 1.0.22.1. Not sure which version is in later mint releases.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: sound muted on every startup

Postby rgrwtrs on Tue Mar 16, 2010 9:15 pm

willi wrote:
rgrwtrs wrote:Had the same problem, what worked for me was to comment out line in the /etc/init.d/alsa-utils file:
# mute_and_zero_levels

mine looked like this
# $1 <control>
# $CARDOPT
# mute_and_zero_level()
{
{ [ "$1" ] && [ "$CARDOPT" ] ; } || bugout
amixer $CARDOPT -q set "$1" "0%" mute 2>&1 | filter_amixer_output || :
return 0



Hello everybody. I do not understand what you did to fix the problem. I have this problem since installing fluxbox on my lappi so I thought it was normal. But it's really a pain in the a.. to unmute it manually. Unluckyly I do not understand what you mean by "comment out line". I dont know what i have to change in this file. Mine exactly looks like what we see in your quote. It would be nice if anybody can post how the file has to look after modification.
Thanks a lot in advance
Willi


Commenting out a line means putting an # in front of the line. By commenting out the line, it is not read. If there is already an # in front of the line, then this would not be causing your problem.

My original looked like this:

# $1 <control>
# $CARDOPT
mute_and_zero_level()
{
{ [ "$1" ] && [ "$CARDOPT" ] ; } || bugout
amixer $CARDOPT -q set "$1" "0%" mute 2>&1 | filter_amixer_output || :
return 0


and I added an # in front of the line "mute_and_zero_level() to make it look like:

# $1 <control>
# $CARDOPT
# mute_and_zero_level()
{
{ [ "$1" ] && [ "$CARDOPT" ] ; } || bugout
amixer $CARDOPT -q set "$1" "0%" mute 2>&1 | filter_amixer_output || :
return 0

Hope that helps
rgrwtrs
Level 1
Level 1
 
Posts: 34
Joined: Sat Mar 06, 2010 4:54 pm

Re: sound muted on every startup

Postby willi on Wed Mar 17, 2010 4:33 am

Thanks for explaining. It did fix the problem!!! :D Wow great support here. Respect!
willi
Level 1
Level 1
 
Posts: 14
Joined: Thu Feb 18, 2010 5:59 am

Re: sound muted on every startup

Postby Gerard on Wed Mar 17, 2010 4:14 pm

Sorry, it took a bit longer than expected before I could post again, but the screenshot of Decibel audio player is included.
In the screen shot you can also see the small pop-up window (right top) appears when you try to change the volume with the scroll wheel of the mouse (there is no change in volume level though).

Anybody who knows what could be the cause and preferrably the solution :D

regards,
Gerard
Attachments
screenshot_1.jpg
Screenshot of Decibel audio player
screenshot_1.jpg (258.33 KiB) Viewed 1652 times
Gerard
Level 1
Level 1
 
Posts: 12
Joined: Sat Jan 27, 2007 7:13 am

Linux Mint is funded by ads and donations.
 
Previous

Return to Others

Who is online

Users browsing this forum: No registered users and 1 guest