Turn off compositing?

Forum rules
Before you post please read this

Turn off compositing?

Postby vsluiter on Fri Mar 05, 2010 5:04 pm

Hello all,
I tried to install Eagle5.7, but the windows are totally illegible, see attached screenshot. Someone suggested here that I should turn compositing off in my xorg.conf.
I already found out that Linux Mint Fluxbox doesn't come with xorg.conf by default.
I tried the following:
Code: Select all
victor@victor-laptop X11 $ sudo X -configure

Fatal server error:
Server is already active for display 0
   If this server is no longer running, remove /tmp/.X0-lock
   and start again.

I searched for this on the forum but was only able to find something on xrandr, which doesn't help me here.
second try:
Code: Select all
sudo dpkg-reconfigure xserver-xorg

Didn't give me anything, I had hoped to find a xorg.conf in /etc/X11 ...

Please help me on this one!
Attachments
screenshot.jpg
screenshot.jpg (110.73 KiB) Viewed 1971 times
vsluiter
Level 1
Level 1
 
Posts: 4
Joined: Wed Jan 13, 2010 5:03 pm

Linux Mint is funded by ads and donations.
 

Re: Turn off compositing?

Postby Kendall on Fri Mar 05, 2010 5:20 pm

Fluxbox has no native support for compositing so naturally it's disabled by default. I'll take a look at this "Eagle" thing and see if I can figure anything out.
User avatar
Kendall
Level 7
Level 7
 
Posts: 1580
Joined: Mon Nov 16, 2009 12:20 pm
Location: Asheville, NC, USA

Re: Turn off compositing?

Postby Kendall on Fri Mar 05, 2010 5:28 pm

Where did you install Eagle from? I just tried version 5.4.0 from the Ubuntu repo and it works flawlessly. I'm going to take a look at the 5.7.0 version from the Debian repo and see how well that works.
User avatar
Kendall
Level 7
Level 7
 
Posts: 1580
Joined: Mon Nov 16, 2009 12:20 pm
Location: Asheville, NC, USA

Re: Turn off compositing?

Postby Kendall on Fri Mar 05, 2010 5:37 pm

Version 5.7.0 from the Debian repo works perfectly:

Image
User avatar
Kendall
Level 7
Level 7
 
Posts: 1580
Joined: Mon Nov 16, 2009 12:20 pm
Location: Asheville, NC, USA

Re: Turn off compositing?

Postby vsluiter on Mon Mar 15, 2010 4:07 pm

Hello Kendall,

Thanks for checking out this problem; I installed from the installer I downloaded from the CadSoft website. Since I posted this, I found several other events that show the same erronous gray patchwork. One of these events is when I plug in my wireless network USB stick, and it finds a network to connect to. Also, I discovered that it happens when installing LTSpice (from linear.com) using wine (from repository).
Could it be that this has something to do with my graphics card? Here's my LSPCI:
Code: Select all
victor@victor-laptop ~ $ lspci
00:00.0 Host bridge: ATI Technologies Inc RS200/RS200M AGP Bridge [IGP 340M] (rev 02)
00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 340M]
00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:03.0 Modem: ALi Corporation M5457 AC'97 Modem Controller
00:04.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device (rev 02)
00:06.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:07.0 ISA bridge: ALi Corporation M1533/M1535/M1543 PCI to ISA Bridge [Aladdin IV/V/V+]
00:0b.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5901 100Base-TX (rev 01)
00:0c.0 CardBus bridge: Texas Instruments PCI1510 PC card Cardbus Controller
00:0f.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon IGP 330M/340M/350M
victor@victor-laptop ~ $


Greetings, Victor
Attachments
2010-03-15-210417_1024x768_scrot.png
2010-03-15-210417_1024x768_scrot.png (95.91 KiB) Viewed 1912 times
vsluiter
Level 1
Level 1
 
Posts: 4
Joined: Wed Jan 13, 2010 5:03 pm

Re: Turn off compositing?

Postby Kendall on Mon Mar 15, 2010 6:18 pm

It's possible, but I kind of suck when it comes to debugging graphics issues. I'll take a look at it when I get some free time and let you know if I find anything.
User avatar
Kendall
Level 7
Level 7
 
Posts: 1580
Joined: Mon Nov 16, 2009 12:20 pm
Location: Asheville, NC, USA

Re: Turn off compositing?

Postby vsluiter on Tue Mar 16, 2010 3:55 pm

OK, thank you... if you need any input, please let me know...
vsluiter
Level 1
Level 1
 
Posts: 4
Joined: Wed Jan 13, 2010 5:03 pm

Linux Mint is funded by ads and donations.
 

Return to Others

Who is online

Users browsing this forum: No registered users and 1 guest