(solved) Trouble getting Scribus to run...

Forum rules
Before you post please read this

(solved) Trouble getting Scribus to run...

Postby beansandjeans on Wed Apr 14, 2010 2:11 am

I just installed Scribus, but it won't run. I'm not sure, but I think it's maybe a Fluxbox issue.

I've installed it twice now - first with Mintinstall, then uninstalled it and tried with Synaptic. Both with the same results. It stays "Changes applied." It says "successfully applied all changes. You can close the window now."

But then when I click to show the "details" of how the installation went, I notice that it says "debconf: unable to initialize frontend: Gnome"

So I'm thinking maybe this is the problem...

Anyhow, Scribus shows up in my system menu under "graphics," but when I click to run it nothing happens :-( I can't see any processes from Scribus on either of my task managers either. And the hard drive doesn't make the sound it usually makes when a program starts up, so I'm pretty sure nothing's running. I've tried re-starting (just in case that might be needed) but still the same.

So does anybody know what I would need to do to get Scribus to actually run? Do any of you have Scribus running on Fluxbox? Does it need Gnome or some substitute as a "frontend"?...

I'm pretty much still a newbie - both with Fluxbox in particular and with Mint and Linux in general. Any help would be much appreciated!

Thanks :-)
Last edited by beansandjeans on Wed Apr 14, 2010 12:31 pm, edited 1 time in total.
beansandjeans
Level 3
Level 3
 
Posts: 116
Joined: Tue Feb 23, 2010 3:12 pm

Linux Mint is funded by ads and donations.
 

Re: Trouble getting Scribus to run...

Postby shane on Wed Apr 14, 2010 3:44 am

The problem almost surely lies in the menu entry that is generated for Fluxbox. Please post the contents of the file ~/.mint-fm2/submenus/Graphics.

[edit] I went ahead and installed it myself... change the line

Code: Select all
[exec] (Scribus (Stable)) {scribus} <> #/usr/share/applications/scribus.desktop


to

Code: Select all
[exec] (Scribus) {scribus} <> #/usr/share/applications/scribus.desktop


Those brackets confuse Fluxbox.
User avatar
shane
Level 6
Level 6
 
Posts: 1300
Joined: Sun Feb 25, 2007 11:15 pm

Working now :-)

Postby beansandjeans on Wed Apr 14, 2010 12:30 pm

Hi Shane,

Thanks for finding that fix! It's running just fine now :-)

I was thinking it was something complicated, but it turned out to be something real simple. Guess it's often that way!

Should I contact Scribus about that? Wonder if they'd change the naming so it installs better on Fluxbox....Or maybe that sorta thing is fairly common...
beansandjeans
Level 3
Level 3
 
Posts: 116
Joined: Tue Feb 23, 2010 3:12 pm

Re: (solved) Trouble getting Scribus to run...

Postby shane on Thu Apr 15, 2010 2:25 am

No need to report it. It is more a Fluxbox issue. In Fluxbox, normally you have to make the menu by hand... the Mint FB edition tries to make one for you, but as you see it is not perfect. If starting something from the menu does not work, check out the menu files first.
User avatar
shane
Level 6
Level 6
 
Posts: 1300
Joined: Sun Feb 25, 2007 11:15 pm


Return to Others

Who is online

Users browsing this forum: No registered users and 1 guest