Fluxbox lm9 rc volume key not working + unvoluntary log out

Forum rules
Before you post please read how to get help

Fluxbox lm9 rc volume key not working + unvoluntary log out

Postby wiksten on Tue Aug 24, 2010 3:15 pm

Hi!

I'm trying out the new fluxbox rc, I really like it so far and i've only encountered two problems so far. One of them beeing that i can't adjust the volume with my laptops volume key. I ran xev and i got this post

KeyRelease event, serial 34, synthetic NO, window 0x4400001,
root 0xfd, subw 0x0, time 40988399, (695,550), root:(1228,790),
state 0x0, keycode 123 (keysym 0x1008ff13, XF86AudioRaiseVolume), same_screen YES,
XLookupString gives 0 bytes:
XFilterEvent returns: False

according to that the key is usually used to raise volume, but it doesn't do the trick. It worked alright in Helena though.

The other problem i have i don't know how to adress. When i close the fullscreen of a youtube video (flash working out of the box, well done) lm9 fluxbox ce just logs out, why is this? It happened with one other app, don't remember the one.

I hope someone can help :)
wiksten
Level 1
Level 1
 
Posts: 9
Joined: Tue Feb 16, 2010 3:57 pm
Location: Uppsala

Linux Mint is funded by ads and donations.
 

Re: Fluxbox lm9 rc volume key not working + unvoluntary log

Postby shane on Tue Aug 24, 2010 4:16 pm

This is how you configure the keyboard shortcuts in Fluxbox http://fluxbox-wiki.org/index.php/Keyboard_shortcuts

About the logging out, most probably Flash is causing Fluxbox to crash. There are some known issues between the two. Does this happen when there is no Flash?
User avatar
shane
Level 6
Level 6
 
Posts: 1300
Joined: Sun Feb 25, 2007 11:15 pm

Re: Fluxbox lm9 rc volume key not working + unvoluntary log

Postby anderigs on Mon Aug 30, 2010 10:34 am

Hi
I just stumbled across this thread and it looks similar to my problem in:
viewtopic.php?f=142&t=54000&p=311172#p311172
So if somebody cleverer than me wants to try reproduce the problem I think now it is quite simple if you have an external monitor:
1. start firefox
2. open flash video e.g. youtube
3. press your "activate external monitor" Fn key (mine is Fn-F5)
and then you should either have a logout or simple fluxbox crash - I have seen both.
So far this works (or rather doesn't work) every time...
Cheers,
andE
anderigs
Level 2
Level 2
 
Posts: 50
Joined: Mon Dec 28, 2009 5:54 am

Re: Fluxbox lm9 rc volume key not working + unvoluntary log

Postby wiksten on Mon Aug 30, 2010 5:31 pm

Is it possible to get fluxbox to react on the keycode from xev? I have an ´fn´ key on my keyboard that is normally used for sounds but i don't know what that is called in fluxbox vocabulary :)

I think i only had it in flash. If it's in flash i guess you guys will be working on it until the main edition comes out, i was counting on having some problems using the rc.
wiksten
Level 1
Level 1
 
Posts: 9
Joined: Tue Feb 16, 2010 3:57 pm
Location: Uppsala

Re: Fluxbox lm9 rc volume key not working + unvoluntary log

Postby Terminator on Mon Sep 06, 2010 12:22 am

The involuntary log out can sometimes be triggered by editing the ~/.fluxbox/startup file which points me to conclude perhaps there is some linux mint specific daemon polling that file? Then upon leaving the xscreensaver going I have had the log out problem happen as well. I read on the update notes there was a problem with ctrl alt backspace yet that works properly for relogging but is it spontaneously being triggered? I would like to note to readers that fluxbox linux mint is now using lxdm perhaps that could be causing some issues, perhaps some using the lxde desktop might comment? Another note about flash video full screen exit (esc key) crashing to login manager it seems to be repeatable with any browser.

On another note alt 2 a key combination I use often with many programs keeps triggering a desktop switch while I'm in middle of doing something. So I will be playing around with key bindings as well.
Terminator
Level 1
Level 1
 
Posts: 1
Joined: Mon Sep 06, 2010 12:06 am

Re: Fluxbox lm9 rc volume key not working + unvoluntary log

Postby wiksten on Sun Sep 19, 2010 8:53 am

I think i solved the audiokey problem by installing banshee, putting in some banshee commands for the usual mplayer tasks and trough some keybindings for the amixer, the play, next, stop etcetera are not systemwide, but then again i mainly want this feature for playing my music.

I put this line into my keys file:

#Banshee
None XF86AudioPlay :ExecCommand banshee --play
None XF86AudioStop :ExecCommand banshee --stop
None XF86AudioNext :ExecCommand banshee --play
None XF86AudioPrev :ExecCommand banshee --restart-or-previous
None XF86AudioLowerVolume :Exec amixer sset Master,0 5%-
None XF86AudioRaiseVolume :Exec amixer sset Master,0 5%+
wiksten
Level 1
Level 1
 
Posts: 9
Joined: Tue Feb 16, 2010 3:57 pm
Location: Uppsala


Return to Others

Who is online

Users browsing this forum: No registered users and 0 guests