Tint2 Transparency Problem [Solved]

Forum rules
Before you post please read this

Tint2 Transparency Problem [Solved]

Postby dlodlo on Fri Oct 15, 2010 5:11 am

Hello,

I have a standard Linux Mint 9 Fluxbox installation (no additional software installed) with all the latest updates in an Asus Eee PC 701.
The problem I've been having since the start is that some times (and there really seems to be no regular pattern or stable period of occurance), when I boot up my tint panel , tint (which also has the standard "factory" configuration) comes up with the wrong area of the underlying desktop displayed as its background. This means that instead of displaying what's directly underneath it, giving a sense of transparency, it takes the top center area of my desktop and uses it as a background for its panel area and buttons - as if it was placed there. Everything goes back to normal for a few more boots when I reset the background image for my desktop.
What's this? Does anybody else have it? And is there a way to fix it?

I'll post some images as soon as it happens again.

Thanks in advance.
Last edited by dlodlo on Sat Oct 16, 2010 10:30 am, edited 1 time in total.
dlodlo
Level 1
Level 1
 
Posts: 15
Joined: Mon Sep 06, 2010 4:43 pm

Linux Mint is funded by ads and donations.
 

Tint2 Transparency Problem

Postby dlodlo on Fri Oct 15, 2010 8:28 am

Here
Messed up:
wrong.png
wrong.png (77.76 KiB) Viewed 2637 times


Correct:
right.png
right.png (81.87 KiB) Viewed 2637 times
dlodlo
Level 1
Level 1
 
Posts: 15
Joined: Mon Sep 06, 2010 4:43 pm

Re: Tint2 Transparency Problem

Postby thil7 on Fri Oct 15, 2010 10:18 am

looks like tint2 is too speed. try to slow tint2's startup.
(sleep 2s && tint2) &
thil7
Level 1
Level 1
 
Posts: 3
Joined: Fri Oct 15, 2010 10:14 am

Re: Tint2 Transparency Problem

Postby dlodlo on Fri Oct 15, 2010 10:58 am

Here's a part of my ~/.Fluxbox/startup script:
Code: Select all
mintinput1 &
xfce4-power-manager &
tint2 -c ~/.tint2rc &
mintwelcome-launcher &


All I have to do is this?:
Code: Select all
mintinput1 &
xfce4-power-manager &
sleep 2 && tint2 -c ~/.tint2rc &
mintwelcome-launcher &
dlodlo
Level 1
Level 1
 
Posts: 15
Joined: Mon Sep 06, 2010 4:43 pm

Re: Tint2 Transparency Problem

Postby thil7 on Sat Oct 16, 2010 9:48 am

it looks good to me. but try the line in a terminal to check the syntax.
thil7
Level 1
Level 1
 
Posts: 3
Joined: Fri Oct 15, 2010 10:14 am

Re: Tint2 Transparency Problem

Postby dlodlo on Sat Oct 16, 2010 10:24 am

I tried it and there seems to be no problem.
It's been quite a few boot-ups now and tint2 comes up ok every time.
It seems to have worked. Thanks thil7 :mrgreen:
dlodlo
Level 1
Level 1
 
Posts: 15
Joined: Mon Sep 06, 2010 4:43 pm


Return to Others

Who is online

Users browsing this forum: No registered users and 0 guests