[solved] trying to install gnucash 2.4.2

Forum rules
Before you post please read this

[solved] trying to install gnucash 2.4.2

Postby Kent88 on Mon Feb 21, 2011 11:24 pm

As you see from the subject, I'm trying to install gnucash 2.4.2 on a VM of Mint 9 fluxbox.

I downloaded the tarball, moved it over to /usr/lib/ where I understand these sorts of things are supposed to go, decompressed it to make /usr/lib/gnucash-2.4.2/ cd into that directory and ran "sudo ./configure" (without the quotes) because I think (though I'm not sure) that is how one is supposed to install it.

I keep getting an error about GLIB is not installed, but checking synaptic it looks like I have "libglib2.0-0" version 2.24.1 installed.

The exact error reads as follows (this is output following the ./configure command and the script preforming a bunch of other checks) :

checking for GLIB - version >= 2.12.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** GLIB >= 2.12 is required to build Gnucash; please make sure you have the
*** development headers installed. The latest version of GLIB is
*** always available at ftp://ftp.gnome.org/pub/gnome/sources/glib/.



I'd like to attach the 'config.log' document but the forum doesn't want me to upload a .log or .txt attachment, and it is a long file so I didn't want to copy it into the main body of this text. If that file is needed, let me know how I should attach the file. Anything else let me know.
Last edited by Kent88 on Sat Mar 05, 2011 2:15 am, edited 1 time in total.
Kent88
Level 1
Level 1
 
Posts: 36
Joined: Wed Dec 22, 2010 1:57 am

Linux Mint is funded by ads and donations.
 

Re: trying to install gnucash 2.4.2

Postby unexistance on Mon Feb 21, 2011 11:43 pm

Hi,

0. Any reason not using gnucash in the repo?

1. We suggest you use an external PPA to get all latest software, as compiling should be regarded as a LAST resort.
https://launchpad.net/~gnucash/+archive/ppa

Regards,
:: Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved ::
unexistance
Level 5
Level 5
 
Posts: 646
Joined: Tue Aug 05, 2008 12:28 am
Location: Malaysia

Re: trying to install gnucash 2.4.2

Postby Kent88 on Tue Feb 22, 2011 12:44 am

I have my reasons for not wanting to use gnucash 2.2.9, mainly because 2.3 has matured into 2.4, they're calling it stable so why get stuck with 'old' software when I don't know how well it will upgrade. I think I'll wait for one more bug fixing release before I move it from my VM and onto my main system.

Being a transplant from Mepis I was unaware of the PPA repos. How well do these packages integrate with the system? Have they been known to cause dependency issues? If so is there anything I can keep an eye on to keep things running smoothly?

Thanks for the tip.
Kent88
Level 1
Level 1
 
Posts: 36
Joined: Wed Dec 22, 2010 1:57 am

Re: trying to install gnucash 2.4.2

Postby unexistance on Tue Feb 22, 2011 2:01 am

Hi,

Generally dependencies will be taken care of by the package manager, so you just need to add the repo, then refresh package list then install ...

As for stability, so far I'm using a few PPA (not gnucash), no PPA-caused issues crops up

Regards,
:: Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved ::
unexistance
Level 5
Level 5
 
Posts: 646
Joined: Tue Aug 05, 2008 12:28 am
Location: Malaysia


Return to Others

Who is online

Users browsing this forum: No registered users and 2 guests