Note: I'm only posting this for info purposes and not recommending anyone jump out and upgrade. Perhaps some more experienced than I can determine whether it's needed or not.
ZDNet and Ubuntu recently announced that more vulnerabilities have been found in Ubuntu's latest kernels covering versions 6.06 LTS to 9.10 (Ubuntu/Kubuntu/Xubuntu/Edubuntu) which should include Mint versions also I believe? In my case, my latest kernel is 2.6.31-20.57 in which case I would need to upgrade to 2.6.31-20.58 if I read things right.
Here's the link to the ZDNet article and another to the referenced Ubuntu announcement. The latter lists the Ubuntu versions and the various vulnerable kernel versions along with the required updates under each one:
I found that the updates are available under "Level 5" in mintUpdate.