Strange volume control behavior

Forum rules
Before you post please read how to get help

Strange volume control behavior

Postby freechus9 on Fri Apr 27, 2012 1:23 pm

I recently installed LInux Mint 12 LXDE, and everything works peachy. However, I am having a strange issue with volume control.

Whenever I use my volume buttons, raise and lower work fine. But if I use the mute button, the volume mutes fine, and is reflected both in volume control and in alsamixer. However, when I try to unmute, alsamixer shows that it is unmuting, but volume control remains muted and I cannot get any sound. I have to manually click the icon and uncheck mute.

To test what was happening, I also issued the commands to raise/lower the volume.

When I use:

amixer sset Master 5%+
or
amixer sset Master 5%-

volume control and alsamixer both respond correctly, whether it is muted or not.

When I use:

amixer sset Master toggle
or
amixer sset Master unmute

The alsamixer responds properly, but volume control does not, hence sound cannot get unmuted from these commands.

Thanks for your help in advance.
freechus9
Level 1
Level 1
 
Posts: 2
Joined: Fri Apr 27, 2012 1:18 pm

Linux Mint is funded by ads and donations.
 

Re: Strange volume control behavior

Postby Van.Vreeborg on Sat Apr 28, 2012 5:58 am

Hi freechus9,

I can confirm this behavior, but have no solution yet.
I am on Mint 12 (lisa) LXDE, using an apple keyboard.

Some things I thought while the problem occured:
1) that it only concerned the multimedia keys on my apple keyboard.
2) that it only concerned sound of my command line mplayer.

When watching movies using command line mplayer I would accidentally press mute instead of volume-down. I then had to unmute using the desktop taskbar(?) sound icon. After having to do this a number of times, mplayer muted permanently. But other movie players did still give sound.

I then tried to fix this, ... the wrong way,... and broke all sound on my system. (installed mplayer2, but that broke my 10bit video decoding, which i cannot live without.. :), then tried to install ffmpeg > 0.7, without knowing what i was doing. After that the system never gave sound again... LOL ) Finally, reinstalled MintLXDE.

However, after reading your post I think it may be a more general problem than just the mplayer-apple-keyboard interaction.

I will get back if I do find a good solution. In the meantime I am a little afraid to experiment too much, as I broke my mplayer (and system) by doing so last week.

What I do now is use the normal "m" key to mute my mplayer, instead of using the multimedia mute button on the apple keyboard. Sofar, "m" has always unmuted for me...

Hope this helped a little,

Cheers
Van Vreeborg
Van.Vreeborg
Level 1
Level 1
 
Posts: 3
Joined: Sat Apr 28, 2012 4:01 am

Re: Strange volume control behavior

Postby freechus9 on Sat Apr 28, 2012 5:50 pm

I believe the multimedia keys are just a layer before the real issue, since they just issue the amixer commands I listed above. I think that this is a problem with PulseAudio, but I am not l337 enough to figure it out. Hopefully someone else can!
freechus9
Level 1
Level 1
 
Posts: 2
Joined: Fri Apr 27, 2012 1:18 pm

Re: Strange volume control behavior

Postby kingofnerds on Wed May 02, 2012 1:28 pm

I have a laptop with a volume wheel on the front of it, and I experience the same problem, when I accidentally put the volume wheel all the way down, I have to use the volume icon or mixer to un-mute the sound. Otherwise, the volume controls seem to work just fine.
kingofnerds
Level 1
Level 1
 
Posts: 1
Joined: Tue May 11, 2010 12:52 am

Re: Strange volume control behavior

Postby Jamesc359 on Sun May 06, 2012 2:03 pm

I have this same problem with my generic Acer KB. I don't believe the problem lies in either the keyboard or the keybinds, but instead lies with amixer or something else. I say this because when I hit the mute key or use amixer sset Master toggle it mutes Master, PCM, Surround, Center and LFE. But upon repeating it-it only unmutes Master. The taskbar app correctly unmutes them all though.
“Gosh, you've... really got some nice toys here.”
User avatar
Jamesc359
Level 3
Level 3
 
Posts: 134
Joined: Sun May 06, 2012 1:42 pm

Re: Strange volume control behavior

Postby melbo on Sun May 06, 2012 2:55 pm

I'm sure you've tried:
Settings > Options > Volume Control Behavior > Strange > Off

Sorry, couldn't resist ;)
melbo
Level 2
Level 2
 
Posts: 67
Joined: Fri Jan 04, 2008 11:57 pm
Location: WA, USA

Re: Strange volume control behavior

Postby Jamesc359 on Sun May 06, 2012 3:03 pm

This is a hack, but it works for me.

Place this in a file somewhere (in your path perhaps.) I put mine in ~/bin/togglemute
Code: Select all
#!/bin/sh

amixer -q sset PCM unmute
amixer -q sset Surround unmute
amixer -q sset Center unmute
amixer -q sset LFE unmute
amixer -q sset Master toggle


If you want you can chmod, but you don't have to.
Code: Select all
chmod a+x ~/bin/togglemute


Open ~/.config/openbox/mintlxde-rc.xml
Comment out line 192 and just after that line insert
Code: Select all
          <command>sh ~/bin/togglemute</command>

It should look something like this when you're done.
Code: Select all
    <keybind key="XF86AudioMute">
      <action name="Execute">
<!--          <command>amixer -q sset Master toggle</command> -->
          <command>sh ~/bin/togglemute</command>
      </action>
    </keybind>


Save and reboot. :-)
“Gosh, you've... really got some nice toys here.”
User avatar
Jamesc359
Level 3
Level 3
 
Posts: 134
Joined: Sun May 06, 2012 1:42 pm

Re: Strange volume control behavior

Postby gari126 on Mon Dec 03, 2012 5:51 pm

Hi,
I had the same problem running MATE desktop on a Linux Mint Debian Edition (201204) ...
"Volume up" action was not able to unmute the volume
I realised that the problem was with Pulse audio but the package mate-media-gstreamer and mate-settings-deamon-gstreamer where installed by default ...
I installed instead the mate-media-pulse and mate-settings-deamon-pulse (that unisntal mate-media-gstreamer and mate-settings-deamon-gstreamer) and tadam ... "Volume up" action was able to unmute the volume again !
I hope this will also work for you !
gari126
Level 1
Level 1
 
Posts: 2
Joined: Mon Dec 03, 2012 5:38 pm

Linux Mint is funded by ads and donations.
 

Return to Others

Who is online

Users browsing this forum: No registered users and 1 guest