LXDE Session Can't Start!!!

Forum rules
Before you post please read this

LXDE Session Can't Start!!!

Postby MaR1oC on Fri May 20, 2011 1:55 pm

I'm new to the community. My country's mint forum administrators have forbidden new members. So I registered here ! :)
I have a Toshiba NB200 (no1 in my signature) netbook and I installed Linux Mint LXDE a few hours ago. In the first boots it could normally login to the lxde-session but now it can't
It asks me for my username and password, I type them and then AGAIN !!! The login screen appears again !!!

I also tried booting into command-line envirorment and typing the
Code: Select all
startx
and
Code: Select all
startlxde
commands but nothing

Please Help!!! :idea:
1. Toshiba NB200 with Linux Mint LXDE/Ubuntu 11..04/WindowsXP OEM
CPU: Intel Atom 1,66GHZ | 1GB Ram | HDA Intel Sound Card
MaR1oC
Level 1
Level 1
 
Posts: 2
Joined: Fri May 20, 2011 1:28 pm

Linux Mint is funded by ads and donations.
 

Re: LXDE Session Can't Start!!!

Postby secipolla on Sat May 21, 2011 12:29 pm

Hit ctrl+alt+f1 to go to the console #1
login as root
run: nano /etc/xdg/lxsession/LXDE/autostart
edit the file and put a ! in front of the pcmanfm --desktop line
Hit F3 to save and ctrl+x to exit
Hit ctrl+alt+f7 (or ctrl+alt+f8, ctrl+alt+f9...) to go back to gdm and login again.


The above will disable pcmanfm desktop. If it works then you edit ~/.config/pcmanfm/LXDE/pcmanfm.conf and change
"wallpaper_mode=0"
for
"wallpaper_mode=3"
and put an image path like
"wallpaper=/usr/share/lxde/wallpapers/lxde_blue.jpg"
If it was empty.

Then you can remove the ! from the pcmanfm line in /etc/xdg/lxsession/LXDE/autostart and thus enable pcmanfm desktop again.
But you can't use only a background colour or else it will crash again (if you want to use a plain colour as a background create an image for that).
secipolla
Level 4
Level 4
 
Posts: 356
Joined: Sun Sep 05, 2010 5:19 pm

LXDE Session Can't Start!!!

Postby MaR1oC on Sun May 22, 2011 4:01 am

I reinstalled and I have no such issues so far!! :) However, thanks for your help ;)
1. Toshiba NB200 with Linux Mint LXDE/Ubuntu 11..04/WindowsXP OEM
CPU: Intel Atom 1,66GHZ | 1GB Ram | HDA Intel Sound Card
MaR1oC
Level 1
Level 1
 
Posts: 2
Joined: Fri May 20, 2011 1:28 pm

Re: LXDE Session Can't Start!!!

Postby JedMeister on Thu Jun 30, 2011 8:17 am

Thanks secipolla. I had this same problem (it occurred tonight following a restart after installing some updates).

I sort of followed your instructions although the autostart file was in a slightly different place to what you suggested. It was /etc/xdg/lxsession/LXDE/autostart
I found the line you mentioned and edited it, but somehow I managed to delete the whole contents... Doh! I'm still not really sure how I did it because I've used nano before and never managed to do that.
So needless to say I think I've borked it...
JedMeister
Level 1
Level 1
 
Posts: 1
Joined: Thu Jun 30, 2011 4:45 am

Re: LXDE Session Can't Start!!!

Postby Rail Balco on Fri Dec 21, 2012 2:28 pm

I have similar problem. I tried secipolas way but it didn't work. Only messed my GUI so I had to put it back
Rail Balco
Level 1
Level 1
 
Posts: 12
Joined: Tue May 29, 2012 6:12 am


Return to Others

Who is online

Users browsing this forum: No registered users and 3 guests