Right click on LXDE desktop

Forum rules
Before you post please read this

Right click on LXDE desktop

Postby AlfonP on Wed Mar 14, 2012 5:19 am

Hello all,

sorry if this question has already been asked. I have been searching through the net and can't find a suitable answer, so I have decided to place it here to see if I'm lucky.

I have just installed Linux Mint 12 on my netbook to test it and I love it. It's fast, reliable and saves a lot of energy (my battery life has moved from 30 minutes on windows XP, 45 on Meego to 1 hour and a half on Mint, awsome).

However, I'm having a problem (not major) with PCManFM and OpenBox. Somehow I switched the context menu (right-click on the desktop) from PCManFM to OpenBox and I can't find out how to switch it back again.

Browsing on the net I have found that the place to switch it is in the Preferences menu of PCManFM where it says "Desktop". However, that "Desktop" section is not shown in the preferences menu of the PCManFM version included in Mint.

Does anyone have the answer?

Thanks a lot!!!
AlfonP
Level 1
Level 1
 
Posts: 1
Joined: Wed Mar 14, 2012 4:59 am

Linux Mint is funded by ads and donations.
 

Re: Right click on LXDE desktop

Postby nunol on Wed Mar 14, 2012 7:27 am

Did you check if the "/etc/xdg/lxsession/Mint-LXDE/autostart" file has the "@pcmanfm --desktop" line?
User avatar
nunol
Level 9
Level 9
 
Posts: 2664
Joined: Sun Mar 06, 2011 9:25 pm
Location: Portugal

Re: Right click on LXDE desktop

Postby alxstewart on Mon Apr 16, 2012 11:59 pm

It may be a little late, but just had this same problem today. I found the fix below here;

http://wiki.lxde.org/en/LXDE:Questions# ... s_go.3F.29

Right click on the desktop renders a weird menu (aka where did my desktop icons go?)

You have (by accident?) chosen to show the right click menu from the window manager (or vice versa as you'll see). This is a feature in PCManFM.
Open the Preference dialog (click preferences in the edit menu)
Pick the desktop tab
Mark (or unmark) the checkbox next to "Show menus provided by WM when desktop is clicked" or, if this checkbox is not present, tick "Manage the desktop and show file icons"
Press OK and you should be done.
If the desktop tab is not there, try running the following command from the terminal to open the desktop preferences dialog directly:
pcmanfm --desktop-pref
alxstewart
Level 1
Level 1
 
Posts: 2
Joined: Mon Apr 16, 2012 9:54 pm

Re: Right click on LXDE desktop

Postby rouage on Fri May 25, 2012 10:12 am

Thank you alxsteward !
Your answer helped me a lot !
rouage
Level 1
Level 1
 
Posts: 1
Joined: Fri May 25, 2012 10:01 am


Return to Others

Who is online

Users browsing this forum: No registered users and 2 guests