Internet Connectivity Lost After Update

Questions about cabled networking
Forum rules
Before you post please read this

Internet Connectivity Lost After Update

Postby mgnapp on Tue Jun 12, 2012 2:17 am

Hello all.

I am posting my issue here because this happened during installation and have not been able to resolve it..... yet...... I just installed Mint 13 and during the install I lost my internet. I have a realtek 8111/8186 ethernet card and it seems that the system sees it but says "wired - cable unplugged". I am currently tethering my phone to get wireless through a USB connection and have no problems. The ethernet cable is not the problem. I suspect a driver issue. From all of the posts that I have dug through over the last 48 hours, and commands I have input in the terminal I have had no luck. Here is a little information, but I am at your mercy, so anything else you would need, please let me know! I am a newb, but I don't give up.

sudo ifconfig -a

eth0 Link encap:Ethernet HWaddr 00:30:67:5f:8a:4c
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:40 Base address:0x4000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:3366 errors:0 dropped:0 overruns:0 frame:0
TX packets:3366 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:349556 (349.5 KB) TX bytes:349556 (349.5 KB)

usb0 Link encap:Ethernet HWaddr 02:0c:64:93:03:4e
inet addr:192.168.42.147 Bcast:192.168.42.255 Mask:255.255.255.0
inet6 addr: fe80::c:64ff:fe93:34e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:8889 errors:0 dropped:0 overruns:0 frame:0
TX packets:7028 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:10283827 (10.2 MB) TX bytes:1241704 (1.2 MB)

Any and all help is much appreciated!!!
mgnapp
Level 1
Level 1
 
Posts: 8
Joined: Fri Nov 05, 2010 11:01 am

Linux Mint is funded by ads and donations.
 

Re: Internet Connectivity Lost After Update

Postby mgnapp on Mon Jun 18, 2012 2:22 pm

I see lots of others with this very same issue. Is this being worked on or am I just not asking the right questions to get this resolved?
mgnapp
Level 1
Level 1
 
Posts: 8
Joined: Fri Nov 05, 2010 11:01 am

Re: Internet Connectivity Lost After Update

Postby oobetimer on Mon Jun 18, 2012 2:49 pm

mgnapp wrote:I see lots of others with this very same issue. Is this being worked on or am I just not asking the right questions to get this resolved?


DNS nameservers can be missing. Command cat /etc/resolv.conf tells if they are there. I have write-protected mine .. :wink:

Command nm-tool tells more info.
Attachments
Saunalahden nameservers.png
Saunalahden nameservers.png (12.08 KiB) Viewed 2120 times
User avatar
oobetimer
Level 7
Level 7
 
Posts: 1889
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle

Re: Internet Connectivity Lost After Update

Postby merlinof2 on Wed Jun 20, 2012 2:11 pm

had a similar problem. Mint 13 was working perfectly until a kernel upgrade. then... all went to crap... was using the "remove Network.Manager.state" routine but that was a pain and didn't always work on first try.

nanowire (a forum user) suggested using Synaptic Package Manager to remove Network.Manager and replacing it with Wicd. That solved my issues completely. Might be worth a look.
merlinof2
Level 1
Level 1
 
Posts: 5
Joined: Sat Jun 02, 2012 11:24 pm

Re: Internet Connectivity Lost After Update

Postby mgnapp on Fri Jun 22, 2012 4:21 am

gnapps@gnapps ~ $ cat /etc/resolv.conf
nameserver 8.8.8.8
nameserver 8.8.8.8
gnapps@gnapps ~ $ nm-tool

NetworkManager Tool

State: disconnected

- Device: usb0 -----------------------------------------------------------------
Type: Wired
Driver: rndis_host
State: disconnected
Default: no
HW Address: F2:D4:5D:CC:D2:39

Capabilities:
Carrier Detect: yes

Wired Properties
Carrier: on


- Device: eth0 -----------------------------------------------------------------
Type: Wired
Driver: r8169
State: unavailable
Default: no
HW Address: 00:30:67:5F:8A:4C

Capabilities:
Carrier Detect: yes

Wired Properties
Carrier: off
mgnapp
Level 1
Level 1
 
Posts: 8
Joined: Fri Nov 05, 2010 11:01 am

Re: Internet Connectivity Lost After Update

Postby oobetimer on Fri Jun 22, 2012 12:16 pm

User avatar
oobetimer
Level 7
Level 7
 
Posts: 1889
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle

Re: Internet Connectivity Lost After Update

Postby mgnapp on Sat Jun 23, 2012 11:12 am



I followed this fix, but no success. Here are the results:

gnapps@gnapps ~ $ sudo gedit/etc/resolv.conf
[sudo] password for gnapps:
sudo: gedit/etc/resolv.conf: command not found
gnapps@gnapps ~ $ sudo gedit /etc/resolv.com

(gedit:2591): GLib-GIO-WARNING **: Missing callback called fullpath = /root/.local/share/recently-used.xbel

What's next? And in case I haven't mentioned, I appreciate everybody's input so far. Just a big learning adventure. When I sleep at night, I dream about this terminal as though I am stuck in the Matrix!
mgnapp
Level 1
Level 1
 
Posts: 8
Joined: Fri Nov 05, 2010 11:01 am

Re: Internet Connectivity Lost After Update

Postby oobetimer on Fri Jul 06, 2012 5:45 am

It is a bug caused by new net controlling system. Network has to restart using command sudo service network-manager start and if you want not to start every time via command line, make a script.
gksudo pluma /etc/rc.local

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
service network-manager start
exit 0


Save, quit and reboot.
User avatar
oobetimer
Level 7
Level 7
 
Posts: 1889
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle

Re: Internet Connectivity Lost After Update

Postby mgnapp on Sun Jul 08, 2012 2:20 am

[quote="oobetimer"]It is a bug caused by new net controlling system. Network has to restart using command sudo service network-manager start and if you want not to start every time via command line, make a script.

I just get this:

gnapps@gnapps ~ $ sudo service network-manager start
[sudo] password for gnapps:
start: Job is already running: network-manager
gnapps@gnapps ~ $ sudo service network-manager start
start: Job is already running: network-manager
gnapps@gnapps ~ $

I can't figure this out!
mgnapp
Level 1
Level 1
 
Posts: 8
Joined: Fri Nov 05, 2010 11:01 am

Linux Mint is funded by ads and donations.
 

Return to Ethernet

Who is online

Users browsing this forum: No registered users and 3 guests