can't share file with windows systems over lan [solved]

Questions about cabled networking
Forum rules
Before you post please read this

can't share file with windows systems over lan [solved]

Postby opensam on Thu Nov 08, 2012 4:41 am

i live in a hostel in which each room is connected by ethernet lan. i m using mint 11 32bit while most other people use windows 7.
the problem is while i can access the files shared by these windows users, the file which i share on my system can't be accessed by others.
any help would be appreciated..
Last edited by opensam on Fri Nov 09, 2012 2:32 am, edited 1 time in total.
opensam
Level 1
Level 1
 
Posts: 15
Joined: Wed Oct 24, 2012 9:37 am

Linux Mint is funded by ads and donations.
 

Re: can't share file with windows systems over lan

Postby altair4 on Thu Nov 08, 2012 7:30 am

Please go through the checklist here:
HowTo: Samba Browsing Problems Checklist: viewtopic.php?f=42&t=88146&start=0

It might be something as simple as your host name length. After going through the checklist if you still have problems post the output of the following commands:
Code: Select all
testparm -s

Code: Select all
net usershare info --long
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5986
Joined: Tue Feb 03, 2009 10:27 am

Re: can't share file with windows systems over lan

Postby opensam on Thu Nov 08, 2012 10:05 am

altair4 wrote:Please go through the checklist here:
HowTo: Samba Browsing Problems Checklist: viewtopic.php?f=42&t=88146&start=0

It might be something as simple as your host name length. After going through the checklist if you still have problems post the output of the following commands:
Code: Select all
testparm -s

Code: Select all
net usershare info --long


i went thru viewtopic.php?f=42&t=88146&start=0 and i've managed to show the name of the folders ,which i wanna share, over the lan. Still they can't be accessed over the lan as windows is asking for network username & password.Anyways i ran the personal file sharing preferences app and it said on it's screen under 'share files over the network' "this feature can't b enabled coz the required packages are not installed on ur system".

Here is the o/p for testparm -s
"Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[printers]"
Processing section "[print$]"
Loaded services file OK.
Server role: ROLE_STANDALONE
[global]
netbios name = OPNSM-N4010
server string = %h server (Samba, LinuxMint)
map to guest = Bad User
obey pam restrictions = Yes
pam password change = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
unix password sync = Yes
syslog = 0
log file = /var/log/samba/log.%m
max log size = 1000
name resolve order = bcast host lmhosts wins
dns proxy = No
usershare allow guests = Yes
panic action = /usr/share/samba/panic-action %d

[printers]
comment = All Printers
path = /var/spool/samba
create mask = 0700
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/printers"

for net usershare info --long
"[images]
path=/media/linux/linux downloads/images
comment=
usershare_acl=Everyone:R,Unix User\opensam:F,
guest_ok=n"

thanx for ur reply
opensam
Level 1
Level 1
 
Posts: 15
Joined: Wed Oct 24, 2012 9:37 am

Re: can't share file with windows systems over lan

Postby altair4 on Thu Nov 08, 2012 11:03 am

Let me answer the easy one first:
Anyways i ran the personal file sharing preferences app and it said on it's screen under 'share files over the network' "this feature can't b enabled coz the required packages are not installed on ur system".

You need Samba to share folders with Windows systems. Personal File Sharing is not Samba it's something else and it's something that really doesn't work with Windows so it's best to just ignore it.
Still they can't be accessed over the lan as windows is asking for network username & password

You have a Samba share that requires authentication for it to be accessed:
[images]
path=/media/linux/linux downloads/images
comment=
usershare_acl=Everyone:R,Unix User\opensam:F,
guest_ok=n

So you have 2 choices depending on what you want to do:

[1] Convert the share to allow anyone to access it.

Go back into Nautilus > right click the folder > Sharing Options > select "Guest Access"

[2] Leave it as a private share but add samba users that will be allowed access.

It's 2 steps: Create a local Mint user and then add him to the samba password database. See "Scenario 1" or "Scenario 2" in this HowTo for the steps:
Simple File Sharing in Mint: viewtopic.php?f=42&t=23169
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5986
Joined: Tue Feb 03, 2009 10:27 am

Re: can't share file with windows systems over lan

Postby opensam on Thu Nov 08, 2012 12:38 pm

altair4 wrote:Let me answer the easy one first:
Anyways i ran the personal file sharing preferences app and it said on it's screen under 'share files over the network' "this feature can't b enabled coz the required packages are not installed on ur system".

You need Samba to share folders with Windows systems. Personal File Sharing is not Samba it's something else and it's something that really doesn't work with Windows so it's best to just ignore it.
Still they can't be accessed over the lan as windows is asking for network username & password

You have a Samba share that requires authentication for it to be accessed:
[images]
path=/media/linux/linux downloads/images
comment=
usershare_acl=Everyone:R,Unix User\opensam:F,
guest_ok=n

So you have 2 choices depending on what you want to do:

[1] Convert the share to allow anyone to access it.

Go back into Nautilus > right click the folder > Sharing Options > select "Guest Access"

[2] Leave it as a private share but add samba users that will be allowed access.

It's 2 steps: Create a local Mint user and then add him to the samba password database. See "Scenario 1" or "Scenario 2" in this HowTo for the steps:
Simple File Sharing in Mint: viewtopic.php?f=42&t=23169




well i m able to share folders within the home folder but nothing else.
anyways thanx a ton for ur help.
opensam
Level 1
Level 1
 
Posts: 15
Joined: Wed Oct 24, 2012 9:37 am

Re: can't share file with windows systems over lan

Postby altair4 on Thu Nov 08, 2012 3:27 pm

If you are able to share some folders and not others then it may not be a Samba sharing issue it may be a Linux permissions issue. For example if /media/linux/linux downloads/images is pointing to the mountpoint of an external NTFS formatted USB device then the only user that can access that folder is you regardless of what you tell Samba to do.

There is a way around this issue and that's to add a line to /etc/samba/smb.conf - right under the workgroup line:
Code: Select all
force user = altair

Change altair to you Mint login user name.

Then restart samba:
Code: Select all
sudo service smbd restart


The remote guest or authenticated user will be converted to your user name for these Samba shares so if you have access to the folder so does he.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5986
Joined: Tue Feb 03, 2009 10:27 am

Re: can't share file with windows systems over lan

Postby opensam on Fri Nov 09, 2012 2:28 am

altair4 wrote:If you are able to share some folders and not others then it may not be a Samba sharing issue it may be a Linux permissions issue. For example if /media/linux/linux downloads/images is pointing to the mountpoint of an external NTFS formatted USB device then the only user that can access that folder is you regardless of what you tell Samba to do.

There is a way around this issue and that's to add a line to /etc/samba/smb.conf - right under the workgroup line:
Code: Select all
force user = altair

Change altair to you Mint login user name.

Then restart samba:
Code: Select all
sudo service smbd restart


The remote guest or authenticated user will be converted to your user name for these Samba shares so if you have access to the folder so does he.


i replied to u yesterday ,i guess it didn't get posted. Anyways i downloaded a gui for samba and thru it i can share anything now. So problem solved.
again thanx a lot.
cheers!!
opensam
Level 1
Level 1
 
Posts: 15
Joined: Wed Oct 24, 2012 9:37 am

Linux Mint is funded by ads and donations.
 

Return to Ethernet

Who is online

Users browsing this forum: No registered users and 5 guests