eth0 connection cyles on/off after upgrade to Mint 14 Mate

Questions about cabled networking
Forum rules
Before you post please read this

eth0 connection cyles on/off after upgrade to Mint 14 Mate

Postby ruddy on Fri Nov 30, 2012 12:57 am

The card was working fine before I did the upgrade, which went very smoothly. Now it disconnects and reconnects about every 20 seconds. How do I fix this? Here are some details:

nm-tool output:
State: connected (global)

- Device: eth0 [Wired connection 1] -------------------------------------------
Type: Wired
Driver: r8169
State: connected
Default: yes
HW Address: 00:14:D1:1C:8A:11

Capabilities:
Carrier Detect: yes
Speed: 1000 Mb/s

Wired Properties
Carrier: on

IPv4 Settings:
Address: 192.29.15.3
Prefix: 24 (255.255.255.0)
Gateway: 192.29.15.1

DNS: 192.29.15.1

lshw output:
network
description: Ethernet interface
product: RTL8169 PCI Gigabit Ethernet Controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 2
bus info: pci@0000:03:02.0
logical name: eth0
version: 10
serial: 00:14:d1:1c:8a:11
size: 1Gbit/s
capacity: 1Gbit/s
width: 32 bits
clock: 66MHz
capabilities: pm bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.29.15.3 latency=64 link=yes maxlatency=64 mingnt=32 multicast=yes port=MII speed=1Gbit/s
resources: irq:18 ioport:dc00(size=256) memory:dfbfef00-dfbfefff memory:dfc00000-dfc1ffff
ruddy
Level 1
Level 1
 
Posts: 9
Joined: Wed Nov 09, 2011 5:55 pm

Linux Mint is funded by ads and donations.
 

Re: eth0 connection cyles on/off after upgrade to Mint 14 Ma

Postby Gord on Sun Dec 02, 2012 8:07 pm

ruddy wrote:IPv4 Settings:
Address: 192.29.15.3
Prefix: 24 (255.255.255.0)
Gateway: 192.29.15.1

That's odd. The numbers look convincing except that according to...

http://whois.arin.net/rest/net/NET-192-29-0-0-1/pft

...that IP address has belonged to Sun Microsystems for the last 25 years. You don't happen to work for them, do you?

If not, then under...

Control Center > Network Connections

...on the "Wired" tab, select "Wired connection 1" and then click the "Edit..." button. What do the settings on the "IPv4" tab look like?
Gord
Level 1
Level 1
 
Posts: 46
Joined: Fri Nov 23, 2012 5:14 pm
Location: Canada

Re: eth0 connection cyles on/off after upgrade to Mint 14 Ma

Postby ruddy on Sun Dec 02, 2012 8:34 pm

I dummied the actual IP address, because that was not a part of my problem.

I gave up and did a fresh install, and everything is fine now. I should have known better than to try an upgrade in the first place, because Mint does not seem to be quite as robust as Ubuntu. Ubuntu upgrades have always worked for me, but I abandoned ship when the Unity desktop appeared.
ruddy
Level 1
Level 1
 
Posts: 9
Joined: Wed Nov 09, 2011 5:55 pm

Re: eth0 connection cyles on/off after upgrade to Mint 14 Ma

Postby dmon66 on Wed Dec 05, 2012 3:29 pm

I had the drop connection problem, but I think mine was driver related as I have a i650 nforce motherboard.
Looking into the problem with ethtool didn't help matters in that everything looked fine. My motherboard uses a Marvel chipset 88e1111 for eth0.
After much searching, I was able to find an appropriate driver in the Marvel website.
(I did get a version warning when installing the driver), however, my repair boiled down to:

1. stopping network-manager
2. installing the appropriate driver
3. redefining the interface in: /etc/network/interfaces
4. restarting the network

I had a few minor issues to deal with that were related to my specific install, but all in all, I now have a working, managed, eth0.

I sincerely hope this helps others. Most people don't know how to edit /etc/network/interfaces to define an eth0 interface.
I've found it should look similar to this:

Code: Select all
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp


This is pretty basic information in linux, but because most users are "casual" users, they lack this information.

Hope this helps others, enjoy!

dmon66
dmon66
Level 1
Level 1
 
Posts: 1
Joined: Wed Dec 05, 2012 3:12 pm

Re: eth0 connection cyles on/off after upgrade to Mint 14 Ma

Postby billmc on Sat Jan 05, 2013 2:10 am

I gave up and did a fresh install, and everything is fine now.


I thought I read on Mint's site, that they recomend to NOT do an upgrade. If you want to go to a new version they recomend always doing a fresh install.
billmc
Level 1
Level 1
 
Posts: 40
Joined: Sat Dec 29, 2012 7:22 pm


Return to Ethernet

Who is online

Users browsing this forum: No registered users and 2 guests