Connection Succeeds, Can Ping/SSH/Wget (some), still broke

Questions about cabled networking
Forum rules
Before you post please read how to get help

Connection Succeeds, Can Ping/SSH/Wget (some), still broke

Postby fozzle on Wed Jan 09, 2013 1:34 am

I'm having trouble using my wired ethernet connection, well, sort of. I'm able to use it with Windows on the same PC, so the cable is fine. In fact, I'm even able to "connect" using Mint (or at least it thinks it is).

With the ethernet connection I've found that I can ssh. Ping works for every site. Wget works for google's robots.txt, but never completes for facebook or ubuntuforums.org (connects and resolves, no response). So that kind of rules out DNS screw ups yea?

Here's the kicker. Trying to access any page other than google in any browser times out. IRC doesn't work either.

I'm using wireless at the moment. I've tried installing wicd to see if it'd fix anything, but no dice. Odd eh? Anyone have any other ideas? I'd much like to use my wired connection.

Running Mint 14 Cinnamon.
fozzle
Level 1
Level 1
 
Posts: 2
Joined: Wed Jan 09, 2013 1:08 am

Linux Mint is funded by ads and donations.
 

Re: Connection Succeeds, Can Ping/SSH/Wget (some), still bro

Postby fozzle on Fri Feb 08, 2013 3:47 pm

I'm still having this issue, but I've found a weird workaround to get wired internet. After starting the computer with the cable unplugged, I plug it in and run "sudo dhcpcd eth0", and then it works. Just plugging it in and connecting automatically or via wicd results in the strange pseudo-connected state I mentioned above.

A really bizarre problem and kind of a pain. :roll: If anyone knows of a way to actually solve this, I'd be very grateful.
fozzle
Level 1
Level 1
 
Posts: 2
Joined: Wed Jan 09, 2013 1:08 am


Return to Ethernet

Who is online

Users browsing this forum: No registered users and 2 guests