Wired Setting not showing under Network Settings [SOLVED]

Questions about cabled networking
Forum rules
Before you post please read this

Wired Setting not showing under Network Settings [SOLVED]

Postby mathewvghese on Thu Mar 07, 2013 9:27 am

Hi,

I have installed Linux Mint 14 Cinnamon edition in my new Toshiba laptop as dual boot along with Windows 8.
The wired connection is working perfectly in Windows.

But in Linux Mint 14. The Network Settings dialog shows only "Wireless" and "Proxy". "Wired" is missing, so my wired connection is also not working.

When I tried ifconfig -a , got the below message:

Code: Select all
ifconfig -a

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:214 errors:0 dropped:0 overruns:0 frame:0
          TX packets:214 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:27929 (27.9 KB)  TX bytes:27929 (27.9 KB)

wlan0     Link encap:Ethernet  HWaddr 20:16:d8:a7:ca:1b 
          inet addr:192.168.1.10  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::2216:d8ff:fea7:ca1b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7633 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5468 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:10006202 (10.0 MB)  TX bytes:644594 (644.5 KB)


When I tried - ifconfig eth0 up : Got the below ERROR message.

Code: Select all
 ifconfig eth0 up
eth0: ERROR while getting interface flags: No such device


I searched the web and this forrum, could not get an appropriate solution.
I have another laptop with Linux Mint 13 Maya installed and it works perfectly fine for both Wired and Wireless connections. Please help me to fix this issue. Thanks

When I ran the nm-tool command , I got the below message: it does not show eth0 at all. Do I need to install any additional drivers ?

Code: Select all
NetworkManager Tool

State: connected (global)

- Device: wlan0  [Auto mmraju] -------------------------------------------------
  Type:              802.11 WiFi
  Driver:            rtl8192ce
  State:             connected
  Default:           yes
  HW Address:        20:16:D8:A7:CA:1B

  Capabilities:
    Speed:           18 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    *mmraju:         Infra, 80:A1:D7:BC:01:E2, Freq 2417 MHz, Rate 54 Mb/s, Strength 78 WPA2

  IPv4 Settings:
    Address:         192.168.1.10
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.1

    DNS:             192.168.1.1




ooOOoo UPDATE ooOOoo

http://forums.linuxmint.com/viewtopic.php?f=150&t=109661

This thread solved the issue.
Last edited by mathewvghese on Thu Mar 07, 2013 1:47 pm, edited 1 time in total.
mathewvghese
Level 1
Level 1
 
Posts: 7
Joined: Sat Apr 21, 2012 1:35 pm

Linux Mint is funded by ads and donations.
 

Re: Wired Setting not showing under Network Settings in Mint

Postby mathewvghese on Thu Mar 07, 2013 1:45 pm

http://forums.linuxmint.com/viewtopic.php?f=150&t=109661

This thread solved my issue. The steps given in the comments worked perfectly.
Now my Network Settings dialog has "Wired" in it.
Thanks.

Sorry for posting this here. :)
mathewvghese
Level 1
Level 1
 
Posts: 7
Joined: Sat Apr 21, 2012 1:35 pm


Return to Ethernet

Who is online

Users browsing this forum: No registered users and 5 guests