Network connection to Linux Machine

Questions about cabled networking
Forum rules
Before you post please read this

Network connection to Linux Machine

Postby Fornhamfred on Thu Mar 14, 2013 6:36 am

I have three machines on a network, LMDE Mate, PcLinuxOS Gnome and Windows XP. On both the PcLinux and XP machines I can see all the machines on the network and can access all the shares but on Mint I can see and access the XP machine thro smb but when I click the PcLinux machine icon in network it returns Unable to mount location Failed to retrieve share list from server. I have been able to connect to the machine using smb and the ip address but is this the correct method. I note that on the Pclinux machine the connection to Mint is not through smb but network:///
Fornhamfred
Level 6
Level 6
 
Posts: 1134
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Linux Mint is funded by ads and donations.
 

Re: Network connection to Linux Machine

Postby altair4 on Thu Mar 14, 2013 7:38 am

You might want to go through the checklist:
Samba Browsing Problems Checklist: viewtopic.php?f=42&t=88146&start=0

If you have further issues post the output of the following command:
Code: Select all
smbtree
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5924
Joined: Tue Feb 03, 2009 10:27 am

Re: Network connection to Linux Machine

Postby Fornhamfred on Thu Mar 14, 2013 2:47 pm

Thanks as usual for your networking help.

I checked all your list and apart from nmap all was as listed. I installed nmap and although I got no output in a terminal when running it.

I did try smbtree but again got no output in LMDE but in Pclinux got the following:

Server requested LANMAN password (share-level security) but 'client lanman auth' is disabled
failed tcon_X with NT_STATUS_ACCESS_DENIED
Server requested LANMAN password (share-level security) but 'client lanman auth' is disabled
failed tcon_X with NT_STATUS_ACCESS_DENIED
Fornhamfred
Level 6
Level 6
 
Posts: 1134
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: Network connection to Linux Machine

Postby altair4 on Thu Mar 14, 2013 3:22 pm

** There is always an output to nmap even if it just gives you a "host seems down" error.

** You didn't specify which machine smbtree was referencing when you got this error in PCLinuxOS:
Server requested LANMAN password (share-level security) but 'client lanman auth' is disabled
failed tcon_X with NT_STATUS_ACCESS_DENIED

If it's PCLinuxOS itself then I can't help you with that. Samba should be samba but with PCLOS ......

If it's the LMDE it's referencing it's likely you have a "encrypt passwords = No" in your smb.conf. If you post the output of this command we can verify if your LMDE smb.conf file has any errors:
Code: Select all
testparm -s


** You might want to make sure all these adjustments are made since LMDE's samba isn't configured correctly on install: viewtopic.php?f=42&t=23169&p=315218#p315218

Side question
: PCLOS always likes to go down a path less traveled but would you happen to know if avahi is installed and running on that system? In Debian/Ubuntu/Mint it's the avahi-daemon service. The reason I ask is because Avahi + Samba is a lot easier that Samba alone.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5924
Joined: Tue Feb 03, 2009 10:27 am

Re: Network connection to Linux Machine

Postby Fornhamfred on Fri Mar 15, 2013 3:24 pm

Thanks for your suggestions. After reading your previous post I checked whether I had set static IP addresses on the two linux machines ( XP i knew had a static IP)
and I found that I had not. I have now assigned the static IPs and all the machines are talking to each other.

Out of interest Avahi is installed on both PcLinux and LMDE.
Fornhamfred
Level 6
Level 6
 
Posts: 1134
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK


Return to Ethernet

Who is online

Users browsing this forum: No registered users and 4 guests