delay in internet

Questions about cabled networking
Forum rules
Before you post please read this

delay in internet

Postby Sandra_S on Tue Aug 27, 2013 2:08 pm

Hi,

I am new in linux, i have linux mint 15, and since i changed from net operator i have now cable conection.

And when i boot my pc, the network manager recognizes the connection, but it takes +/- 15 minutes before i can go to the web.

i've tried severel things, i know what my gateway is (192.168.1.254) and i can ping the gateway, but i can't ping google for example.
Only after those 15 minutes i can "go out to the ewb" :?


can you help me ?

thank you
Sandra_S
Level 1
Level 1
 
Posts: 20
Joined: Tue Aug 27, 2013 1:54 pm

Linux Mint is funded by ads and donations.
 

Re: delay in internet

Postby trapperjohn on Tue Aug 27, 2013 6:14 pm

Can you ping 8.8.8.8 after making your connection? If you can, but you cannot ping by name (eg google.com), then you may have a lag being created by your DNS server. There is a way to modify the DNS server if you find that 8.8.8.8 pings immediately.

BTW: You say your gateway is 192.168.1.254. This is perhaps so, but most often a lan gateway would be located at something like 192.168.1.1 Just to be sure, double check this setting.
trapperjohn
Level 5
Level 5
 
Posts: 686
Joined: Wed Jul 11, 2012 4:10 pm

Re: delay in internet

Postby Sandra_S on Wed Aug 28, 2013 6:25 am

Hello,

Thank you for your help.

My gateway is indeed 192.168.1.254 (Thomson) i've alreadu checked with me net provider.
Before I had gateway 192.168.1.1 (i changed net provider last month, until then i had no problems with mu wifi connection).

Ehen i turned on my pc i tried to ping www.google.com and said unknow host.

Then i tried to ping 8.8.8.8 and the terminal hang on for some minutes. When i finally got access to net, the ping started writing.

This is what i got:

sandra@sandra-PCL ~ $ ping 192.168.1.254
PING 192.168.1.254 (192.168.1.254) 56(84) bytes of data.
64 bytes from 192.168.1.254: icmp_req=1 ttl=64 time=0.301 ms
64 bytes from 192.168.1.254: icmp_req=2 ttl=64 time=0.321 ms
64 bytes from 192.168.1.254: icmp_req=3 ttl=64 time=0.331 ms
^C
--- 192.168.1.254 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2001ms
rtt min/avg/max/mdev = 0.301/0.317/0.331/0.024 ms
sandra@sandra-PCL ~ $ ping www.google.com
ping: unknown host www.google.com
sandra@sandra-PCL ~ $ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_req=430 ttl=47 time=48.3 ms
64 bytes from 8.8.8.8: icmp_req=431 ttl=47 time=47.6 ms
64 bytes from 8.8.8.8: icmp_req=432 ttl=47 time=48.1 ms
64 bytes from 8.8.8.8: icmp_req=433 ttl=47 time=47.7 ms
^C
--- 8.8.8.8 ping statistics ---
435 packets transmitted, 4 received, 99% packet loss, time 436688ms
rtt min/avg/max/mdev = 47.642/47.986/48.355/0.283 ms
sandra@sandra-PCL ~ $ ^C
sandra@sandra-PCL ~ $


Thank you
Sandra_S
Level 1
Level 1
 
Posts: 20
Joined: Tue Aug 27, 2013 1:54 pm

Re: delay in internet

Postby trapperjohn on Wed Aug 28, 2013 8:41 am

It does not seem to be related to your computer setup. Your networking was working with the previous provider. I would look for the trouble with the new net provider.
trapperjohn
Level 5
Level 5
 
Posts: 686
Joined: Wed Jul 11, 2012 4:10 pm

Re: delay in internet

Postby Sandra_S on Wed Aug 28, 2013 12:17 pm

:( i don't think so..

i have dual boot and when i log in with windows the net works fine. and i have other computers all with windows and they also work fine.

any other opinions??

Thank you
Sandra_S
Level 1
Level 1
 
Posts: 20
Joined: Tue Aug 27, 2013 1:54 pm

Re: delay in internet

Postby trapperjohn on Wed Aug 28, 2013 1:08 pm

Good point, and yes, anyone with other ideas feel free to jump in.

Meanwhile, when you boot from your live cd, is the connection immediate?
trapperjohn
Level 5
Level 5
 
Posts: 686
Joined: Wed Jul 11, 2012 4:10 pm

Re: delay in internet

Postby Sandra_S on Thu Aug 29, 2013 5:11 pm

thank you, i'll try that and give feedback

my pc is weird, today i turned on and imediate got acess to net :?
Sandra_S
Level 1
Level 1
 
Posts: 20
Joined: Tue Aug 27, 2013 1:54 pm

Re: delay in internet

Postby Sandra_S on Fri Aug 30, 2013 8:19 am

Hi,

i tried to boot from live cd and it was the same, no net.

i couldn't even ping the router (192.168.1.254)

Booted normally and today it took 426.977 ms to get net access? :evil:

i also tried the command "sudo ifup eth0" (read somewhere this wold help), and this is what o got:

thak you, any help is welcome

Code: Select all
sandra@sandra-PCL ~ $ sudo ifup eth0
sudo: unable to resolve host sandra-PCL
[sudo] password for sandra:
Ignoring unknown interface eth0=eth0.
sandra@sandra-PCL ~ $ ping 192.168.1.254
PING 192.168.1.254 (192.168.1.254) 56(84) bytes of data.
64 bytes from 192.168.1.254: icmp_req=1 ttl=64 time=0.324 ms
64 bytes from 192.168.1.254: icmp_req=2 ttl=64 time=0.316 ms
64 bytes from 192.168.1.254: icmp_req=3 ttl=64 time=0.315 ms
^C
--- 192.168.1.254 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 1998ms
rtt min/avg/max/mdev = 0.315/0.318/0.324/0.015 ms
sandra@sandra-PCL ~ $ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_req=421 ttl=47 time=50.6 ms
64 bytes from 8.8.8.8: icmp_req=422 ttl=47 time=49.2 ms
64 bytes from 8.8.8.8: icmp_req=423 ttl=47 time=49.0 ms
64 bytes from 8.8.8.8: icmp_req=424 ttl=47 time=49.0 ms
64 bytes from 8.8.8.8: icmp_req=425 ttl=47 time=48.9 ms
^C
--- 8.8.8.8 ping statistics ---
425 packets transmitted, 5 received, 98% packet loss, time 426977ms
rtt min/avg/max/mdev = 48.948/49.394/50.611/0.632 ms
sandra@sandra-PCL ~ $ host



sandra@sandra-PCL ~ $ sudo ifup eth0
sudo: unable to resolve host sandra-PCL
[sudo] password for sandra:
Ignoring unknown interface eth0=eth0.
sandra@sandra-PCL ~ $ ping 192.168.1.254
PING 192.168.1.254 (192.168.1.254) 56(84) bytes of data.
64 bytes from 192.168.1.254: icmp_req=1 ttl=64 time=0.324 ms
64 bytes from 192.168.1.254: icmp_req=2 ttl=64 time=0.316 ms
64 bytes from 192.168.1.254: icmp_req=3 ttl=64 time=0.315 ms
^C
--- 192.168.1.254 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 1998ms
rtt min/avg/max/mdev = 0.315/0.318/0.324/0.015 ms
sandra@sandra-PCL ~ $ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_req=421 ttl=47 time=50.6 ms
64 bytes from 8.8.8.8: icmp_req=422 ttl=47 time=49.2 ms
64 bytes from 8.8.8.8: icmp_req=423 ttl=47 time=49.0 ms
64 bytes from 8.8.8.8: icmp_req=424 ttl=47 time=49.0 ms
64 bytes from 8.8.8.8: icmp_req=425 ttl=47 time=48.9 ms
^C
--- 8.8.8.8 ping statistics ---
425 packets transmitted, 5 received, 98% packet loss, time 426977ms
rtt min/avg/max/mdev = 48.948/49.394/50.611/0.632 ms
sandra@sandra-PCL ~ $ host
Sandra_S
Level 1
Level 1
 
Posts: 20
Joined: Tue Aug 27, 2013 1:54 pm

Re: delay in internet

Postby wavespot on Fri Aug 30, 2013 8:35 am

could you type 'ifconfig -a' and 'cat /etc/hosts' and 'cat /etc/resolv.conf' ?
wavespot
Level 2
Level 2
 
Posts: 92
Joined: Tue Jan 17, 2012 6:44 am

Re: delay in internet

Postby Sandra_S on Fri Aug 30, 2013 9:25 am

yos, of course :)

thank you

Code: Select all
sandra@sandra-PCL ~ $ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 10:bf:48:7f:ed:40 
          inet addr:192.168.1.66  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::12bf:48ff:fe7f:ed40/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:35669 errors:0 dropped:0 overruns:0 frame:0
          TX packets:30556 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:29633551 (29.6 MB)  TX bytes:4001143 (4.0 MB)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:4543 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4543 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:197110 (197.1 KB)  TX bytes:197110 (197.1 KB)

wlan1     Link encap:Ethernet  HWaddr 10:bf:48:4a:ca:b7 
          inet addr:192.168.1.76  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::12bf:48ff:fe4a:cab7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5027 errors:0 dropped:0 overruns:0 frame:0
          TX packets:154 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1044070 (1.0 MB)  TX bytes:38023 (38.0 KB)

sandra@sandra-PCL ~ $ cat /etc/hosts

# The following lines are desirable for IPv6 capable hosts
sandra@sandra-PCL ~ $ cat etc/resolv.conf
cat: etc/resolv.conf: No such file or directory
sandra@sandra-PCL ~ $ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1
search lan

# OpenDNS Fallback (configured by Linux Mint in /etc/resolvconf/resolv.conf.d/tail).
nameserver 208.67.222.222
nameserver 208.67.220.220
sandra@sandra-PCL ~ $
Sandra_S
Level 1
Level 1
 
Posts: 20
Joined: Tue Aug 27, 2013 1:54 pm

Re: delay in internet

Postby wavespot on Fri Aug 30, 2013 10:06 am

Something wrong here : you've got 2 interfaces UP with IP in the same network : eth0 and wlan0 has respectively 192.168.1.66 and 192.168.1.76.

Did you let your cable plugged while using wifi ?
wavespot
Level 2
Level 2
 
Posts: 92
Joined: Tue Jan 17, 2012 6:44 am

Re: delay in internet

Postby Sandra_S on Fri Aug 30, 2013 1:51 pm

Hello wavespot:

wlan1, don't have wlan0, i don't know if makes difference.

Whwn i said i tried to connect with wifi only, i disconnected the cable, but it didn't got net acesss as usual, and so i rebooted and connected the cable again.

I usually have both connected, as i write this moment the ip's are the same.

And in network manager , when i right click the icon in connection information, both connections apear, "Auto Ethernet(default)" and "M_WIFI".

Than you

EDIT: My wireless is "internal" and has a little antena, to disconnect it i have to open the pc.

Sorry for the bad English :oops:
Sandra_S
Level 1
Level 1
 
Posts: 20
Joined: Tue Aug 27, 2013 1:54 pm

Re: delay in internet

Postby wavespot on Sat Aug 31, 2013 5:43 am

Sandra_S wrote:Hello wavespot:

wlan1, don't have wlan0, i don't know if makes difference.

Whwn i said i tried to connect with wifi only, i disconnected the cable, but it didn't got net acesss as usual, and so i rebooted and connected the cable again.

I usually have both connected, as i write this moment the ip's are the same.


Hi Sandra_S

That's the main reason everything is slow. You just created a loop between your 2 interfaces and your ISP box. It can't works that way. You must disable one of your interface depending on which one you want to use.

Sandra_S wrote:And in network manager , when i right click the icon in connection information, both connections apear, "Auto Ethernet(default)" and "M_WIFI".


So, disable one of them from here, or unplugged the cable, or use the wifi on/off button on your laptop (if you have one of course), and then, let's review the configuration :

1/ ifconfig -a
2/ route
3/ cat /etc/resolv.conf
4/ cat /etc/hosts

Sandra_S wrote:Than you

EDIT: My wireless is "internal" and has a little antena, to disconnect it i have to open the pc.

Sorry for the bad English :oops:
wavespot
Level 2
Level 2
 
Posts: 92
Joined: Tue Jan 17, 2012 6:44 am

Re: delay in internet

Postby Sandra_S on Thu Sep 05, 2013 7:34 am

Hi,

sorry for the time i took to answer, haven't been around the pc.

here is what i did this morning.

my pc is a desktod, so i can't turn off the wifi, so i did it by software, netwok manager, disable wifi and rebooted.

it took even more time to get net acess and here are the result of the commands you asked.

thank you

Code: Select all
sandra@sandra-PCL ~ $ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 10:bf:48:7f:ed:40 
          inet addr:192.168.1.66  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::12bf:48ff:fe7f:ed40/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:17953 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24960 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:9382883 (9.3 MB)  TX bytes:2670949 (2.6 MB)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:10659 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10659 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:396822 (396.8 KB)  TX bytes:396822 (396.8 KB)

wlan1     Link encap:Ethernet  HWaddr 10:bf:48:4a:ca:b7 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

sandra@sandra-PCL ~ $ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         dsldevice.lan   0.0.0.0         UG    0      0        0 eth0
link-local      *               255.255.0.0     U     1000   0        0 eth0
192.168.1.0     *               255.255.255.0   U     1      0        0 eth0
sandra@sandra-PCL ~ $ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1
search lan

# OpenDNS Fallback (configured by Linux Mint in /etc/resolvconf/resolv.conf.d/tail).
nameserver 208.67.222.222
nameserver 208.67.220.220
sandra@sandra-PCL ~ $ cat /etc/hosts

# The following lines are desirable for IPv6 capable hosts
sandra@sandra-PCL ~ $
Sandra_S
Level 1
Level 1
 
Posts: 20
Joined: Tue Aug 27, 2013 1:54 pm

Re: delay in internet

Postby wavespot on Mon Sep 16, 2013 4:06 am

Hi,

Sorry for the delay, I was on vacation.

Is your /etc/hosts file empty ? It definitely shouldn't, that's where you localhost address is defined, dnsmasq and other services are using this one (see resolv.conf)

It should be like this : (replace <your-hostname> by .. guess what.. your hostname)

127.0.0.1 localhost
127.0.1.1 <your-hostname>

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters


-- Fred
wavespot
Level 2
Level 2
 
Posts: 92
Joined: Tue Jan 17, 2012 6:44 am

Re: delay in internet

Postby Sandra_S on Wed Sep 18, 2013 9:48 am

Hi, hope you had good vacations :)

Sorry, but i didn't understant what you wrote.

What is my hostname? Is it the one on etc/hostname?

And wich file shall i edit?

etc/hosts?

I have host.conf, hostname, hosts, hosts.allow and host.deny in etc/.

:?

thank you
Sandra_S
Level 1
Level 1
 
Posts: 20
Joined: Tue Aug 27, 2013 1:54 pm

Re: delay in internet

Postby administrollaattori on Wed Sep 18, 2013 2:57 pm

Sandra_S wrote:What is my hostname? Is it the one on etc/hostname?

Yes
Code: Select all
cat /etc/hostname
User avatar
administrollaattori
Level 6
Level 6
 
Posts: 1112
Joined: Tue Sep 03, 2013 4:51 am

Re: delay in internet

Postby Sandra_S on Wed Sep 18, 2013 7:12 pm

hi again...



didn't worked.

i have now this in /etc/hosts and /etc/resolv.conf:

Code: Select all
sandra@sandra-PCL ~ $ cat /etc/hosts
127.0.0.1 localhost
127.0.1.1 sandra-PCL

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
sandra@sandra-PCL ~ $ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 192.168.1.254
nameserver 127.0.1.1
search lan

# OpenDNS Fallback (configured by Linux Mint in /etc/resolvconf/resolv.conf.d/tail).
nameserver 208.67.222.222
nameserver 208.67.220.220
sandra@sandra-PCL ~ $



and something weird happend few days ago, don't know why.

i have now in network manager, a new connection "ifupdown (eth0)" besides "Auto Ethernet"

????


thank you again
Sandra_S
Level 1
Level 1
 
Posts: 20
Joined: Tue Aug 27, 2013 1:54 pm

Re: delay in internet

Postby administrollaattori on Wed Sep 18, 2013 11:25 pm

Sandra_S wrote:and something weird happend few days ago, don't know why.

i have now in network manager, a new connection "ifupdown (eth0)" besides "Auto Ethernet"

You need to edit /etc/NetworkManager/NetworkManager.conf file and reboot computer after that.
Code: Select all
gksudo pluma /etc/NetworkManager/NetworkManager.conf
### you can use your favorite editor of course (gedit, nano, kate, etc.)

The contents
Code: Select all
[main]
plugins=ifupdown,keyfile
dns=dnsmasq

[ifupdown]
managed=false
User avatar
administrollaattori
Level 6
Level 6
 
Posts: 1112
Joined: Tue Sep 03, 2013 4:51 am

Re: delay in internet

Postby wavespot on Thu Sep 19, 2013 3:03 am

Sandra_S wrote:hi again...



didn't worked.

i have now this in /etc/hosts and /etc/resolv.conf:

Code: Select all
sandra@sandra-PCL ~ $ cat /etc/hosts
127.0.0.1 localhost
127.0.1.1 sandra-PCL

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
sandra@sandra-PCL ~ $ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 192.168.1.254
nameserver 127.0.1.1
search lan

# OpenDNS Fallback (configured by Linux Mint in /etc/resolvconf/resolv.conf.d/tail).
nameserver 208.67.222.222
nameserver 208.67.220.220
sandra@sandra-PCL ~ $



and something weird happend few days ago, don't know why.

i have now in network manager, a new connection "ifupdown (eth0)" besides "Auto Ethernet"

????


thank you again


That's fine. You have now a DNS pointing to your box, but it's harmless. And with that configuration, it's always slow ?
wavespot
Level 2
Level 2
 
Posts: 92
Joined: Tue Jan 17, 2012 6:44 am

Linux Mint is funded by ads and donations.
 
Next

Return to Ethernet

Who is online

Users browsing this forum: No registered users and 4 guests