NAS drive odd behavior and Gigabit question

Questions about cabled networking
Forum rules
Before you post please read this

NAS drive odd behavior and Gigabit question

Postby WildSioux on Thu Mar 05, 2009 1:22 pm

Hello,

I have finally come to a Linux OS that does everything I need. I have been jumping around for about 4 months now waiting for Linuxmint KDE 4 CE to come out. This past weekend I downloaded and installed the mint6 KDE CE RC1 and am loving it.

After setting up everything I need including my fstab mount entry for my NAS drive. I have a fully functioning computer with linux. No other OS came close to doing this. However, I have noticed some odd behavior with my NAS box. It is a Dlink DNS323 attached to my router, which then is connected to a gigabit switch which is then connected to my desktop with a Netgear/Realtek gigabit card that I added to it.

1.) First, I have it set to automount at start. This works fine. I have the NAS box to sleep after 30 minutes of inactivity. I have noticed periodically the drive wakes up without any activity. And I believe it is how it is mounted but I don't want to mess it up since this is the first OS that I have made it work with an actual mount entry in FSTAB instead of using SMB4K. None of the other OS's I tried did this.

Any idea???? Here is my FSTAB entry
Code: Select all
//IP_Address/User\040&\040Our\040Files /home/user/mnt/DEVICE/USER\040&\040Our\040Files cifs rw,nounix,nobrl,_netdev 0 0


~ I did a lot of testing and wasting time before finally coming to this entry to make it work. The "nounix" entry is the only one that I found which would allow it to save a document in OpenOffice to the box.

~ I would prefer not having it wake up periodically if I am not using anything to warrant it coming out of sleep. Do I need to remove the "0 0" at the end to make it not automount and just mount manually?

2.) May be related, but I have noticed when copying pictures to the box. I get an error in Dolphin saying something like
Code: Select all
"Unable to change permissions on xx file." 


I don't know what is causing this. But if I have 100 pictures to copy, it pops this error up 100 times. Clicking on "OK" continues the copying process, popping it up each time until done. I can view and open the files. I just don't know if I can edit and save them since when I do edit them I always save it in a different folder as "manip."

~ I believe the DNS323 itself is causing this since it has its own permissions set. But I don't know how or where to begin. Is the FSTAB entry causing this?

3.) re: Netgear/Realtek gigabit card. After installing KNetStats, I found out that the MTU is set to 1500. The max this card has is "7500." How can I change the "MTU" on it?

4.) I also have a 10/100 built in on my Intel board. How can I disable this as I don't use it now?

Thank you for any help and Thanks again to the amazing development on the Mint6 KDE CE RC.
Image
WildSioux
Level 3
Level 3
 
Posts: 118
Joined: Thu Jan 22, 2009 3:21 pm

Linux Mint is funded by ads and donations.
 

Re: NAS drive odd behavior and Gigabit question

Postby Husse on Sat Mar 07, 2009 5:40 pm

I'll try to answer this
<<
I don't think the way you mount wakes up the NAS - but I may be wrong
What exactly does this mean?
I have noticed periodically the drive wakes up without any activity.

Check the system logs > messages Every twenty minutes (can be changed but that is the default) the syslog daemon writes --MARK-- to show it's awake
If you have placed the logs on the NAS, well ....
There may be other daemons that write on a regular schedule
<<
Do I need to remove the "0 0" at the end

Let them be - or it will not mount (well it does not necessary have to be zeros)
See man fstab fstab has and extensive man page
<<
The permissions problem - is is just for images?
The mount is in home with user in the line so you should own the NAS unless there are folders belonging to someone else in it
Be careful with sudo if you try to fix this so you do not unintentionally make root the owner - I've made that mistake a couple of times :)
<<
mtu 7500 careful - you want come an inch on the internet with that mtu I think
But if that's no problem it's fairly easy to fix - see
viewtopic.php?f=150&t=19837&start=15&st=0&sk=t&sd=a#p127456
but that gives the new mtu to that interface so if it's used for internet.....
<<
I think you can disable the built in card in BIOS
If not run lspci -v to identify which module and driver it uses
It is then possible to blacklist these if they are not used by something else
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: NAS drive odd behavior and Gigabit question

Postby WildSioux on Mon Mar 09, 2009 1:53 pm

Husse wrote:I'll try to answer this

What exactly does this mean?
I have noticed periodically the drive wakes up without any activity.


Meaning I am not accessing it at all through Dolphin, OO, or any other way.

I just tried over the weekend to add "noauto" to the fstab for the NAS. It solved the problem of it waking up without any activity. However, I was unable to use "sudo mount -a" It would not mount the drive.

So I removed the "noauto" to gain access and the drive wakes up when I boot in to Mint. After letting it sit for 30 minutes it will sleep. But I have noticed opening up Dolphin, using the open dialog in OO opens up the folder list starting at my main root but this will wake the NAS drive up without even clicking on anything.

It is really annoying how it does this since I don't want it waking up every 10 minutes or so especially when I don't need it. None of the other OS distros I tried did this.

Husse wrote:Check the system logs > messages Every twenty minutes (can be changed but that is the default) the syslog daemon writes --MARK-- to show it's awake
If you have placed the logs on the NAS, well ....
There may be other daemons that write on a regular schedule


Hmm, not sure what I am looking for in the logs. No, I have not placed the logs on the NAS.

Husse wrote:The permissions problem - is is just for images?
The mount is in home with user in the line so you should own the NAS unless there are folders belonging to someone else in it
Be careful with sudo if you try to fix this so you do not unintentionally make root the owner - I've made that mistake a couple of times :)


I just checked and it is for any file. The share that I am accessing is setup for anyone to access with read/write permissions.

Thanks for replying!
Image
WildSioux
Level 3
Level 3
 
Posts: 118
Joined: Thu Jan 22, 2009 3:21 pm

Re: NAS drive odd behavior and Gigabit question

Postby Husse on Tue Mar 10, 2009 7:44 am

I have much to do right now and I don't quite understand the problem so I'll have to think about it and come back to you
You should not have permissions problem for yourself as it's mounted - maybe others though
Check the permissions setting of the NAS - you could right click and make sure you and the group have read and write permissions
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: NAS drive odd behavior and Gigabit question

Postby WildSioux on Thu Mar 12, 2009 1:33 pm

No problem Husse...

Here are some links I found which may shed some light on this problem. I don't know if they are the same to what my issue is. But they may help hopefully.

Clicking on "Trash" or "Deleted" items causes Synology NAS to come out of hibernation (I haven't clicked on the trash folder when my NAS wakes up):
http://www.synology.com/enu/forum/viewtopic.php?f=106&t=8518

Keep NAS from going to sleep (opposite problem since I don't want mine to wake up when not being accessed):
http://ubuntuforums.org/showthread.php?t=581778
Image
WildSioux
Level 3
Level 3
 
Posts: 118
Joined: Thu Jan 22, 2009 3:21 pm

Re: NAS drive odd behavior and Gigabit question

Postby Husse on Sat Mar 14, 2009 2:22 pm

Here's a description for Ubuntu 8.04
http://www.marcus-furius.com/?p=59
Similar to your solution, but the line in fstab explicitly declares the permissions
I have found at least one explanation to part of the wake up problem
Mint makes a (hidden) trash folder .Trash-1000 in a partition you have deleted something in - not sure about that, in some but not all partitions
That folder is a "sub set" of "normal" trash - they are linked - and when you throw something in the trash bin all the trash reacts
There may be other files or folders that do this - check the NAS for hidden files
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: NAS drive odd behavior and Gigabit question

Postby WildSioux on Mon Mar 16, 2009 11:07 am

Husse wrote:I have found at least one explanation to part of the wake up problem
Mint makes a (hidden) trash folder .Trash-1000 in a partition you have deleted something in - not sure about that, in some but not all partitions
That folder is a "sub set" of "normal" trash - they are linked - and when you throw something in the trash bin all the trash reacts
There may be other files or folders that do this - check the NAS for hidden files


I searched for hidden files on my NAS and I have found files in some folders that I use (word document files in OO). They are named: "cifs###," or "cifs#fe." The "#" being a number like cifs117, cifs221, cifs321, cifs1fe, cifs2fe, etc... are some in one folder I have. These are all .txt files so I opened them and here is what cifs1fe says.
6061
dolphin
MintComputerName


I also have a hidden file called .directory
[Dolphin]
Timestamp=2009,3,16,10,49,29

[Settings]
ShowDotFiles=true


I just noticed that in Dolphin, choosing "Show Hidden Files" shows these files. And when I uncheck "Show Hidden Files," the .directory files hides. But the cifs### files are still there along with a few new cifs### files. I just tried deleting all the cifs### files in one folder. They deleted, but it created two new ones.

Any idea what these files may be and why do they create new files.

Also, when I started up my computer this morning. My NAS was asleep as usual. I downloaded a PDF file to my Desktop folder. And when I opened it, the NAS woke up. Why does opening up a PDF file wake up the NAS? Ugh, this is frustrating.
Image
WildSioux
Level 3
Level 3
 
Posts: 118
Joined: Thu Jan 22, 2009 3:21 pm

Re: NAS drive odd behavior and Gigabit question

Postby Husse on Tue Mar 17, 2009 6:47 am

I'm lost here - will call for help :)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: NAS drive odd behavior and Gigabit question

Postby Boo on Tue Mar 17, 2009 9:03 am

OK on seeing this I first thought automount not fstab.
remember too some indexing service may check the fs at regular intervals including the nas mount (ie wake it up).

so checkout:
http://www.howtoforge.com/accessing_win ... ing_autofs

and just checkout automount (autofs) in general.

for fstab you may need the auto option added and the user option to allow the user to un/mount.

Boo
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Re: NAS drive odd behavior and Gigabit question

Postby WildSioux on Tue Mar 17, 2009 10:37 pm

Boo wrote:remember too some indexing service may check the fs at regular intervals including the nas mount (ie wake it up).

and just checkout automount (autofs) in general.

for fstab you may need the auto option added and the user option to allow the user to un/mount.

Boo


I did some checking and am not sure if this is the problem or not.

Reading this...
http://ubuntuforums.org/showthread.php?t=283131&highlight=mount+-a+samba+doesn%27t+work

I found...
Ubuntu 8.04 now defaults to "relatime". For a discussion of this option see : http://lwn.net/Articles/244829/


I checked my fstab and there is "relatime" for my "# /dev/sda5" (I believe my hard drive). Could this be the thing that is waking up my NAS? Using the other OS's I can't remember if the fstab had that or not.

Would removing "relatime" for that drive mess up anything?

For now, I have found kind of a work around for the mount problem. I added
noauto,nouser
to my fstab. It doesn't auto mount at boot. Although I am unable to use "sudo mount -a" to mount that drive. I found that this works. I right clicked in the /mnt/ directory, Link To Device, then Hard Disk Device, and clicked the Device tab and clicked on the share to it.

I then opened up a terminal and typed "sudo dolphin." It opens up dolphin, and I am able to double click on that drive in my /mnt/ folder. It pops up a warning for a password (but no password box since this share has no password). It then opens up a new dolphin window giving me access to that share.

Like I said, its not the best thing but it works. Is there a way to just open dolphin as user and somehow mount that as root without having to open terminal and typing in sudo dolphin? This allows me access to it until I logout or turn the computer off. But it still doesn't fix the problem of random wake ups (see relatime above)?

I still don't understand why sudo mount -a works.

EDIT: Now using this mount method, my computer hangs while logging out or shutting down. All i get is a black screen with a mouse arrow. To get out i have to CTL-ALT-BACK SPACE which brings me the KDM login screen. Grrrr

Thanks
Image
WildSioux
Level 3
Level 3
 
Posts: 118
Joined: Thu Jan 22, 2009 3:21 pm

Re: NAS drive odd behavior and Gigabit question

Postby WildSioux on Fri Mar 20, 2009 11:53 am

FYI...

I just checked my system logs and there is something funky going on with modprobe and ipv6
Code: Select all
2009-03-20 11:49:02   PC-NAME   modprobe   WARNING: Not loading blacklisted module ipv6
2009-03-20 11:49:03   PC-NAME   modprobe   WARNING: Not loading blacklisted module ipv6


It does this every 2 minutes or so. And this is the same time when it woke up the NAS without me accessing it.
Image
WildSioux
Level 3
Level 3
 
Posts: 118
Joined: Thu Jan 22, 2009 3:21 pm

Re: NAS drive odd behavior and Gigabit question

Postby Husse on Sat Mar 21, 2009 1:29 pm

Well we blacklist ipv6 as it's hardly ever used and can cause (severe) problems
This indicates that "some network thing" is behaving a bit badly
We had in some previous versions fusesmb installed by default and that could have caused something like this
I can't find that in my logs (gnome though)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: NAS drive odd behavior and Gigabit question

Postby Boo on Sat Mar 21, 2009 10:37 pm

I have been checking my laptop logs and found that the ip6 module blacklist only shows up when my laptop was connected to a network via copper.
on a wireless network the blacklist ipv6 message does not show up.
I would check the other devices on your network and make sure they are not using (or probing for) some ipv6 related app/network protocol.
also check if you are using ipchains (and ipchains_ip6), there could something happening here too.

Boo
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Re: NAS drive odd behavior and Gigabit question

Postby WildSioux on Wed Mar 25, 2009 11:00 am

Thanks for the information on IPv6. I haven't had time over the past weekend since I moved. I still haven't hooked up my NAS yet. I don't think the DNS323 NAS uses IPv6. But I need to check in to that since that may be causing the probe problems.

Just a quick check with my Desktop connected via ethernet Cat 5e to a Gigabit switch which is then hooked to my DIR-655 router by another Cat 5e. I checked the logs and these are still in there.
Code: Select all
2009-03-25 10:47:52   PC-name   modprobe   WARNING: Not loading blacklisted module ipv6


So its not the NAS since that isn't even hooked up. Could it be either my router or my computer? My computer has a Netgear GA311 gigabit card. I don't even know where or how to change those settings. No other network device is on at the moment (wired or wireless).

Could this be a bug in Mint6 KDE CE???
Image
WildSioux
Level 3
Level 3
 
Posts: 118
Joined: Thu Jan 22, 2009 3:21 pm

Re: NAS drive odd behavior and Gigabit question

Postby WildSioux on Wed Mar 25, 2009 4:41 pm

I just did some searching and found that this is a bug in Ubuntu Intrepid.

Read down towards the bottom last two posts...
https://bugs.launchpad.net/ubuntu/+source/module-init-tools/+bug/66423

If IP6 is blacklisted, why am I still getting those errors in the log?

I am convinced that this is what is causing my NAS to wake up. If Mint is sending this broadcast over the network that is the only way for it to wake up as it does so when someone or something accesses it. This isn't anything else on my network that is causing it as I tried 4 other distros before settling on Mint6 KDE CE.

So...how do I go about fixing this problem as indicated in that bug report?
This bug was fixed in the package module-init-tools - 3.7~pre7-1
Image
WildSioux
Level 3
Level 3
 
Posts: 118
Joined: Thu Jan 22, 2009 3:21 pm

Re: NAS drive odd behavior and Gigabit question

Postby Boo on Thu Mar 26, 2009 4:22 am

a quick fix might be to un-blacklist the ipv6 module.

edit /etc/modprobe.d/blacklist
and remove the line
blacklist ipv6

this will stop the warning messages but your NAS may still get woken up.

the fixed package in the bug report could be in the intrepid backport repository.
enable it and install the package

Boo
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Re: NAS drive odd behavior and Gigabit question

Postby WildSioux on Thu Mar 26, 2009 12:15 pm

Boo wrote:a quick fix might be to un-blacklist the ipv6 module.

edit /etc/modprobe.d/blacklist
and remove the line
blacklist ipv6

this will stop the warning messages but your NAS may still get woken up.

the fixed package in the bug report could be in the intrepid backport repository.
enable it and install the package

Boo


Hmm, I would rather try the fixed package because I've read that enabling (un-blacklist) ipv6 slows down the internet. I didn't find that "module-init-tools - 3.7~pre7-1" in any of the intrepid repos. Is it possible to add a jaunty repo to an intrepid system or would that screw things up? If possible which one?
Image
WildSioux
Level 3
Level 3
 
Posts: 118
Joined: Thu Jan 22, 2009 3:21 pm

Re: NAS drive odd behavior and Gigabit question

Postby Boo on Thu Mar 26, 2009 6:06 pm

It would most likely be in the main jaunty repo.
the problem may be dependancies on the package, so one package may turn in lots...

Boo
Image
Now where was i going? Oh yes, crazy!
User avatar
Boo
Level 8
Level 8
 
Posts: 2364
Joined: Mon Mar 26, 2007 7:48 am

Re: NAS drive odd behavior and Gigabit question

Postby WildSioux on Thu Mar 26, 2009 7:27 pm

I found a fix for the erroneous log entries for the "Modprobe Warning Not Loading IPV6..."

modify the /etc/modprobe.d/aliases file
Change the line:
Code: Select all
alias net-pf-10 ipv6

To:
Code: Select all
alias net-pf-10 off

http://ubuntuforums.org/showthread.php?t=1017014&highlight=ipv6+modprobe+warning

That most definitely have stopped those. But unfortunately it still wakes up my NAS.

At this point I am at a loss.
Image
WildSioux
Level 3
Level 3
 
Posts: 118
Joined: Thu Jan 22, 2009 3:21 pm

Re: NAS drive odd behavior and Gigabit question

Postby Husse on Sun Mar 29, 2009 8:40 am

In your case it seems to me that we have to find out what makes regular system or network calls
My logs reveal nothing of the kind - the only periodic log entry is the MARK entries in syslog every twenty minutes
I'm on gnome - could it be something in KDE 4? I don't really know what to search for here but something that happens regularly
Will reboot and check logs
Edit
Been in Felicia KDE RC1 for a while - nothing in the logs at a regular interval no ipv6 - what's going on in your end? :shock:
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Linux Mint is funded by ads and donations.
 
Next

Return to Ethernet

Who is online

Users browsing this forum: No registered users and 7 guests