Linux Mint 7 Gloria XFCE Networking Problem - Atheros

Questions about cabled networking
Forum rules
Before you post please read this

Linux Mint 7 Gloria XFCE Networking Problem - Atheros

Postby orc_dragoon on Fri Jul 31, 2009 2:55 am

I followed this tutorial to fix the IPV6 error, http://www.ubuntu-inside.me/2009/04/how ... aunty.html, but when I got to the

$ifconfig eth0 step

this is what I got this

josh@joshua-eee ~ $ $ifconfig eth0
bash: eth0: command not found

Heres the results of ifconfig

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:374 errors:0 dropped:0 overruns:0 frame:0
TX packets:374 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:26988 (26.9 KB) TX bytes:26988 (26.9 KB)

pan0 Link encap:Ethernet HWaddr ee:39:a8:9a:f5:c6
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:64 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:15262 (15.2 KB)

pan0:avahi Link encap:Ethernet HWaddr ee:39:a8:9a:f5:c6
inet addr:169.254.11.10 Bcast:169.254.255.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1


Im trying connect via ethernet now, but will later do it through wireless.
Last edited by orc_dragoon on Sat Aug 01, 2009 5:06 pm, edited 1 time in total.
orc_dragoon
Level 1
Level 1
 
Posts: 7
Joined: Fri Jul 31, 2009 2:46 am

Linux Mint is funded by ads and donations.
 

Re: Linux Mint 7 Gloria XFCE Networking Problem

Postby DrHu on Fri Jul 31, 2009 7:29 am

orc_dragoon wrote:I followed this tutorial to fix the IPV6 error, http://www.ubuntu-inside.me/2009/04/how ... aunty.html, but when I got to the...

What was that error with using IPV6...

You have to install a 2.6.29.3 or a later kernel.You can find debian packages of kernels from here..
First issue, the kernel version for those packages
    You have to install a 2.6.29.3 or a later kernel.You can find debian packages of kernels from here
--then..
Code: Select all
Update your grub via :
$sudo update-grub

Reboot your box with 2.6.29-03 kernel.To be sure, open a terminal and paste this command (change eth0 to your network interface : eth1,eth0, wlan0 etc)

$ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:1d:92:4b:92:c7
inet addr:94.54.36.125 Bcast:94.54.63.255 Mask:255.255.192.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:228348 errors:0 dropped:0 overruns:0 frame:0
TX packets:2891 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:16159134 (16.1 MB) TX bytes:486253 (486.2 KB)
Interrupt:27 Base address:0xe000
If the output is similar to this (no extra lines like 213123/64), then you have disabled ipv6


Well for some reason it could not find the path to ifconfig, however that doesn't explain how you have a collection of displays for ifconfig on its own
/sbin/ifconfig eth0
The path to ifconfig
--in terminal, check
    locate ifconfig
    /sbin/ifconfig
    /usr/share/man/man8/ifconfig.8.gz
User avatar
DrHu
Level 16
Level 16
 
Posts: 6611
Joined: Wed Jun 17, 2009 8:20 pm

Re: Linux Mint 7 Gloria XFCE Networking Problem

Postby orc_dragoon on Fri Jul 31, 2009 2:37 pm

/sbin/ifconfig
/usr/share/man/man8/ifconfig.8.gz


Those are the results when I did locate ifconfig.


Im kinda lost on the rest.
orc_dragoon
Level 1
Level 1
 
Posts: 7
Joined: Fri Jul 31, 2009 2:46 am

Re: Linux Mint 7 Gloria XFCE Networking Problem

Postby altair4 on Fri Jul 31, 2009 3:16 pm

WAIT :!: :!: :!: :!:

Don't be updating the kernel or grub. Please state the nature of the problem please. Why are you trying to disable IPV6. Is this a firefox only problem or do you have other networking issues.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5833
Joined: Tue Feb 03, 2009 10:27 am

Re: Linux Mint 7 Gloria XFCE Networking Problem

Postby orc_dragoon on Fri Jul 31, 2009 3:23 pm

I changed it, because I heard ipv6 cant support opera and I was having network problems before I messed with the kernel.
orc_dragoon
Level 1
Level 1
 
Posts: 7
Joined: Fri Jul 31, 2009 2:46 am

Re: Linux Mint 7 Gloria XFCE Networking Problem

Postby orc_dragoon on Fri Jul 31, 2009 8:22 pm

since everyone said I shouldnt touch the kernel I took the time to re-install Linux Mint 7 XFCE CE in its default form, Im dual booting, but Im still not able to connect to the internet or get updates.
orc_dragoon
Level 1
Level 1
 
Posts: 7
Joined: Fri Jul 31, 2009 2:46 am

Re: Linux Mint 7 Gloria XFCE Networking Problem

Postby altair4 on Sat Aug 01, 2009 8:06 am

Do you connect directly to the internet or are you connected to a router?
Are you wired or wireless?
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5833
Joined: Tue Feb 03, 2009 10:27 am

Re: Linux Mint 7 Gloria XFCE Networking Problem

Postby orc_dragoon on Sat Aug 01, 2009 8:23 am

Im connected to a router.
Wired for now, but when I got to my other household Ill be wireless.
orc_dragoon
Level 1
Level 1
 
Posts: 7
Joined: Fri Jul 31, 2009 2:46 am

Re: Linux Mint 7 Gloria XFCE Networking Problem

Postby altair4 on Sat Aug 01, 2009 9:47 am

You're not even getting an ip adddress from the router and I have no idea why. You might want to post the output of the following in the hope that someone eventually sees what's wrong here.

You said you were dual booting. If it's with windows:
Open Command Prompt
Type ipconfig /all

Back in Mint:
Open Terminal
Type cat /etc/network/interfaces
Type cat /etc/resolv.conf
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5833
Joined: Tue Feb 03, 2009 10:27 am

Re: Linux Mint 7 Gloria XFCE Networking Problem

Postby orc_dragoon on Sat Aug 01, 2009 4:35 pm

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Josh>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : Josh-eeepc
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection 2:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Atheros AR8132 PCI-E Fast Ethernet C
ontroller
Physical Address. . . . . . . . . : 00-26-18-2D-C2-63

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Atheros AR9285 Wireless Network Adap
ter
Physical Address. . . . . . . . . : 00-25-D3-0A-13-88
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.0.195
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DNS Servers . . . . . . . . . . . : 192.168.0.1
Lease Obtained. . . . . . . . . . : Saturday, August 01, 2009 3:21:04 PM

Lease Expires . . . . . . . . . . : Monday, January 18, 2038 10:14:07 PM


C:\Documents and Settings\Josh>

--------------------------------------------------------------------------------------
auto lo
iface lo inet loopback


iface pan0 inet dhcp

auto pan0

------------------------------------------------
josh@josh-eee ~ $ cat /etc/resolv.conf
cat: /etc/resolv.conf: No such file or directory
-------------------------------------------
Also if this is important, this is a Asus eeepc, EEEpc 1005hab.
orc_dragoon
Level 1
Level 1
 
Posts: 7
Joined: Fri Jul 31, 2009 2:46 am

Re: Linux Mint 7 Gloria XFCE Networking Problem

Postby altair4 on Sat Aug 01, 2009 4:48 pm

I would like to reccomend 2 things:

Change your topic to Linux Mint 7 Gloria XFCE Networking Problem - Atheros
You'll get many more people who have this somewhat problematic card to respond.

Second, you may want to look at this:
Asus Eee 1005HA - Cannot get ethernet to work [SOLVED] :
viewtopic.php?f=90&t=29460&start=0&st=0&sk=t&sd=a
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5833
Joined: Tue Feb 03, 2009 10:27 am

Re: Linux Mint 7 Gloria XFCE Networking Problem - Atheros

Postby orc_dragoon on Sat Aug 01, 2009 5:32 pm

Changed the topic title and that thread is really complicated, can you maybe dum it up some?
orc_dragoon
Level 1
Level 1
 
Posts: 7
Joined: Fri Jul 31, 2009 2:46 am

Re: Linux Mint 7 Gloria XFCE Networking Problem - Atheros

Postby altair4 on Sun Aug 02, 2009 8:20 am

You know, Google is your friend :) .

As more concise version: http://ubuntuforums.org/showpost.php?p= ... ostcount=2

Re: Asus Eee 1008 Ha wireless lan driver
to get the wired eth0 you need the new atheros driver atl1e, which has to be compiled. Then once you have that you can just install linux-backports-modules-jaunty from the Unsupported Updates repository. There are a few errors compiling the atheros driver, but these can be ignored safely.

using some computer that has network and a usb stick:
1. go to http://partner.atheros.com/Drivers.aspx
2. download [459]AR813X-linux-v1.0.0.9.tar.gz
3. put that file on the USB stick and then plug that insto your Eee

Then on the Eee:
1. copy the driver tarball file to /tmp
2. Open Terminal
cd /tmp
tar -xvzf \[459\]AR813X-linux-v1.0.0.9.tar.gz
[ignore gzip errors]
make
sudo make install
[ignore error about permissions]
3. sudo modprobe atl1e
4. You should now have a eth0 (ifconfig -a) - wired ethernet. Hook up a cable and get an IP addr.

get wlan0 up:
5. go to Administration > Software Sources > Updates and check off "Unsupported Updates (jaunty-backports)", .
6. sudo apt-get install linux-backports-modules-jaunty
7. reboot

Once you reboot, you should have wireless showing up in the top status bar.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5833
Joined: Tue Feb 03, 2009 10:27 am

Re: Linux Mint 7 Gloria XFCE Networking Problem - Atheros

Postby yackerena on Sun Dec 13, 2009 3:38 am

Are there any cons to purchasing an ethernet adapter versus an actual ethernet port? The ethernet on my Dell Dimension 4550 has been dead for quite some time now. I am looking into purchasing an ethernet/usb adapter, since the usb ports work just fine. Are there any cons to purchasing just an adapter versus an actual ethernet port?
_____________
matrimonial
yackerena
Level 1
Level 1
 
Posts: 1
Joined: Fri Dec 11, 2009 2:15 am

Re: Linux Mint 7 Gloria XFCE Networking Problem - Atheros

Postby ipernar on Fri Dec 18, 2009 7:50 am

Try restarting modem/router
"Chicks come and go but you will always have your PS3. "
User avatar
ipernar
Level 2
Level 2
 
Posts: 91
Joined: Fri Nov 20, 2009 1:08 pm
Location: Zagreb Croatia

Linux Mint is funded by ads and donations.
 

Return to Ethernet

Who is online

Users browsing this forum: wilky and 2 guests