NFS shares not mounted at boot

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read this

NFS shares not mounted at boot

Postby chuck_theobald on Mon Nov 12, 2012 9:49 pm

I am running Linux Mint 13 and have several entries in /etc/fstab. I've also permitted these machines to mount on the file server. It seems that fstab is not getting processed at boot time, nothing beyond the system file systems are mounted. aptitude is showing that nfs-client is installed.

Code: Select all
lab-3 ~ # more /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda3 during installation
UUID=f5b76058-9448-4a06-ae54-03156c78cb7c /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda4 during installation
UUID=c9f55591-50f4-4091-85ca-d7afb7edfb8b none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

bordeaux:/raid/data0/vxfsvol/home /mnt/bordeaux/home nfs defaults,acl,intr 0 0
bordeaux:/raid/data0/vxfsvol/staff /mnt/bordeaux/staff nfs defaults,acl,intr 0 0
bordeaux:/raid/data0/vxfsvol/public /mnt/bordeaux/public nfs defaults,acl,intr 0 0
bordeaux:/mnt/sdd1 /mnt/sdd1 nfs defaults,acl,intr 0 0
bordeaux:/mnt/sde1 /mnt/sde1 nfs defaults,acl,intr 0 0
bordeaux:/mnt/sdd2 /mnt/sdd2 nfs defaults,acl,intr 0 0
##bdl-xserve:/Volumes/bdl-xserve-raid2/mri /mnt/bdl/mri nfs defaults,acl,intr 0 0
##bdl-xserve:/Volumes/VTrakData1/VisTac /mnt/bdl/vistac nfs defaults,acl,intr 0 0
##bdl-xserve:/Volumes/VTrakData1/eri_dti /mnt/bdl/eri_dti nfs defaults,acl,intr 0 0
##cogneuro78:/Volumes/CogneuroRAID2/home1 /mnt/cogneuro78/Volumes/CogneuroRAID2/home1 nfs defaults,acl,intr 0 0
##cogneuro78:/Volumes/CogneuroRAID2/home2 /mnt/cogneuro78/Volumes/CogneuroRAID2/home2 nfs defaults,acl,intr 0 0
##cogneuro78:/Volumes/CogneuroRAID3/home3 /mnt/cogneuro78/Volumes/CogneuroRAID3/home3 nfs defaults,acl,intr 0 0
##cogneuro78:/Volumes/CogneuroRAID4/home4 /mnt/cogneuro78/Volumes/CogneuroRAID4/home4 nfs defaults,acl,intr 0 0
lab-3 ~ #


Issuing a "mount -a" on the command line does get these mounted, albeit with confusing messaging:

Code: Select all
lab-3 ~ # mount -a
mount.nfs: /mnt/bordeaux/public is busy or already mounted
mount.nfs: access denied by server while mounting (null)
mount.nfs: access denied by server while mounting (null)
mount.nfs: /mnt/sdd2 is busy or already mounted
lab-3 ~ # mount
/dev/sda3 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
rpc_pipefs on /run/rpc_pipefs type rpc_pipefs (rw)
bordeaux:/raid/data0/vxfsvol/home on /mnt/bordeaux/home type nfs (rw,acl,intr,addr=128.223.78.130)
bordeaux:/raid/data0/vxfsvol/staff on /mnt/bordeaux/staff type nfs (rw,acl,intr,addr=128.223.78.130)
bordeaux:/mnt/sde1 on /mnt/sde1 type nfs (rw,acl,intr,addr=128.223.78.130)
bordeaux:/mnt/sdd1 on /mnt/sdd1 type nfs (rw,acl,intr,addr=128.223.78.130)
bordeaux:/mnt/sdd2 on /mnt/sdd2 type nfs (rw,acl,intr,addr=128.223.78.130)
bordeaux:/raid/data0/vxfsvol/public on /mnt/bordeaux/public type nfs (rw,acl,intr,addr=128.223.78.130)
lab-3 ~ #


I need these to be processed at boot time, since the home directories of network users are shared via NFS. Any suggestions? This setup works on every other Linux machine I've got, I am just missing the piece to make it work on Mint.
chuck_theobald
Level 1
Level 1
 
Posts: 2
Joined: Mon Nov 12, 2012 9:32 pm

Linux Mint is funded by ads and donations.
 

Re: NFS shares not mounted at boot

Postby chuck_theobald on Tue Nov 13, 2012 8:01 pm

Okay, so this is bizarre. If I include a non-NFS share after the NFS shares in /etc/fstab, all shares are mounted correctly at boot time. I have an NFTS partition on /dev/sda1, so I updated /etc/fstab like so:
Code: Select all
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda2 during installation
UUID=b0c6de79-d9b3-47b0-a289-389e34add38d /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda3 during installation
UUID=567013d9-9b47-4c00-a2e4-3aacf6e25941 none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

bordeaux:/raid/data0/vxfsvol/home /mnt/bordeaux/home nfs defaults,acl 0 0
bordeaux:/raid/data0/vxfsvol/staff /mnt/bordeaux/staff nfs defaults,acl 0 0
bordeaux:/raid/data0/vxfsvol/public /mnt/bordeaux/public nfs defaults,acl 0 0
bordeaux:/mnt/sdd1 /mnt/sdd1 nfs defaults,acl 0 0
bordeaux:/mnt/sde1 /mnt/sde1 nfs defaults,acl 0 0
bordeaux:/mnt/sdd2 /mnt/sdd2 nfs defaults,acl 0 0
##bdl-xserve:/Volumes/bdl-xserve-raid2/mri /mnt/bdl/mri nfs defaults,acl 0 0
##bdl-xserve:/Volumes/VTrakData1/VisTac /mnt/bdl/vistac nfs defaults,acl 0 0
##bdl-xserve:/Volumes/VTrakData1/eri_dti /mnt/bdl/eri_dti nfs defaults,acl 0 0
##cogneuro78:/Volumes/CogneuroRAID2/home1 /mnt/cogneuro78/Volumes/CogneuroRAID2/home1 nfs defaults,acl 0 0
##cogneuro78:/Volumes/CogneuroRAID2/home2 /mnt/cogneuro78/Volumes/CogneuroRAID2/home2 nfs defaults,acl 0 0
##cogneuro78:/Volumes/CogneuroRAID3/home3 /mnt/cogneuro78/Volumes/CogneuroRAID3/home3 nfs defaults,acl 0 0
##cogneuro78:/Volumes/CogneuroRAID4/home4 /mnt/cogneuro78/Volumes/CogneuroRAID4/home4 nfs defaults,acl 0 0
/dev/sda1 /mnt/sda1 ntfs defaults 0 0

After reboot, all the shares are correctly mounted. Could this be upstart-related?
chuck_theobald
Level 1
Level 1
 
Posts: 2
Joined: Mon Nov 12, 2012 9:32 pm

Re: NFS shares not mounted at boot

Postby aifesteves on Wed Mar 20, 2013 7:20 am

Try installing nfs-common.

Code: Select all
sudo apt-get install nfs-common

on the command line.
It worked for me after that.
aifesteves
Level 1
Level 1
 
Posts: 2
Joined: Wed Mar 20, 2013 7:16 am


Return to Other networking topics

Who is online

Users browsing this forum: No registered users and 8 guests