Cannot get Huawei E 220 to connect

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read this

Cannot get Huawei E 220 to connect

Postby mbeenham on Mon Dec 10, 2012 12:46 pm

System is Mint 13 Maya 32 bit

I have an E220 and an E173 dongle.
The E173 initialises and connects fine the E220 does not.
I switch the same SIM between dongles.
Both dongles work fine on a friend's XP PC in the same location :oops: (again with the same SIM so I reckon SIM and dongles are all fine.
I have the same problem on another MINT 13 laptop.

lsusb output:

Bus 002 Device 010: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E230/E270/E870 HSDPA/HSUPA Modem


and here's a snip from syslog.log with the E220:

Dec 10 16:20:14 rivendell NetworkManager[787]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) scheduled...
Dec 10 16:20:14 rivendell NetworkManager[787]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) started...
Dec 10 16:20:14 rivendell NetworkManager[787]: <info> (ttyUSB0): device state change: prepare -> need-auth (reason 'none') [40 60 0]
Dec 10 16:20:14 rivendell NetworkManager[787]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) complete.
Dec 10 16:20:14 rivendell NetworkManager[787]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) scheduled...
Dec 10 16:20:14 rivendell NetworkManager[787]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) started...
Dec 10 16:20:14 rivendell NetworkManager[787]: <info> (ttyUSB0): device state change: need-auth -> prepare (reason 'none') [60 40 0]
Dec 10 16:20:14 rivendell NetworkManager[787]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) complete.
Dec 10 16:20:14 rivendell modem-manager[751]: <info> (ttyUSB0) opening serial port...
Dec 10 16:20:14 rivendell modem-manager[751]: <info> Modem /org/freedesktop/ModemManager/Modems/6: state changed (disabled -> enabling)
Dec 10 16:20:14 rivendell modem-manager[751]: <info> (ttyUSB1) opening serial port...
Dec 10 16:20:14 rivendell modem-manager[751]: <info> (ttyUSB0): using text mode for SMS
Dec 10 16:20:14 rivendell modem-manager[751]: <info> Modem /org/freedesktop/ModemManager/Modems/6: state changed (enabling -> enabled)
Dec 10 16:20:14 rivendell NetworkManager[787]: <info> WWAN now enabled by management service
Dec 10 16:20:14 rivendell modem-manager[751]: <info> Modem /org/freedesktop/ModemManager/Modems/6: state changed (enabled -> registered)
Dec 10 16:20:54 rivendell NetworkManager[787]: <warn> GSM connection failed: (32) Serial command timed out
Dec 10 16:20:54 rivendell NetworkManager[787]: <info> (ttyUSB0): device state change: prepare -> failed (reason 'unknown') [40 120 1]
Dec 10 16:20:54 rivendell NetworkManager[787]: <warn> Activation (ttyUSB0) failed.
Dec 10 16:20:54 rivendell NetworkManager[787]: <info> (ttyUSB0): device state change: failed -> disconnected (reason 'none') [120 30 0]
Dec 10 16:20:54 rivendell NetworkManager[787]: <info> (ttyUSB0): deactivating device (reason 'none') [0]
Dec 10 16:20:54 rivendell NetworkManager[787]: nm_system_iface_flush_routes: assertion `ifindex > 0' failed
Dec 10 16:20:54 rivendell NetworkManager[787]: nm_system_iface_flush_addresses: assertion `ifindex > 0' failed


I've googled and searched this forum, spent ages but haven't found any information except that E220 should work.
Has anybody any hints or steers - I'm pretty 'nix familiar but not that familiar with USB mobile broadband dongles.
TIA
mbeenham
Level 1
Level 1
 
Posts: 6
Joined: Mon Dec 10, 2012 12:23 pm

Linux Mint is funded by ads and donations.
 

Re: Cannot get Huawei E 220 to connect

Postby Mozenrath on Mon Dec 10, 2012 5:27 pm

I don't know if this helps, but in my search for Huawei E366 linux compatibility, I came across this guide for setting up Huawei cards in Linux. Maybe it'll help?

https://docs.google.com/viewer?a=v&q=ca ... 1aFfosz7nw
Mozenrath
Level 4
Level 4
 
Posts: 212
Joined: Thu Jun 17, 2010 12:41 am

Re: Cannot get Huawei E 220 to connect

Postby mbeenham on Tue Dec 11, 2012 4:29 am

Thanks for that, I read the document and downloaded the installation but it doesn't seem to me to be relevant to Mint Network Manager - references Fedora modem setup.
However I'll give it a try later and let you know.
Meanwhile if anybody has had any success getting Mint Network Manager talking to the E220 I'd be grateful for any hints...
TIA
mbeenham
Level 1
Level 1
 
Posts: 6
Joined: Mon Dec 10, 2012 12:23 pm

Re: Cannot get Huawei E 220 to connect

Postby mbeenham on Tue Dec 11, 2012 10:14 am

OK here's an update.
Having installed the package referred to above the device is no longer available in Network Manager.
Looking at syslog when the device is plugged in this is the conversation that ensues:
Dec 11 13:58:41 rivendell kernel: [ 2219.480043] usb 2-10: new full-speed USB device number 7 using ohci_hcd
Dec 11 13:58:42 rivendell mtp-probe: checking bus 2, device 7: "/sys/devices/pci0000:00/0000:00:02.0/usb2/2-10"
Dec 11 13:58:42 rivendell mtp-probe: bus: 2, device: 7 was not an MTP device
Dec 11 13:58:42 rivendell kernel: [ 2219.688997] scsi8 : usb-storage 2-10:1.0
Dec 11 13:58:42 rivendell HWActivator: Daemon already running
Dec 11 13:58:42 HWActivator: last message repeated 2 times
Dec 11 13:58:42 rivendell kernel: [ 2219.768130] usb 2-10: USB disconnect, device number 7
Dec 11 13:58:42 rivendell kernel: [ 2220.440043] usb 2-10: new full-speed USB device number 8 using ohci_hcd
Dec 11 13:58:43 rivendell mtp-probe: checking bus 2, device 8: "/sys/devices/pci0000:00/0000:00:02.0/usb2/2-10"
Dec 11 13:58:43 rivendell kernel: [ 2220.650348] option 2-10:1.0: GSM modem (1-port) converter detected
Dec 11 13:58:43 rivendell kernel: [ 2220.650561] usb 2-10: GSM modem (1-port) converter now attached to ttyUSB0
Dec 11 13:58:43 rivendell kernel: [ 2220.652752] option 2-10:1.1: GSM modem (1-port) converter detected
Dec 11 13:58:43 rivendell kernel: [ 2220.652934] usb 2-10: GSM modem (1-port) converter now attached to ttyUSB1
Dec 11 13:58:43 rivendell kernel: [ 2220.654953] scsi11 : usb-storage 2-10:1.2
Dec 11 13:58:43 rivendell mtp-probe: bus: 2, device: 8 was not an MTP device
Dec 11 13:58:43 rivendell HWActivator: Daemon already running
Dec 11 13:58:43 HWActivator: last message repeated 6 times
Dec 11 13:58:43 rivendell udevd[2367]: kernel-provided name 'ttyUSB1' and NAME= 'ttyUSB_utps_pcui' disagree, please use SYMLINK+= or change the kernel to provide the proper name
Dec 11 13:58:43 rivendell HWActivator: Daemon already running
Dec 11 13:58:43 rivendell udevd[2366]: kernel-provided name 'ttyUSB0' and NAME= 'ttyUSB_utps_modem' disagree, please use SYMLINK+= or change the kernel to provide the proper name
Dec 11 13:58:43 rivendell HWActivator: Daemon already running
Dec 11 13:58:44 rivendell kernel: [ 2221.660985] scsi 11:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2
Dec 11 13:58:44 rivendell HWActivator: Daemon already running
Dec 11 13:58:44 rivendell HWActivator: Daemon already running
Dec 11 13:58:44 rivendell kernel: [ 2221.696073] sr2: scsi-1 drive
Dec 11 13:58:44 rivendell kernel: [ 2221.698363] sr 11:0:0:0: Attached scsi CD-ROM sr2
Dec 11 13:58:44 rivendell kernel: [ 2221.698694] sr 11:0:0:0: Attached scsi generic sg4 type 5
Dec 11 13:58:44 rivendell HWActivator: Daemon already running
Dec 11 13:58:44 HWActivator: last message repeated 3 times
Dec 11 13:58:44 rivendell HWActivator: HW load_for_dynamic_pid start
Dec 11 13:58:44 rivendell HWActivator: load_for_dynamic_pid is called start
Dec 11 13:58:44 rivendell HWActivator: load_for_dynamic_pid is called end
Dec 11 13:58:44 rivendell HWActivator: HW load_for_dynamic_pid end



In the bit about 1/2 way down where it mentions that tty names disagree and to use SYMLINK: This is coming from udevd and I am starting to get a bit out of my depth. Do I need to edit a rules file and if so what do I need to look for to change to move the game on? Help anybody?

The documention carries on (in Fedora speak) to set up a modem on a tty. Whilst this is all very interesting I don't want to go down a blind alley.
Maybe nobody is running an E220 on Mint 13 and it's not been provided for? How can I tell?

I could always sell the device to an MS user as it works perfectly on XP, but I don't like to give up without trying.
TIA
mbeenham
Level 1
Level 1
 
Posts: 6
Joined: Mon Dec 10, 2012 12:23 pm

Re: Cannot get Huawei E 220 to connect

Postby mank_in on Wed Dec 12, 2012 1:21 pm

Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: Cannot get Huawei E 220 to connect

Postby mbeenham on Fri Dec 14, 2012 8:24 am

@mank
Thanks!
That did it - but how I missed this bug report in Launchpad I don't know.
It seems that support for E220 is well and truly busted in Modemmanager 5.
Until an update gets issued I will just do the workround:

cat /dev/ttyUSB1

Which works for me fine and is no hassle.
mbeenham
Level 1
Level 1
 
Posts: 6
Joined: Mon Dec 10, 2012 12:23 pm

[SOLVED]Re: Cannot get Huawei E 220 to connect

Postby mbeenham on Sat Jan 05, 2013 2:08 pm

Just thought I'd follow up to say the Huawei E220 works fine on Mint 14.1 so modemmanager V6 has fixed the bug.
mbeenham
Level 1
Level 1
 
Posts: 6
Joined: Mon Dec 10, 2012 12:23 pm

Linux Mint is funded by ads and donations.
 

Return to Other networking topics

Who is online

Users browsing this forum: PeeGee and 3 guests