Network manager not running

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help

Network manager not running

Postby Honayo on Tue Dec 11, 2012 8:18 pm

Network manager not running after updates but I can connect both wired and wirelesly when using the live USB to boot. Just not upon booting from the HD. I'm on a Dell D630 running Mint 13 only and using a Netgear WG511T wireless card.
I've searched for hours but found nothing that worked. It's as if network manager doesn't exist any longer. Any ideas would be appreciated.

tried to restart network manager with this: "sudo service networkmanager start"

Here are the results:
[sudo] password for kim:
networkmanager: unrecognized service
Registered Linux user #453081
Honayo
Level 1
Level 1
 
Posts: 10
Joined: Tue Dec 08, 2009 6:51 pm
Location: Southern Arizona desert

Linux Mint is funded by ads and donations.
 

Re: Network manager not running

Postby mank_in on Wed Dec 12, 2012 10:55 am

i think the correct one is :
Code: Select all
sudo service network-manager restart


this one is documentation : https://help.ubuntu.com/community/NetworkManager
Image
Sorry for my bad English , I am Indonesian.
User avatar
mank_in
Level 6
Level 6
 
Posts: 1346
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

SOLVED!!!!!!! Network manager not running

Postby Honayo on Thu Dec 13, 2012 10:02 pm

Thank you mank_in.
I re-installed Maya on my Dell and opted to keep the existing files instead of overwriting with new on a couple of packages in the many updates. All is well on mine and I did the same on my daughters Acer last night. Both work fine with both wireless and wired connections. Same issue on both machines after some updates. Gone are the days of blindly installing every update but would really like to know exactly what caused it. There are lots of other posts recently with same or similar issues.
Registered Linux user #453081
Honayo
Level 1
Level 1
 
Posts: 10
Joined: Tue Dec 08, 2009 6:51 pm
Location: Southern Arizona desert

Re: Network manager not running

Postby SlideRuleUser on Wed Feb 20, 2013 11:04 am

Two days ago I tried to establish a dialup connection, which was not successful. The next morning when I started the laptop up I saw the message "waiting for network manager to start" followed by a second one saying it would wait an additional 60 seconds. When the startup finished I found that there were no network connections, the network connection icon stated that the network manager was not running, and the control panel had no icon for the network manager. Obviously, the network manager was somehow disabled.

This does not make me comfortable using Linux Mint 14 as a primary operating system. :(

I'm now running this laptop on Win7 so that I can have internet access, and the Linux Mint 14 hard drive has been set aside until I can find a way to restore the Network Manager to the startup queue. Looking at a number of blogs I see that this is a somewhat common problem.
SlideRuleUser
Level 1
Level 1
 
Posts: 4
Joined: Wed Feb 20, 2013 10:54 am

Re: Network manager not running

Postby robert-e on Wed Feb 20, 2013 2:32 pm

This happened to me when I was twiddling about trying to get the cell fone tethering (see my recent post re verizon). The solution was to open the Network tab in the menu and delete all the dial up settings, and then reboot. I noticed that when network manager showed up in the bar, that the wireless info tab was blank. I imagine when I go to use the wireless, I will have to do all the passwords over again...or maybe not, since while poking around, I found the file where that login info was kept, and it had a whole load of stuff in it.

Regards,
Bob
robert-e
Level 3
Level 3
 
Posts: 141
Joined: Fri Nov 27, 2009 1:38 am

Re: Network manager not running

Postby SlideRuleUser on Thu Feb 21, 2013 10:03 am

I did get the network manager to run after using the "sudo service network-manager restart" mentioned earlier in this thread. But, it does not reestablish it in the startup queue, and that's a bit of a problem as it takes almost two minutes longer for startup while it sits there waiting for the networks to be configured. I'll try your suggestion of deleting all wired networks later when I have the time to hack my way through this. :|
SlideRuleUser
Level 1
Level 1
 
Posts: 4
Joined: Wed Feb 20, 2013 10:54 am

Re: Network manager not running

Postby robert-e on Thu Feb 21, 2013 11:39 am

just a reminder...delete the network configurations using the tab in Menu-->All-->Network NOT the one in Menu-->All-->Network Configuration (which is the same as "Edit Connections" in the Network Manager utility.
Just to be sure ;)

Regards,
Bob
robert-e
Level 3
Level 3
 
Posts: 141
Joined: Fri Nov 27, 2009 1:38 am

Re: Network manager not running

Postby SlideRuleUser on Fri Feb 22, 2013 11:06 am

While experimenting with various ideas, I happened to press the F1 and F2 buttons while the "Waiting for Network Configuration" message was being displayed. That resulted in a listing of the processes that were being executed during startup, and the one it was hanging up on was "Starting Configure Virtual Network Devices". Not certain if that's at all helpful, but it's a bit more information for someone to work with.

The fact that this problem has persisted for over a year with various Linux distributions is troubling. I would have thought that something like this would have been remedied by now. I've actually spent more time on this one issue than I have with any Windows problem of recent years, and there's still no solution in sight. :(

Chris
SlideRuleUser
Level 1
Level 1
 
Posts: 4
Joined: Wed Feb 20, 2013 10:54 am

Re: Network manager not running

Postby SlideRuleUser on Fri Feb 22, 2013 11:31 am

Okay, deleting the network configurations as you described did clear out the startup problem, and the machine starts up with the wireless/WiFi working. :D

When I deleted the network configurations, I happened to notice that there were TWO instances of "wired connection" listed below the "wireless connection". After I disabled all three configurations, the second instance of "wired connection" became "point-to-point connection". Hmmmm.... :|
SlideRuleUser
Level 1
Level 1
 
Posts: 4
Joined: Wed Feb 20, 2013 10:54 am

Re: Network manager not running

Postby derekscottwoods on Mon Apr 22, 2013 10:33 am

Hello,

I developed this same problem (among others) almost seven months ago, (see previous post http://forums.linuxmint.com/viewtopic.php?f=53&t=113772&p=634753#p634753) but have just been restarting network manager every time, since I've been busy. Now seeking to tackle this problem. My first question is: when you refer to deleting network configurations, is that all the ones listed with IP addresses and aliases?

Thanks.
derekscottwoods
Level 1
Level 1
 
Posts: 5
Joined: Sun Sep 30, 2012 7:02 am

Re: Network manager not running

Postby rloftus on Tue Dec 16, 2014 3:34 pm

I just ran into this with my machine and found the solution. Go to Menu > Control Center > Internet and Network > Network > click to make changes >enter your root password > Wired (or Wireless) Connection > Properties . Make sure to un-check the box labeled "Enable roaming mode" and set Connection Settings > Configuration to "Automatic Configuration (DHCP)".

That this error would end up in a Mint update suggests someone was working on porting a version of Mint for mobile devices and accidentally inserted the wrong chunk of code into the update.
rloftus
Level 2
Level 2
 
Posts: 83
Joined: Sat Mar 02, 2013 6:09 pm

Re: Network manager not running

Postby harry26 on Wed Dec 17, 2014 3:18 am

after re-installing the driver then reboot the system and checking all connections where does the problem.
harry26
Level 1
Level 1
 
Posts: 30
Joined: Sat Nov 29, 2014 5:45 am

Linux Mint is funded by ads and donations.
 

Return to Other networking topics

Who is online

Users browsing this forum: No registered users and 5 guests