samba shared home directory instead of FAT32 media partition

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read this

samba shared home directory instead of FAT32 media partition

Postby MrCreosote on Tue Mar 12, 2013 7:23 pm

just went to browse my shared videos folder via my xbox and found i was browsing my linux mint home directory instead.
i assumed this was my mistake so i checked my shared folder settings, deleted the one that was sharing my home directory then added a new share, selected the path of my videos folder, which is on a separate internal HDD formatted as FAT32 and labelled as media, so i was navigating to /media/videos.
after pressing share it went back to the shared folders menu and instead of sharing my videos folder it had again shared my home directory, which isn't even on the same physical drive as the folder i wanted to share.
i repeated this a couple of times to make sure it wasn't something i was doing, but the same thing happened every time.
i have also shared another FAT32 partition called music, which is on the same physical drive as linux mint. this one shared fine.

i managed to fix it myself by manually editing the samba configuration file and rebooting, and my videos folder is now shared, but i thought i should share this information just in case this affects anyone else who may be sharing their entire home directory over their home network without knowing it.
MrCreosote
Level 1
Level 1
 
Posts: 4
Joined: Tue Mar 12, 2013 2:26 pm

Linux Mint is funded by ads and donations.
 

Re: samba shared home directory instead of FAT32 media parti

Postby altair4 on Wed Mar 13, 2013 6:50 am

I have no idea what operating system you are using but there are 2 types of samba shares one can create - Classic and Usershares. And for Classic shares there are a number of utilities you can use to create them. If you are using "Shared Folders" that is likely the source of your problem. It's broke.

My suggestion is to either use Nemo > Right Click a folder > Sharing Options ( assuming you are using Mint-Cinnamon ) or install a Samba utility that isn't broke:
Code: Select all
sudo apt-get install system-config-samba

Of course if you are using LMDE there is no system-config-samba so it's good you learned how to edit smb.conf directly.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5987
Joined: Tue Feb 03, 2009 10:27 am

Re: samba shared home directory instead of FAT32 media parti

Postby MrCreosote on Wed Mar 13, 2013 7:43 am

i'm using mint 14 MATE and i haven't installed any additional samba utilities, i've just enabled personal file sharing in preferences and used shared folders in administration to choose folders to share.
i found the samba config file in /etc/samba, right clicked it and selected "open as administrator" then edited the location of the second share.

thing is, i've configured samba so many times in so many ubuntu based distros, and this is the closest it's got to the file sharing options that came with the operating system just working "out of the box" without having to install additional samba config utlilities.
if this issue could be resolved and the option could be added to mount an external drive at startup without needing to manually edit fstab or use the utterly broken psydm then mint would be pretty close to perfection.
MrCreosote
Level 1
Level 1
 
Posts: 4
Joined: Tue Mar 12, 2013 2:26 pm

Re: samba shared home directory instead of FAT32 media parti

Postby altair4 on Wed Mar 13, 2013 8:06 am

i've just enabled personal file sharing in preferences and used shared folders in administration to choose folders to share.

Personal File Sharing is not Samba. It sets up a baby Apache file server to share only the Public folder of your home folder using mDNS to broadcast it's share. And like I said "Shared Folders" is broke.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5987
Joined: Tue Feb 03, 2009 10:27 am

Re: samba shared home directory instead of FAT32 media parti

Postby altair4 on Wed Mar 13, 2013 12:08 pm

FYI, I have submitted a bug report since you are now the 2nd person to have this issue. You can follow it here:
Shared Folders Does Not Share Selected Folder

BTW, there is a workaround for this if you want to use this utility. Don't open it through the Menu. Open Caja > Right click the folder you want to share > Select "Share Folder"
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5987
Joined: Tue Feb 03, 2009 10:27 am

Re: samba shared home directory instead of FAT32 media parti

Postby MrCreosote on Thu Mar 14, 2013 9:25 am

cool, i thought that shared folders had only become usable after enabling personal file sharing, but on closer inspection i see they're not connected. i see share folder in the context menu now and using that method to share seems to be working fine.
MrCreosote
Level 1
Level 1
 
Posts: 4
Joined: Tue Mar 12, 2013 2:26 pm


Return to Other networking topics

Who is online

Users browsing this forum: No registered users and 3 guests