Vista enterprise can't access samba share

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read this

Vista enterprise can't access samba share

Postby westcoastsunset on Fri Feb 03, 2012 3:52 pm

I have three computers in my home network

computerA: Linuxmint 11 LXDE hardwired network connection
computerB Linuxmint 11 with LXDE installed later wireless network connection
computerC Vista enterprise wireless connection

I would like to be able to access shares on my linux boxes from computerC. After some trouble I finally got the vista pc to see both linux boxes in network neighborhood by making sure the linux boxes were never the master browser. So far so good. Now, every time I click on computerB in vista's network neighborhood I get the password prompt. I enter the username and password this way:

username:computerb\username - using my unix username set up on computerb
password:<password> password for above named unix account

This doesn't work and I get the following error message in vista:

Code: Select all
Windows cannot access \\computerB

check the spelling of the name.  Otherwise there might be a problem with your network.  To try to identify and resolve network problems click diagnose.

error code 0x80070035
the network path was not found


when attempting to connect to computerA from computerC i get the following error:

Code: Select all
\\computerA is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

The account is not authorized to log in from this station.


Here are the smb.conf files for the linuxboxes:

computerA

Code: Select all
[global]
workgroup=WORKGROUP
netbios name=computerA
os level = 2
preferred master = No
local master = No
domain master = No
;security=user
encrypt passwords = yes
;map to guest = bad user
;usershare allow guests = yes
;client ntlmv2 auth = yes
log file=/var/log/samba.%m
max log size=50
username map=/etc/samba/usermap.txt

[homes]
guest ok=yes
read only=no

[cdrv]
path = /mnt
available = yes
browsable = yes
public = yes
writable = no

[cookie]
path = /
available = yes
browsable = no
public = no
writable = no
;valid users = <the unix acct I log into the machine with>


computerB

Code: Select all
#======================= Global Settings =======================

[global]

    workgroup = WORKGROUP
    netbios name = computerB
    server string = %h server (Samba, LinuxMint)
    os level = 2
    preferred master = No
    local master = No
    domain master = No
    dns proxy = no
    username map = /etc/samba/smbusers
    wins support = no
    client ntlmv2 auth = yes

#### Networking ####

    interfaces = wlan0 eth0
#   bind interfaces only = yes
    log file = /var/log/samba/log.%m

    max log size = 1000

    syslog = 0
    panic action = /usr/share/samba/panic-action %d
   
#### Authentication ####

    security = user
    map to guest = Bad Password
    encrypt passwords = yes
    passdb backend = tdbsam
    obey pam restrictions = yes
    unix password sync = yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
    pam password change = yes
    usershare allow guests = yes

#### share definitions ####

[homes]
   
    comment = Home Directories
    browseable = no

# By default, the home directories are exported read-only. Change the
# next parameter to 'no' if you want to be able to write to them.
;   read only = yes

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
;   create mask = 0700

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
;   directory mask = 0700

# By default, \\server\username shares can be connected to by anyone
# with access to the samba server. Un-comment the following parameter
# to make sure that only "username" can connect to \\server\username
# The following parameter makes sure that only "username" can connect
#
# This might need tweaking when using external authentication schemes
;   valid users = %S


wins support = no

[cdrv]
comment = Public Stuff
path = /mnt/cdrv
public = yes
writable = yes
printable = no
available = yes
browsable = no

[<my home share>]
path = /home/<my home share>
available = yes
browsable = yes
public = yes
writable = yes

[File System]
path = /
available = yes
browsable = yes
public = yes
writable = yes



I would like to be able to access shares on my linux boxes from the vista pc. I know the authentication sections of each smb.conf is probably messed up as i have been trying different settings for awhile. Anyone have any ideas?


also forgot to mention the router is actiontec from verizon fios

I have just tried to access computerA's shares from computerB which is a dualboot machine XP(sp3)/linuxmint 11 and it works fine.
westcoastsunset
Level 1
Level 1
 
Posts: 18
Joined: Mon Jul 18, 2011 12:17 pm

Linux Mint is funded by ads and donations.
 

Re: Vista enterprise can't access samba share

Postby altair4 on Fri Feb 03, 2012 4:56 pm

username:computerb\username - using my unix username set up on computerb
password:<password> password for above named unix account

It doesn't work that way. The unix account and the samba account are separated. If the unix account is named altair then to add altair to the samba database you need to run this command:
Code: Select all
sudo smbpasswd -a altair

It can be the same actual password if you want but it's not required.

On computerB you have "map to guest = Bad Password". You might want to set that back to the way it was with "map to guest = Bad User". That way an anonymous Windows client ( or a Linux client that insists on passing credentials without being asked ) will be converted to the default guest account cleanly.

A "network path not found" usually means the the samba services are not running or if they are the permissions along the entire path to the shared folder does not allow access to the remote user. On computerB what is the output of this command:
Code: Select all
smbtree


As for computerA it simply has too much stuff missing. And that's not the usual way you use the [homes] section. You might want to reset the smb.conf back to the defaults and look at this for some ideas on the [homes] share:
Using the [homes] Share in Samba: viewtopic.php?f=42&t=77063&p=448039

EDIT: You are allowing guest access to your root directory using Samba. That's not a good idea in my opinion but that's entirely up to you.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6152
Joined: Tue Feb 03, 2009 10:27 am

Re: Vista enterprise can't access samba share

Postby westcoastsunset on Fri Feb 03, 2012 5:26 pm

Code: Select all
WORKGROUP
   \\computerC      
   \\computerB            
      \\computerB\IPC$              IPC Service (computerB server (Samba, LinuxMint))
      \\computerB\File System       
      \\computerB\<unix acct home share>             
   \\computerA              
      \\computerA\<unix acct home share>             Home directory of <unix acct>
      \\ComputerA\IPC$              IPC Service (Samba 3.5.8)
      \\computerA\cdrv              
      \\computerA\homes


I did the smbpasswd command on both unix boxes. I actually did the command a few times, so maybe this is somehow corrupted. Not sure, but I still get the same errors. I do not get any errors when attempting to connect to computerA's shares from computerB when it is running XP sp3 (computerB is a dual boot machine)

As to the file shares, I had intended to secure them properly once I got basic sharing set up. My work ethic is always start simply and build on that.

The router is from verizon fios and its firewall works very well.
westcoastsunset
Level 1
Level 1
 
Posts: 18
Joined: Mon Jul 18, 2011 12:17 pm


Return to Other networking topics

Who is online

Users browsing this forum: No registered users and 3 guests