Mint won't boot after hard freeze; just Grub prompt

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help

Mint won't boot after hard freeze; just Grub prompt

Postby spearman on Sun Nov 07, 2010 12:52 pm

Hi. I have 64-bit Mint 9 installed inside Windows 7 with mint4win/wubi. Eariler today, Mint locked up on me. This has happened before so all I did was hold down the power button for a hard reset. That's never caused a problem before.

But today, when I tried to start Mint back, all I get after choosing it from the Windows Boot Manager menu is a Grub prompt. I don't get the Grub menu like I used to.

I've tried the sticky at the top of this forum about fixing a borked mint4win, but I don't have a "disks" subdirectory there (unless I'm in the wrong place, but wubildr.cfg seems to confirm my fears that the directory's gone).

That kind of scares me. It looks like something has deleted my Mint partition but I have no idea how it happened. It's not a big deal, I'm just curious to see if anything can be done about it. (I hope I'm wrong about the deleted partition though :?)
spearman
Level 1
Level 1
 
Posts: 3
Joined: Sun Nov 07, 2010 11:31 am

Linux Mint is funded by ads and donations.
 

Re: Mint won't boot after hard freeze; just Grub prompt

Postby oobetimer on Sun Nov 07, 2010 1:49 pm

User avatar
oobetimer
Level 7
Level 7
 
Posts: 1889
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle

Re: Mint won't boot after hard freeze; just Grub prompt

Postby spearman on Sun Nov 07, 2010 6:01 pm

Thanks for the reply. Those directions are similar to others I have read, but they have not worked. I get stuck at the step where you change to the "disks" directory.

After following (and changing a bit because of my folder name) the instructions in this thread I get this:
Code: Select all
sudo mount -o loop /win/linuxmint/disks/root.disk /vdisk
/win/linuxmint/disks/root.disk: No such file or directory


Unfortunately, I don't have the "disks" subdirectory so it's looking like I'm not going to be able to get it back. :( All I have are the "winboot" and "install" directories.

I wonder how that happened? :shock:
spearman
Level 1
Level 1
 
Posts: 3
Joined: Sun Nov 07, 2010 11:31 am

Re: Mint won't boot after hard freeze; just Grub prompt

Postby oobetimer on Mon Nov 08, 2010 10:20 am

spearman wrote:
Code: Select all
sudo mount -o loop /win/linuxmint/disks/root.disk /vdisk
/win/linuxmint/disks/root.disk: No such file or directory



A wrong path. Try this way:

mint@mint:~$ sudo mkdir /windows
mint@mint:~$ sudo mount /dev/sda1 /windows
mint@mint:~$ sudo mkdir /wubi
mint@mint:~$ sudo mount -o loop /windows/mint/disks/root.disk /wubi
mint@mint:~$ sudo chroot /wubi
root@mint:/# ls
...now you should be able to do something (copy, repair, ...)
root@mint:/#exit or Ctrl d
mint@mint:~$ sudo umount /wubi
mint@mint:~$ sudo umount /windows
mint@mint:~$
User avatar
oobetimer
Level 7
Level 7
 
Posts: 1889
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle

Re: Mint won't boot after hard freeze; just Grub prompt

Postby spearman on Mon Nov 08, 2010 11:22 am

Still no luck unfortunately.

I get this when /dev/sda1 is mounted as /windows

Code: Select all
sudo mount -o loop /windows/mint/disks/root.disk /wubi
/windows/mint/disks/root.disk: No such file or directory


My main Windows partition is /dev/sda3 but that doesn't work either.
spearman
Level 1
Level 1
 
Posts: 3
Joined: Sun Nov 07, 2010 11:31 am


Return to Installation & Boot

Who is online

Users browsing this forum: Google [Bot], Google Adsense [Bot], quilty2 and 14 guests