linux mint 8 fluxbox - GREAT but microphone problems

Forum rules
Before you post please read how to get help

linux mint 8 fluxbox - GREAT but microphone problems

Postby anderigs on Tue Mar 09, 2010 3:26 pm

Hi
installed mint fluxbox 8 on my eeepc 701 4G.
AND LOVE IT! It is SOOOOOO fast. (15secs login time compared to 40-60secs with gnome).
I have tried various distros with my fave to date having been easypeasy. But gnome is just too slow and heavy for this small box. Flux is perfect for me cos I love meddling around and knowing really whats happening. Got idesk nicely setup as nice alternative to nbr.

So all is cool EXCEPT I am really a dumbfckr when it comes to sound.
I installed skype from skype.com cos the repositories seemed not to be working for this one app.
And the playback is fine. But my microphone sounds like I am talking through a sock. Or several socks. Really muted and distorted. I tried various headsets. (and it worked fine before).
I have tried already to adjust the xfce-mixer settings (capture, e-Mic as capture, e-Mic boost, muted i-mic+boost). I have compared my /etc/modprobe.d/alsa-base.conf with the old one I had which was working in easypeasy times - no differences.
SOOOO what could it be?
In addition when I call arecord I get the following message:
ALSA lib pcm_direct.c:1439:(_snd_pcm_direct_get_slave_ipc_offset) Unknown slave PCM 810
arecord: main:608: audio open error: No such file or directory
ANY IDEAS?
Otherwise everything seems great - or at least I have an idea how to fix / tune.
Cheers
andE or, in this case, true dumbfckr
anderigs
Level 2
Level 2
 
Posts: 50
Joined: Mon Dec 28, 2009 5:54 am

Linux Mint is funded by ads and donations.
 

Re: linux mint 8 fluxbox - GREAT but microphone problems

Postby anderigs on Tue Mar 09, 2010 3:46 pm

Hi again
after much googling and some grepping in /etc I managed to fix it: I had to delete the file /etc/asound.conf and to make sure I rebooted although there was probably some daemon I could just have restarted.
Now sound works fine!!!!! (i,e. now arecord is working as is skype). :-))))))

No idea why asound.conf is installed.... it just gets in the way as far as I can tell...
But maybe somebody out there needs it...

Cheers
andE no longer such a dumbfckr ;-)
anderigs
Level 2
Level 2
 
Posts: 50
Joined: Mon Dec 28, 2009 5:54 am

Re: linux mint 8 fluxbox - GREAT but microphone problems

Postby Kendall on Tue Mar 09, 2010 8:48 pm

I just saw this thread and I'm very glad you got it fixed. I'll add the asound.conf thing to my notes and start looking into it later in the week.
User avatar
Kendall
Level 7
Level 7
 
Posts: 1580
Joined: Mon Nov 16, 2009 12:20 pm
Location: Asheville, NC, USA


Return to Others

Who is online

Users browsing this forum: No registered users and 1 guest