[confirmed][fixed] gDesklets is broken

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

[confirmed][fixed] gDesklets is broken

Postby lagagnon on Sat Jul 04, 2009 3:56 pm

The "gDesklets" package in the Mint repository is broken for Gloria. It requires Python 2.5 and Mint 7 has Python 2.6.2. It throws an error in this regard when launched from a terminal. I don't know who to message on this one so I though I'd post it on the forum...

Larry
User avatar
lagagnon
Level 7
Level 7
 
Posts: 1888
Joined: Wed Jun 17, 2009 7:38 pm
Location: an island in the Pacific...

Linux Mint is funded by ads and donations.
 

Re: gDesklets is broken

Postby clhodapp on Thu Jul 09, 2009 3:54 am

On my Gloria x64 system, it claims to depend on 2.6 <= python < 2.7 and installs fine. Maybe it's been updated?
clhodapp
Level 3
Level 3
 
Posts: 185
Joined: Wed Feb 04, 2009 3:57 am
Location: Tuscaloosa, AL

Re: gDesklets is broken

Postby emorrp1 on Fri Jul 10, 2009 11:11 am

Ok, so the gdesklets package is broken, for the following reasons:
1) Although it correctly depends on python >=2.6 and < 2.7, the /usr/bin/gdesklets script uses a /usr/bin/python2.5 shebang, rather than /usr/bin/python
2) Once this line has been changed, the file /usr/lib/gdesklets/gdesklets-daemon cannot be found, hence failing to connect to the daemon
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Re: gDesklets is broken

Postby clhodapp on Fri Jul 10, 2009 1:16 pm

Ok, then that's why it worked: I just happened to have python2.5 installed. If you do, it installs and runs fine. Maybe we should change the dependency and put it in our repo?
clhodapp
Level 3
Level 3
 
Posts: 185
Joined: Wed Feb 04, 2009 3:57 am
Location: Tuscaloosa, AL

Re: [confirmed] gDesklets is broken

Postby emorrp1 on Sun Jul 19, 2009 2:11 pm

ok, so this has been reported and fixed upstream: https://bugs.launchpad.net/ubuntu/+sour ... bug/350562
Unfortunately, it's only been fixed in karmic (gdesklets - 0.36.1-2ubuntu1) so for the moment at least, you have to stick to the workaround:
Code: Select all
apt install python2.5
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], karlchen, paviluf and 28 guests