[resolved] skype input volume resets to (near) mute

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help

[resolved] skype input volume resets to (near) mute

Postby Timmi on Wed Dec 09, 2009 1:44 pm

I use the "Sound Preferences" that is by default in the Favorites menu, to increase the Input Volume to 3/4 (very amplified) of the scrollbar, so that people can hear me nice and clear in Skype.

Only, if I close that utility, sometimes it will reset the sound input to near zero and people can't hear me and hang up before I have a chance to change it.

It has done this consistently after a reboot, and on occasion when I change a sound setting in Pidgin, and now, without Pidgin even running, has reset the sound input volume to zero simply by closing the "Sound Preferences" Utility.

Why is it not retaining my preferences... am I doing something wrong?
Or is there a way to fix this please?

(WORKAROUND FOUND)
Last edited by Timmi on Fri May 07, 2010 6:26 am, edited 2 times in total.
Timmi
Level 3
Level 3
 
Posts: 112
Joined: Tue Mar 10, 2009 1:04 pm

Linux Mint is funded by ads and donations.
 

Re: input volume resets to (near) mute

Postby emorrp1 on Mon Dec 14, 2009 11:03 am

skype > options > sound: deselect "allow skype to adjust mixer settings"
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Re: input volume resets to (near) mute

Postby Timmi on Tue Dec 15, 2009 2:01 pm

I found a workaround (doesn't resolve skype not doing this correctly, but makes everything usable):
uncheck the box in Skype 'allow skype to adjust volume mixer levels'
for some reason, this feature is not reliable, and user whould adjust these preferences manually via the volume controls found in favorite applications, and not via the skype interface.
Timmi
Level 3
Level 3
 
Posts: 112
Joined: Tue Mar 10, 2009 1:04 pm

Re: input volume resets to (near) mute

Postby Timmi on Tue Dec 15, 2009 2:21 pm

emorrp1 wrote:skype > options > sound: deselect "allow skype to adjust mixer settings"

Thank you... only, I'm not sure it is 'solved'. Only that I found a way to make everything work, by disabling some functionality. Sorry to nitpick... I'd rather let the experts decide if this constitutes a resolution.
Timmi
Level 3
Level 3
 
Posts: 112
Joined: Tue Mar 10, 2009 1:04 pm

Re: input volume resets to (near) mute

Postby emorrp1 on Tue Dec 15, 2009 2:35 pm

with skype being a proprietary application, there's nothing else can be done.
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Re: input volume resets to (near) mute

Postby Timmi on Mon Dec 21, 2009 5:56 pm

It's not solved. Here is the workaround that will make Skype work reliably until this little sound bug is fixed:

0) (I'm adding this "step-0" just in case you have a problem installing it from the "software manager")
My Mint8 Software Manager did not allow me to install skype after a complete reinstall (had a yellow check box to the left of it), I went to the skype website to download and install it skype com/download/skype/linux/choose/ selecting "Debian Lenny" and then install.

1)
Launch Skype, click on the little blue "S" icon in the bottom left, selected Options (or just press Ctrl+O in skype), in the list it presents you, go to Sound Devices, un-check the box labelled "allow skype to automatically adjust my mixer levels". After this, go to step 2 (even if you have already done step-2: because if you tried to make a call after that, the setting will have been reset by Skype).

2)
Now, adjust the microphone input volume to amplified (approx.) +75% past the unamplified mark (or 175% of level-1 non-amplified if you're a mathematician), using the "Sound" item that is in the Mint Favorites Menu by default (click on "Input" tab, then slide the slider 3/4 to the right).

If you use your computer's speakers, at this level, it will probably send your caller's voice back into the mic, giving them an echo. You can play around with this slider until you find a satisfactory level for your mic and your caller, sliding it between +60 and +90% range, I'd expect. Of course, if you use a headset, you won't have the feeding-back sound echo problem.
Timmi
Level 3
Level 3
 
Posts: 112
Joined: Tue Mar 10, 2009 1:04 pm

Re: input volume resets to (near) mute

Postby emorrp1 on Mon Dec 21, 2009 6:08 pm

So let me get this straight - a week later you post a "workaround" that's exactly what I told you a week ago, then turn the volume up and still complain it's not solved. I'll give you a clue: a "feature" that doesn't work properly for *anybody* (if it does work for anyone, let me know) is not a feature, it's a bug. The solution is to disable this bug.
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Re: input volume resets to (near) mute

Postby Timmi on Sun Dec 27, 2009 4:05 pm

emorrp1 wrote:So let me get this straight - a week later you post a "workaround" that's exactly what I told you a week ago, then turn the volume up and still complain it's not solved. I'll give you a clue: a "feature" that doesn't work properly for *anybody* (if it does work for anyone, let me know) is not a feature, it's a bug. The solution is to disable this bug.


Correct.
I did NOT receive an email that there had been a response to my post.
I did not see your post.
And I returned here just as a courtesy to let all know what I found out... and yes, when I did that, I did overlook your post.
I'm very sorry it didn't catch my attention.
I'm thankful that despite the frustration over the lack of attention that I have caused, that you are still kind enough to share your expertise.
Have a nice day.
;-)
Timmi
Level 3
Level 3
 
Posts: 112
Joined: Tue Mar 10, 2009 1:04 pm

Re: input volume resets to (near) mute

Postby emorrp1 on Mon Dec 28, 2009 12:26 pm

Fair enough, sorry I got a bit exasperated that day :oops:
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term site:forums.linuxmint.com
emorrp1
Level 8
Level 8
 
Posts: 2322
Joined: Thu Feb 26, 2009 8:58 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: aurelius, Bing [Bot], gibbs1984, Hecubus, nerdtron, sportsfan7700 and 23 guests