[upstream] Alltel UM175 - usb_modeswitch

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

[upstream] Alltel UM175 - usb_modeswitch

Postby sargenthp on Fri Jan 01, 2010 1:20 pm

Hello,

Found an issues with usb_modeswitch udev configuration file. The file is located at /etc/udev/rules.d/usb_modeswitch.rules

The installed file contains the following code:
SUBSYSTEM=="usb", SYSFS{idVendor}=="106c", SYSFS{idProduct}=="3b03", RUN+="/usr/sbin/usb_modeswitch --default-vendor 0x106c --default-product 0x3b03 --message-content 555342431234567824000000800008ff024445564348470000000000000000"


It turns out it needs to be (SYSFS -> ATTR):
SUBSYSTEM=="usb", ATTR{idVendor}=="106c", ATTR{idProduct}=="3b03", RUN+="/usr/sbin/usb_modeswitch --default-vendor 0x106c --default-product 0x3b03 --message-content 555342431234567824000000800008ff024445564348470000000000000000"


Before I made this change my Alltel UM175 modem would never settle on a device id. Every 2 seconds it would roll to a new device id.

Could this program also be added as part of the default install? Without this I cannot connect to the Internet.

Thanks!
sargenthp
Level 1
Level 1
 
Posts: 1
Joined: Fri Jan 01, 2010 1:08 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot], PussyCat and 40 guests