Language support (gnome-language-selector)

Forums for the LXDE Edition
Forum rules
Before you post please read this

Language support (gnome-language-selector)

Postby andycrofts on Sat Nov 23, 2013 12:58 pm

Hi.
I'm totally frustrated by this bit of jokeware*. :x
I've been trying to move 'suomi' (Finnish) above English, but below British English, as there aint no such animal as US English.

Not to an Englishman, anyway.

It'll either put suomi at the very top, or at the very bottom (i.e., ignored). After several dozen attempts, all made even worse by the Python-esque response time of some seconds, I give up!

Where's the config. file stored, so I can edit it manually? Don't ask me to check the ultra-minimal Mint documentation, I've had enough laughter for one day.

Currently searching filesystem for 'suomi' in the hope it'll give me a clue, but with my ancient system, I'll probably get a reply before 'find' finishes.
(*Reminded me of that old 'trick' in windows, where a dialog box pops up, but immediately moves out of the way on mouseover)

Seriously, help greatly appreciated
andycrofts
Level 1
Level 1
 
Posts: 4
Joined: Thu Jun 07, 2012 9:58 am
Location: Oulu, Finland

Linux Mint is funded by ads and donations.
 

Re: Language support (gnome-language-selector)

Postby MrBob22 on Sat Nov 23, 2013 10:38 pm

I could not find suomi listed on the language selector. Finnish was listed, but not installed.

On my system using Linux Mint 14, to change the order of languages, its a simple drag and drop the one you want ahead the others on the list. The system insists that the last used languge be "English" which is the default when your selected language does not have a translation.

I am not sure where any settings are stored, but the language data is in the following location:
/usr/share/language-selector/data
The data folder has several files but none of them are listed as config files per se.
Hope this helps some/ MrBob22
MrBob22
Level 2
Level 2
 
Posts: 69
Joined: Mon Mar 26, 2012 8:05 pm

Re: Language support (gnome-language-selector)

Postby andycrofts on Sun Nov 24, 2013 11:58 am

Thanks for the reply.
Yeah, mine says 'suomi' instead of Finnish, 'cos I enabled Finnish along with English on installation.
It's the 'final result' of gnome-language-selector I need. Maybe its a problem with Mint XFCE 15, because (IIRC) I could move 'Suomi' to where I wanted it om Mint Mate 13.
Now, I can't. It simply either has to be at the top, or at the bottom. Causes problems when I ssh into my Pi, as it replaces 'ä' with '?', so some scripts get nadgered.
andycrofts
Level 1
Level 1
 
Posts: 4
Joined: Thu Jun 07, 2012 9:58 am
Location: Oulu, Finland


Return to LXDE

Who is online

Users browsing this forum: No registered users and 2 guests