[SOLVED] Cannot connect to internet using Ethernet port

Forum rules
Before you post please read this

[SOLVED] Cannot connect to internet using Ethernet port

Postby llabtaem on Wed Jan 15, 2014 5:58 am

EDIT: Like I said I knew the answer had to be simple. After digging around some more I read a response in a post about how someone just shutdown their machine and unplugged the AC cord. I figured why not I'll try anything at this point. Well it turns out that was my problem. Hopefully this can help someone else out as well. Thank you all for your time.
____________________________________________________________________________________

Hello Linux Mint Debian Edition world, I am at my wits end. I have seen countless threads on this exact issue, but I believe mine to be completely different problem from what I was finding.

I am able to connect to the internet just fine with my wifi dongle, but through my ethernet port I cannot, and the reason I believe I cannot is because I have no eth0, only eth1 for some reason. I ran this command:

Code: Select all
sudo lspci -k|awk '/Ethernet|Network/,/Kernel/'


which gives me this output:

    02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 03)
    Subsystem: Biostar Microtech Int'l Corp Device 2309
    Kernel driver in use: r8169


I have ran this command:


Code: Select all
sudo ifconfig -a


which give me this output:

    eth1 Link encap:Ethernet HWaddr XX:XX:XX:XX:XX:XX
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    lo Link encap:Local Loopback
    inet addr:XXX.X.X.X Mask:XXX.X.X.X
    inet6 addr: ::X/XXX Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:33 errors:0 dropped:0 overruns:0 frame:0
    TX packets:33 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:4046 (3.9 KiB) TX bytes:4046 (3.9 KiB)

    wlan0 Link encap:Ethernet HWaddr XX:XX:XX:XX:XX:XX
    inet addr:XXX.XXX.X.XXX Bcast:XXX.XXX.X.XXX Mask:XXX.XXX.XXX.X
    inet6 addr: XXXX::XXX:XXX:XXXX:XXXX/XX Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:13713 errors:0 dropped:10 overruns:0 frame:0
    TX packets:8235 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:14257656 (13.5 MiB) TX bytes:1257065 (1.1 MiB)

*NOTE: I am using this machine right now as I type this with my wifi dongle. I just want to show what the output of the command which is showing I have no eth0.

I even tried this command:

Code: Select all
sudo ifconfig eth0 up


which of course being that I have no eth0 I get this error:

    eth0: ERROR while getting interface flags: No such device

here is my /etc/network/interface file

    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).

    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    allow-hotplug eth0
    #NetworkManager#iface eth0 inet dhcp

*NOTE: I did not modify this file in anyway.

I have tried so many other options I came a crossed. Like renewing IP addresses, power cycling the router and modem in general, re installing the driver, pinging my router, trying to connect to my router, and even yelled at it, but still I get nothing. I just don't know what else to do. I know this port works just fine, this is my HTPC and I had Linux Mint Olivia installed on it before switching to LMDE. I never had an issue like this before, usually it's the wireless setup that is problematic.

Now I know I am an idiot and the answer is probably right under my nose, but I could really use your help, any help would be greatly appreciated. Thank you.
Image
User avatar
llabtaem
Level 1
Level 1
 
Posts: 27
Joined: Fri Apr 06, 2012 12:21 am

Linux Mint is funded by ads and donations.
 

Return to Others

Who is online

Users browsing this forum: No registered users and 1 guest