keyboard layout switcher

Forum rules
Before you post please read this

keyboard layout switcher

Postby jose76c on Sun Apr 04, 2010 6:07 am

Hi all,

I am using latest Mint LXDE version and would like to have czech and us keyboard layout with ctrl alt switching. I can add keyboard layout switcher to the panel, but I found no way how to add the second layout - it stays only with layout selected "Keyboard layout" in Preferences.

I tried to config my xorg.conf but without any success.

Code: Select all
Section "InputDevice"
    Identifier "Keyboard1"
    Driver "Keyboard"

    Option "XkbModel" "pc104"
    Option "XkbLayout" "us,cz"
    Option "XKbOptions" "grp:alt_shift_toggle"
EndSection


Is there any way how to fix this?

Jose
jose76c
Level 1
Level 1
 
Posts: 2
Joined: Sun Apr 04, 2010 4:00 am

Linux Mint is funded by ads and donations.
 

Re: keyboard layout switcher

Postby senseiski on Sun Apr 11, 2010 9:53 am

As I have quite a experience with the switching layouts (I am Bulgarian), I finally have quite a good solution to this problem:
In my case it is adding
Code: Select all
setxkbmap -option grp:alt_shift_toggle -variant ,phonetic us,bg &

in the /home/username/.config/lxsession/LXDE/autostart file
You should just change bg to cz and eventually remove "-variant ,phonetic" if you do not have such preferences in czech layout :)
User avatar
senseiski
Level 1
Level 1
 
Posts: 34
Joined: Sun Jul 12, 2009 2:47 pm


Return to Others

Who is online

Users browsing this forum: No registered users and 1 guest