#SOLVED# Auto login on Mint 9 LXDE?

Forum rules
Before you post please read this

#SOLVED# Auto login on Mint 9 LXDE?

Postby p10 on Sat Jun 05, 2010 12:15 am

In the release notes for Mint 9 LXDE RC I read that it is possible to create auto login for LXDM. How do I go about creating this?
Last edited by p10 on Sat Jun 05, 2010 2:13 am, edited 2 times in total.
p10
Level 2
Level 2
 
Posts: 52
Joined: Fri Apr 04, 2008 4:13 am

Linux Mint is funded by ads and donations.
 

Re: Auto login on Mint 9 LXDE?

Postby Kendall on Sat Jun 05, 2010 1:29 am

Open the file manager as root, then navigate to /etc/xdg/lxdm and you'll see the lxdm.conf file. Open that file and you'll see options for autologin and session. Uncomment them (delete the # and the preceding space) and change the autologin name to what you need and you should be good.
User avatar
Kendall
Level 7
Level 7
 
Posts: 1580
Joined: Mon Nov 16, 2009 12:20 pm
Location: Asheville, NC, USA

Re: Auto login on Mint 9 LXDE?

Postby p10 on Sat Jun 05, 2010 2:12 am

Kendall wrote:Open the file manager as root, then navigate to /etc/xdg/lxdm and you'll see the lxdm.conf file. Open that file and you'll see options for autologin and session. Uncomment them (delete the # and the preceding space) and change the autologin name to what you need and you should be good.


Thanks Kendall! By following your instructions it works like a charm! Great work by the way! Feels blistering fast on my Asus Eee 1005p!
p10
Level 2
Level 2
 
Posts: 52
Joined: Fri Apr 04, 2008 4:13 am

Re: #SOLVED# Auto login on Mint 9 LXDE?

Postby jv2112 on Mon Jul 26, 2010 4:01 pm

I followed Kendal's suggestion and posted the file below. I would appreciate it if you could review the changes I made below. I removed the comments out of lines 1 & 2 but I am still prompted to log in.

All input is GREATLY appreciated :)


Code: Select all
[base]
autologin=joe
session=/usr/bin/startmintlxde
# numlock=0
# greeter=/usr/lib/lxdm/lxdm-greeter-gtk

last_session=mint-lxde.desktop

last_lang=

[server]
# arg=/usr/bin/X -nr vt1

[display]
gtk_theme=Shiki-Wise-LXDE
bg=/usr/share/backgrounds/mint-lxde/Talento-1.jpg
bottom_pane=1
lang=1
theme=Mint
"Life is pleasant. Death is peaceful. It's the transition that's troublesome." Isaac Asimov
jv2112
Level 1
Level 1
 
Posts: 7
Joined: Sun May 16, 2010 5:47 pm

Re: #SOLVED# Auto login on Mint 9 LXDE?

Postby gqpolo on Fri Jul 30, 2010 7:09 am

If I am breaking any rules I apologize but I have the same problem...any ideas on the previous post?
HP DV5-5120, AMD Turion 64 ML-32, ATI M200, 1GB RAM, Mint 9 LXDE
User avatar
gqpolo
Level 2
Level 2
 
Posts: 85
Joined: Sun Jun 06, 2010 11:23 am
Location: Orlando, Florida

Re: #SOLVED# Auto login on Mint 9 LXDE?

Postby xetaprime on Sat Jul 31, 2010 2:27 pm

Me too- still being greeted :(
xetaprime
Level 1
Level 1
 
Posts: 19
Joined: Sat Jul 31, 2010 8:05 am

Re: #SOLVED# Auto login on Mint 9 LXDE?

Postby thx1138 on Sat Jul 31, 2010 8:09 pm

This worked for me in LXDE. Thank you.
User avatar
thx1138
Level 4
Level 4
 
Posts: 322
Joined: Thu Apr 30, 2009 8:42 pm
Location: Germany/NRW

Re: #SOLVED# Auto login on Mint 9 LXDE?

Postby fbobraga on Sat Jul 31, 2010 10:37 pm

the autologin feature is not working here, even after the file /etc/xdg/lxdm/lxdm.conf was edited...

* I'm using a pt_BR setup fresh install of Mint 9 LXDE

edit: on other box with the same setup it worked (except that, in the machine where the autologin problem persists, the CD install boot only worked in the "compatibility mode")
fbobraga
Level 1
Level 1
 
Posts: 39
Joined: Sat Jul 31, 2010 10:28 pm
Location: São Paulo - Brasil

Re: #SOLVED# Auto login on Mint 9 LXDE?

Postby fbobraga on Fri Aug 06, 2010 7:37 pm

this (autologin) stoped working in my machine, after that: viewtopic.php?f=175&t=52584#p303847

I've noted that a /etc/lxdm/lxdm.conf (like the /etc/xdg/lxdm/lxdm.conf) exists - but, here, editing that has no effects either...

I can setup the autologin thing here with slim? If so, how? (with the package 'slim' here, the login screen changes and the wallpaper, and all other mint customizations, apparently comes to the "default" debian customization - even a "debian" logo is on the wallpaper)
fbobraga
Level 1
Level 1
 
Posts: 39
Joined: Sat Jul 31, 2010 10:28 pm
Location: São Paulo - Brasil

Re: Auto login on Mint 9 LXDE?

Postby gychang on Sat Aug 07, 2010 11:15 am

Kendall wrote:Open the file manager as root, then navigate to /etc/xdg/lxdm and you'll see the lxdm.conf file. Open that file and you'll see options for autologin and session. Uncomment them (delete the # and the preceding space) and change the autologin name to what you need and you should be good.


thanks, works for me.

gychang
--
cruising the desert
--
User avatar
gychang
Level 3
Level 3
 
Posts: 143
Joined: Tue Dec 09, 2008 12:24 pm

Re: #SOLVED# Auto login on Mint 9 LXDE?

Postby xetaprime on Mon Aug 09, 2010 2:34 pm

Just in case anyone is still having issues with autologin...

I gave up trying to configure lxdm to work for me so I removed it and installed gdm. I then ran sudo gdmsetup. Had to unlock it and configure it and set my session to enlightenment which I love btw and it's working!

Best wishes,
Xeta
xetaprime
Level 1
Level 1
 
Posts: 19
Joined: Sat Jul 31, 2010 8:05 am

Re: #SOLVED# Auto login on Mint 9 LXDE?

Postby fbobraga on Sun Aug 15, 2010 1:01 pm

xetaprime wrote:(...)
I gave up trying to configure lxdm to work for me so I removed it and installed gdm. I then ran sudo gdmsetup. Had to unlock it and configure it and set my session to enlightenment which I love btw and it's working!(...)


Removing package 'lxdm' auto removes the package 'mint-lxde-default-settings' - after that, even the 'Logout' item in the "start menu" doesn't work. After this, 'sudo gdmsetup' here brings a GUI with all disabled itens, and try clicking the "Unblock" button doesn't do anything...

... this install is for my Dad's laptot - this issues tell to unexperienced users a "go away". I'm giving up Mint LXDE, and going to change to http://lubuntu.net/

edit: installed http://lubuntu.net/ , the autologin feature work's easily
fbobraga
Level 1
Level 1
 
Posts: 39
Joined: Sat Jul 31, 2010 10:28 pm
Location: São Paulo - Brasil

Re: #SOLVED# Auto login on Mint 9 LXDE?

Postby bayu on Sat Sep 04, 2010 10:28 am

Hi ... newcomer here from very poor country called Indonesia... my name is Bayu (linuxmint 9- with very very old pc 256 RAM)...

Try this (as root)
1.go to /etc/lxdm open the default.conf with leafpad (don't use gun ... hi hi) and add this after [base] :
autologin=(your username)
session=/usr/bin/startmintlxde

so that my default.conf is :

[base]
autologin=babay
session=/usr/bin/startmintlxde

greeter=/usr/lib/lxdm/lxdm-greeter-gtk
last_session=mint-lxde.desktop
last_lang=

[server]

[display]
gtk_theme=Clearlooks
bg=/usr/share/lubuntu/wallpapers/lubuntu-default-wallpaper.png
bottom_pane=1
lang=1
theme=Lubuntu

[input]


my default
2.pray the lord you believe with... :lol:

just share ...

Thank You People...
bayu
Level 1
Level 1
 
Posts: 2
Joined: Sat Sep 04, 2010 10:17 am

Re: #SOLVED# Auto login on Mint 9 LXDE?

Postby bayu on Sat Sep 04, 2010 10:29 am

Hi ... newcomer here from very poor country called Indonesia... my name is Bayu (linuxmint 9- with very very old pc 256 RAM)...

Try this (as root)
1.go to /etc/lxdm open the default.conf with leafpad (don't use gun ... hi hi) and add this after [base] :
autologin=(your username)
session=/usr/bin/startmintlxde

so that my default.conf is :

[base]
autologin=babay
session=/usr/bin/startmintlxde

greeter=/usr/lib/lxdm/lxdm-greeter-gtk
last_session=mint-lxde.desktop
last_lang=

[server]

[display]
gtk_theme=Clearlooks
bg=/usr/share/lubuntu/wallpapers/lubuntu-default-wallpaper.png
bottom_pane=1
lang=1
theme=Lubuntu

[input]


2.pray the lord you believe with... :lol:

just share ...

Thank You People...
bayu
Level 1
Level 1
 
Posts: 2
Joined: Sat Sep 04, 2010 10:17 am

Re: #SOLVED# Auto login on Mint 9 LXDE?

Postby jeffster on Sat Sep 04, 2010 9:05 pm

bayu wrote:Hi ... newcomer here from very poor country called Indonesia... my name is Bayu (linuxmint 9- with very very old pc 256 RAM)...

Try this (as root)
1.go to /etc/lxdm open the default.conf with leafpad (don't use gun ... hi hi) and add this after [base] :
autologin=(your username)
session=/usr/bin/startmintlxde

so that my default.conf is :

[base]
autologin=babay
session=/usr/bin/startmintlxde

greeter=/usr/lib/lxdm/lxdm-greeter-gtk
last_session=mint-lxde.desktop
last_lang=

[server]

[display]
gtk_theme=Clearlooks
bg=/usr/share/lubuntu/wallpapers/lubuntu-default-wallpaper.png
bottom_pane=1
lang=1
theme=Lubuntu

[input]


2.pray the lord you believe with... :lol:

just share ...

Thank You People...


Did this and it seems to work great....
jeffster
Level 1
Level 1
 
Posts: 1
Joined: Sat Sep 04, 2010 9:00 pm

Re: #SOLVED# Auto login on Mint 9 LXDE?

Postby boarder428 on Sun Sep 19, 2010 6:28 pm

How do you open the file manager as root?
User avatar
boarder428
Level 1
Level 1
 
Posts: 39
Joined: Wed Jan 13, 2010 7:28 pm
Location: Eastern Nebraska

Re: #SOLVED# Auto login on Mint 9 LXDE?

Postby bigBuckets on Sun Sep 19, 2010 6:51 pm

boarder428 wrote:How do you open the file manager as root?


One way is to open Terminal and enter in

Code: Select all
sudo pcmanfm
Cyberdyne Systems Model 101
bigBuckets
Level 3
Level 3
 
Posts: 171
Joined: Mon Mar 01, 2010 9:10 pm

Re: #SOLVED# Auto login on Mint 9 LXDE?

Postby boarder428 on Mon Sep 20, 2010 8:52 pm

bigBuckets wrote:
boarder428 wrote:How do you open the file manager as root?


One way is to open Terminal and enter in

Code: Select all
sudo pcmanfm


thanks bigBuckets. The only way I knew how was to install nautilus and use it!
User avatar
boarder428
Level 1
Level 1
 
Posts: 39
Joined: Wed Jan 13, 2010 7:28 pm
Location: Eastern Nebraska

Re: #SOLVED# Auto login on Mint 9 LXDE?

Postby fish_b0oy on Thu Apr 07, 2011 1:33 am

Ok, here are the commands.

Code: Select all
PC user # pcmanfm
No protocol specified
Cannot open display:


Installed gdm
Code: Select all
PC user # gdmsetup
No protocol specified

(gdmsetup:2627): Gtk-WARNING **: cannot open display: :0.0


A buggy mint!
fish_b0oy
Level 1
Level 1
 
Posts: 2
Joined: Sun Apr 03, 2011 9:38 am

Re: #SOLVED# Auto login on Mint 9 LXDE?

Postby boarder428 on Thu Apr 07, 2011 7:12 pm

Yeah, no longer running lxde. Went back to mint 10, like it better
User avatar
boarder428
Level 1
Level 1
 
Posts: 39
Joined: Wed Jan 13, 2010 7:28 pm
Location: Eastern Nebraska

Linux Mint is funded by ads and donations.
 
Next

Return to Others

Who is online

Users browsing this forum: No registered users and 1 guest