Mouse pointer vanishing when changing screen resolution

Forum rules
Before you post please read this

Mouse pointer vanishing when changing screen resolution

Postby Atriya on Tue Jun 08, 2010 1:40 pm

I've installed Mint LXDE Isadora on an old PC with an Intel 845 series motherboard, using an onboard graphics solution. By default, it boots with an 800x600 screen resolution. When I go to Menu->Preferences->Monitor Settings and change the resolution to 1024x768, the resolution switches perfectly, but the mouse pointer disappears. The mouse can still be USED, but I have to 'guess' where the pointer is. The only way I have found to rectify the situation is to reboot, upon which the resolution returns to 800x600 again as well. Lubuntu 10.04 and Peppermint OS also suffer from exactly the same problem. Does anyone know what's wrong? Thanks.
Atriya
Level 1
Level 1
 
Posts: 5
Joined: Mon May 31, 2010 4:01 am

Linux Mint is funded by ads and donations.
 

Re: Mouse pointer vanishing when changing screen resolution

Postby MALsPa on Tue Jun 08, 2010 1:55 pm

I don't know if this will help, but I had a very similar situation, but it was when using a live Mepis 8 CD on a particular machine. I was able to solve the problem by going into /etc/X11/xorg.conf, under the Device section, where I found this line:

Option "hw_cursor" "off"


According to my notes, that line was commented out, so I uncommented it. Saved the changes, then used ctrl+alt+backspace to log out, then logged back in, and that took care of the problem on this particular machine while using the live CD. When I later installed Mepis 8 on the same machine, I made the above changes from the live CD, and then the changes were saved during the installation, I guess.

I hope this info helps you out in some way.

By the way, I was able to find this solution by doing Google searches about the problem, so you may have some luck with that.
User avatar
MALsPa
Level 8
Level 8
 
Posts: 2030
Joined: Mon Nov 19, 2007 10:17 pm
Location: albuquerque

Re: Mouse pointer vanishing when changing screen resolution

Postby Atriya on Tue Jun 08, 2010 10:23 pm

:shock:

Well, thanks for the advice, but it appears to have had some unintended effects. There was no /etc/X11/xorg.conf on my system, so I created one anyway and added the line

Option "hw_cursor" "off"

to it. Unfortunately, now the system refuses to present me with a login screen when I turn it on. Just before the login screen is due to appear, the screen goes black with 3 lines of text on it, the last being

* Starting Common Unix Printing System: cupsd [ OK ]

The screen remains frozen in this state. It doesn't matter though... I only just installed the OS and I have no data on this system; I can always reinstall. But my problem remains unsolved.
Atriya
Level 1
Level 1
 
Posts: 5
Joined: Mon May 31, 2010 4:01 am

Re: Mouse pointer vanishing when changing screen resolution

Postby MALsPa on Wed Jun 09, 2010 1:32 am

Well, I didn't advise you to create that file, I was just sharing my experience here in case it was applicable to your situation. Different distro, no /etc/X11/xorg.conf present, looks like it requires a different solution. Sorry for sending you down the wrong path. I'm no expert in these things but it seems strange to me that /etc/X11/xorg.conf is not there. That is a file that I think is normally there -- looking at a few (4) different Linux installations here and it's present in each one. But I don't have Isadora LXDE installed so obviously that's a different case. Again, hoping someone else will step in here with some guidance.

Aside from that, my situation with the invisible mouse cursor was exactly the same as yours in that I could actually use it, but I couldn't see it.

Again, not trying to be rude, but some web searching on this topic might help you to resolve the issue. Just a suggestion. Also I am curious to know what file in Isadora LXDE does what /etc/X11/xorg.conf does in other distros. I see the file present here in Mint Elyssa.
User avatar
MALsPa
Level 8
Level 8
 
Posts: 2030
Joined: Mon Nov 19, 2007 10:17 pm
Location: albuquerque

Re: Mouse pointer vanishing when changing screen resolution

Postby vincent on Wed Jun 09, 2010 2:14 am

Apparently /etc/X11/xorg.conf is being deprecated in favour of HAL, or so I've heard. Anyways, just get rid of the xorg.conf you added and you should be able to get to your login screen, at least, and back to where you were at the beginning.
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm
vincent
Level 8
Level 8
 
Posts: 2220
Joined: Tue Feb 09, 2010 4:10 am

Re: Mouse pointer vanishing when changing screen resolution

Postby Atriya on Wed Jun 09, 2010 2:54 am

@MALsPa: I don't mind you sending me down the wrong path at all; you don't even need to apologize. I have no data on this system and I only just installed Isadora LXDE. It'll just take me 10 mins to reinstall. I did, however, poke around on Google quite a bit before posting - I found no solution that worked. Thanks for replying anyway!

@vincent: I'd delete the xorg.conf I created, but I can't even reach the shell. :(

Strange that a problem THIS major seems to have no known solution. It would be awesome if someone could help... Isadora LXDE is perfect for my system, but I can't use it at 800x600. :cry:
Atriya
Level 1
Level 1
 
Posts: 5
Joined: Mon May 31, 2010 4:01 am

Re: Mouse pointer vanishing when changing screen resolution

Postby MALsPa on Wed Jun 09, 2010 7:58 am

Does Isadora LXDE come on a live CD? If so, does the same problem occur when running the live CD on that machine?

Also, if you do have a live CD, you should be able to run it on that machine and go in and delete the file that you created on the installed system. That would get you back to where you were, but wouldn't solve the issue.
User avatar
MALsPa
Level 8
Level 8
 
Posts: 2030
Joined: Mon Nov 19, 2007 10:17 pm
Location: albuquerque

Re: Mouse pointer vanishing when changing screen resolution

Postby MALsPa on Fri Jun 11, 2010 1:45 am

Atriya wrote:I've installed Mint LXDE Isadora on an old PC with an Intel 845 series motherboard, using an onboard graphics solution. By default, it boots with an 800x600 screen resolution. When I go to Menu->Preferences->Monitor Settings and change the resolution to 1024x768, the resolution switches perfectly, but the mouse pointer disappears. The mouse can still be USED, but I have to 'guess' where the pointer is. The only way I have found to rectify the situation is to reboot, upon which the resolution returns to 800x600 again as well. Lubuntu 10.04 and Peppermint OS also suffer from exactly the same problem. Does anyone know what's wrong? Thanks.


Gotten anywhere with this problem? I am curious to know if there's a way of fixing this outside of generating an xorg.conf file. By the way, the following indicates that if /etc/X11/xorg.conf isn't present, it has to be generated, not simply created (I am not recommending these instructions, but it's something to take a look at):

http://www.osguides.net/operation-syste ... u-910.html

I don't know if those exact instructions would work in LXDE. They are also repeated in this thread:

http://art.ubuntuforums.org/showthread.php?t=1336863

I hope someone can help out here. It isn't something that's easy to recreate because it's kinda hardware specific.

Another interesting thread on the subject:

http://ubuntuforums.org/showthread.php?t=1325212

Seems to me that leaving out xorg.conf was not such a good idea.
User avatar
MALsPa
Level 8
Level 8
 
Posts: 2030
Joined: Mon Nov 19, 2007 10:17 pm
Location: albuquerque

Re: Mouse pointer vanishing when changing screen resolution

Postby MALsPa on Fri Jun 11, 2010 1:56 am

Atriya wrote:I've installed Mint LXDE Isadora [...] Lubuntu 10.04 and Peppermint OS also suffer from exactly the same problem.


Also I am curious to know if the "invisible pointer" issue occurs on your machine if you use recent Mint or Ubuntu versions that are not LXDE versions. And if it occurs with the live CDs, prior to installation.
User avatar
MALsPa
Level 8
Level 8
 
Posts: 2030
Joined: Mon Nov 19, 2007 10:17 pm
Location: albuquerque

Re: Mouse pointer vanishing when changing screen resolution

Postby Atriya on Tue Jun 29, 2010 8:43 am

Well, I still haven't been able to solve this problem. Also:

1) It DOES occur when I boot from the LiveCD.
2) I recently discovered that it's not LXDE specific, since I have the same problem on both Kubuntu and Ubuntu!

:(
Atriya
Level 1
Level 1
 
Posts: 5
Joined: Mon May 31, 2010 4:01 am

Re: Mouse pointer vanishing when changing screen resolution

Postby Dave68 on Tue Jun 29, 2010 10:12 am

You can also add Isadora Standard. I've got four machines running Linux.

1 is running Dual Boot Mint 9 Standard/ Windows 7 (No Problem on this Machine)
2 running Mint 9 LXDE RC (No Problem on these Machines)
1 is currently running Xubuntu (Not a Problem in Xubuntu)

The one running Xubuntu had this same issue with Isadora Standard and Ubuntu, but does not have this problem with Xubuntu.

Once Mint 9 XFCE RC is out, I will replace Xubuntu with it. It would appear to be an issue on releases with a heavier footprint, but that doesn't explain why you are having trouble with LXDE RC. That one is as light, or lighter than XFCE I believe.

Not much help, just some verification.

Thanks,
Dave
Linux User: 528038
Primary PC: Version: LMDE (201101), 32 Bit.
Alternate 1: Version: Peppermint One OS, 32 Bit.
Laptop: Version: Julia Main (10), AMD 64
Image
User avatar
Dave68
Level 4
Level 4
 
Posts: 298
Joined: Wed Jun 16, 2010 1:15 pm
Location: Bolivar, Missouri

Re: Mouse pointer vanishing when changing screen resolution

Postby Atriya on Wed Jun 30, 2010 9:33 am

@Dave68: Thanks for the info. I tried Xubuntu 10.04 and it's working fine. Like you, I'll stick to it till Mint XFCE is released, hopefully soon. :D
Atriya
Level 1
Level 1
 
Posts: 5
Joined: Mon May 31, 2010 4:01 am

Linux Mint is funded by ads and donations.
 

Return to Others

Who is online

Users browsing this forum: No registered users and 1 guest