To change a keyboard layout switching key(s).(Solved)

Forum rules
Before you post please read how to get help

To change a keyboard layout switching key(s).(Solved)

Postby daison on Thu Sep 08, 2011 8:53 am

As I'm living in Latvia, I have to switch between languages very often. Ok, so I found how to do it for LXDE Mint. I made a file called Xkbmap in /ect/X11 with -option grp:ctrl_shift_toggle,grp_led:scroll us,ru,lv in it and it working fine, but I used to switch layouts with windows key.
Question is: What should be written instead of ctrl_shift_toggle?
Last edited by daison on Sun Oct 23, 2011 2:26 pm, edited 1 time in total.
daison
Level 1
Level 1
 
Posts: 19
Joined: Thu Sep 08, 2011 8:13 am
Location: Latvia, Riga

Linux Mint is funded by ads and donations.
 

Re: To change a keyboard layout switching key(s).

Postby xenopeek on Thu Sep 08, 2011 10:54 am

I think: super_toggle
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15280
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: To change a keyboard layout switching key(s).

Postby daison on Thu Sep 08, 2011 11:28 am

No, Vincent, it doesn't work. But thank you for your reply. Maybe I should mention, that it's Linux Mint 11 Katya LXDE, on notebook HP Compaq nx5000.
daison
Level 1
Level 1
 
Posts: 19
Joined: Thu Sep 08, 2011 8:13 am
Location: Latvia, Riga

Re: To change a keyboard layout switching key(s).

Postby xenopeek on Thu Sep 08, 2011 11:37 am

The key is either called super, or meta_win. Don't know if meta_win_toggle might work (Google has nothing helpful on this :().
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15280
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: To change a keyboard layout switching key(s).

Postby daison on Thu Sep 08, 2011 1:17 pm

Ok, I'll try meta_win later, thank you.

No, not working either. Maybe there is something else to change to make it work?
daison
Level 1
Level 1
 
Posts: 19
Joined: Thu Sep 08, 2011 8:13 am
Location: Latvia, Riga

Re: To change a keyboard layout switching key(s).

Postby maxmm5 on Tue Oct 18, 2011 12:09 pm

Hi daison, Is LXDE has Control Center? I'm using LMDE and from Control Center under Hardware section, hit Keyboard then from Keyboard Preference window go to Layouts and make sure there are 2 languages on the window ( USA+ your language of choice), then hit Options button below, from Keyboard Layout Options select "Key(s) to change layout" and select the two key's combination you like and your done . maxmm5
maxmm5
Level 1
Level 1
 
Posts: 6
Joined: Sat Oct 01, 2011 5:34 am

Re: To change a keyboard layout switching key(s).

Postby daison on Thu Oct 20, 2011 2:03 pm

Hi, maxmm5! No, in LXDE edition I cannot find any Control Center, there is only Openbox Cofiguration Manager, but there is nothing about keyboard configuration. Just Theme, Appearance, Windows, Move & Resize ...
daison
Level 1
Level 1
 
Posts: 19
Joined: Thu Sep 08, 2011 8:13 am
Location: Latvia, Riga

Re: To change a keyboard layout switching key(s).

Postby maxmm5 on Fri Oct 21, 2011 2:42 pm

Hi daison, I've tried LXDE on LIve Session and found out that you can activate the keyboard input method system by following this step; Menu/System Tools/Language Support, on the Language tab, make sure you got the default language first and your language of choice second, then hit the up and down arrow of "Keyboard input method system:", if it was gray-out, then you must install the "ibus" apps using Software Manager. Good luck, maxmm5
maxmm5
Level 1
Level 1
 
Posts: 6
Joined: Sat Oct 01, 2011 5:34 am

Re: To change a keyboard layout switching key(s).

Postby daison on Sat Oct 22, 2011 5:45 pm

Hi, maxmm5, thank you for being so helpful, but there is no such a thing like I couldn't switch keyboard layouts. All is good and working. It is just a way how I used to switch between keyboard layouts. The way it is described in my post makes switching with 2 keys pressed together - ctrl+shift. Using Linux Mint Gnome edition and other Linuxes with XFCE..., I configured those to switch keyboard layout with only pressing one useless windows button. I find it convenient, but here, in Linux Mint LXDE edition I cannot get it my way. That is a matter of my question here. So... We'll keep on trying. :D
daison
Level 1
Level 1
 
Posts: 19
Joined: Thu Sep 08, 2011 8:13 am
Location: Latvia, Riga

Re: To change a keyboard layout switching key(s).

Postby Garvan on Sat Oct 22, 2011 10:48 pm

Try these:

grp:lwin_switch --- Left Win (while pressed)
grp:rwin_switch --- Right Win (while pressed)
grp:win_switch --- Any Win key (while pressed)
grp:win_menu_switch --- Left Win (to first layout), Right Win/Menu (to last layout)
grp:lwin_toggle --- Left Win
grp:rwin_toggle --- Right Win


These are from a file called xorg.lst in /usr/share/X11/xkb/rules of Linux Mint 11 LXDE.

If you get this to work, could you post the format of your Xkbmap file, and where you installed it, for others to learn from.

Garvan
Desktop: Dell, Intel Core 2 Duo E7500 @ 2.93GHz, 2GiB RAM, Lubuntu 14.04 (trusty)
Notebook: HP 14 Notebook PC 14-r003TX, i5-4210U @ 1.7 GHz, 4GB RAM, Linux Mint 17
Notebook: DELL latitude E5520, i5-2520M @ 2.50 GHz, 4GB RAM, Windows 7
User avatar
Garvan
Level 4
Level 4
 
Posts: 277
Joined: Sun May 29, 2011 3:26 am
Location: Lao PDR

Re: To change a keyboard layout switching key(s).

Postby daison on Sun Oct 23, 2011 5:24 am

Hi, Garvan! It is working your way! Big fat THANK YOU!
I just edited my /ect/X11/Xkbmap like this: -option grp:lwin_toggle,grp_led:scroll us,ru,lv
And now it switches throw all my layouts every time I press left win key (that is the only win key I have on my laptop).
I'm happy now :D .
daison
Level 1
Level 1
 
Posts: 19
Joined: Thu Sep 08, 2011 8:13 am
Location: Latvia, Riga

Re: To change a keyboard layout switching key(s).

Postby kasyak on Fri Apr 06, 2012 9:39 pm

daison wrote:Hi, Garvan! It is working your way! Big fat THANK YOU!
I just edited my /ect/X11/Xkbmap like this: -option grp:lwin_toggle,grp_led:scroll us,ru,lv
And now it switches throw all my layouts every time I press left win key (that is the only win key I have on my laptop).
I'm happy now :D .

For anyone still having this problem, I'm posting my experience.
I'm using Mint 12 (lisa) LXDE 32-bit.
/ect/X11/Xkbmap file did not do the job for me. Not sure if I did something wrong, or this just doesn't work anymore.
I am using Russian and English(US) layouts, with Left Win switch (while pressed) and Alt+Shift toggle.
I modified the contents of my /etc/default/keyboard to:
XKBMODEL="pc105"
XKBLAYOUT="us,ru"
XKBVARIANT=""
XKBOPTIONS="grp:lwin_switch,grp:alt_shift_toggle"

The settings for XKBMODEL, XKBLAYOUT, XKBVARIANT and XKBOPTIONS ca be found in Preferences -> Lxkeymap application, you need to go to menu Variant -> Show All

Hope this helps somebody.
P.S. I cannot believe there's no easy graphical way to add layouts. Really discouraging...
kasyak
Level 1
Level 1
 
Posts: 1
Joined: Fri Apr 06, 2012 9:22 pm

Linux Mint is funded by ads and donations.
 

Return to Others

Who is online

Users browsing this forum: No registered users and 3 guests