Mouse button changes not saving.

Forum rules
Before you post please read this

Mouse button changes not saving.

Postby captainpotato on Mon Oct 31, 2011 3:28 am

After a few years away, I'm back using Linux Mint (LXDE), and am enjoying the experience. Everything works as it should (which it didn't back then) and it runs beautifully on my antiquated hardware.

That is, everything works as it should except saving mouse button settings. I'm left-handed, so I change the settings using the Keyboard and Mouse' option in 'Preferences'. The setting works, but it doesn't save it - ie - each time I boot, I have to change the setting again.

I've searched this forum and more broadly for LXDE-related help, but nothing so far has helped me, so I'd appreciate any suggestions that you have, please.
User avatar
captainpotato
Level 1
Level 1
 
Posts: 5
Joined: Thu Feb 14, 2008 7:35 am

Linux Mint is funded by ads and donations.
 

Re: Mouse button changes not saving.

Postby captainpotato on Thu Nov 03, 2011 5:59 am

Nobody's got a suggestion?
User avatar
captainpotato
Level 1
Level 1
 
Posts: 5
Joined: Thu Feb 14, 2008 7:35 am

Re: Mouse button changes not saving.

Postby renoon on Mon Dec 05, 2011 12:27 am

BUMP. I like disabling my trackpad, but not every time I boot-up.
renoon
Level 1
Level 1
 
Posts: 6
Joined: Sun Feb 20, 2011 6:11 pm

Re: Mouse button changes not saving.

Postby Thomcat on Sat Dec 10, 2011 2:14 pm

I have the same issue of the mouse panel not saving my preferences on restart...specifically when disabling the touchpad (I prefer using a trackpoint). Dunno if it is a bug.
Thomcat
Level 1
Level 1
 
Posts: 10
Joined: Sat Dec 10, 2011 1:50 pm

Re: Mouse button changes not saving.

Postby pa blum on Thu Dec 15, 2011 12:22 am

Same here! But my "keyboard and mouse" entries aren't saved at all! When I close the dialog box it goes right back to its defaults. I hate short double click limits and short key-holds, and it won't stay in left-handed, so this is causing my only discomfort with my otherwise excellent new Mint LXDE installation. Loved the User Guide doc too. :)

I'm using an old, faithful Logitech trackball, if that matters -- but that's unlikely. Seems like a bug to me. Any comments will be appreciated.
User avatar
pa blum
Level 1
Level 1
 
Posts: 13
Joined: Sat Dec 10, 2011 11:33 pm

Re: Mouse button changes not saving.

Postby Bob E on Thu Dec 15, 2011 3:23 am

OK, I just did this on my Asus Eee running Mint 11 LXDE. The left-hand mouse settings remained set for left-hand after each reboot, full power off then restart, and also after log out / log in. It stays set for the track pad and my wireless Logitech mouse (V220).

Open your file manager and set it to "Show Hidden" (ctrl+h) to show hidden files.

Then go to /home/(username)/.config/lxsession/Mint-LXDE

There you will see desktop.conf

Right click and open with gedit (or whatever text editor you have).

Near the bottom you will see

Code: Select all
[Mouse]
AccFactor=20
AccThreshold=10
LeftHanded=0


Change the 0 of LeftHanded to 1

Code: Select all
[Mouse]
AccFactor=20
AccThreshold=10
LeftHanded=1


Click SAVE.

Reboot or log out and log back in.

Then shout "Southpaws Rule!"
User avatar
Bob E
Level 4
Level 4
 
Posts: 370
Joined: Sun May 01, 2011 9:45 am
Location: Directly above the center of the Earth.

Re: Mouse button changes not saving.

Postby pa blum on Thu Dec 15, 2011 7:59 pm

It works! Brilliant! Thanks, Bob E! I even fixed my keyboard delay at the same time.

I did some experimenting and found that after you come back in you can still run the "Keyboard and Mouse" dialog box, and even mess with the settings, but as long as you don't hit the "Apply" button, you won't mess up your file editing.

Something strange -- howcum the other checkboxes that surround the left-handed option aren't included in the list? And there's no sign of a setting for the mouse's double-click length. Somewhere else, perhaps?

Anyhoo, I'm afraid I can't join in your lefty cheer, as I am a northpaw. But I like the trackball on the left side, set lefthanded (you just have to think thumb-and-pinky instead of left-and-right) and that leaves my right hand free for page- and enter buttons and the number pad, which I use extensively. I guess the southpaws reading this already appreciate this arrangement, but I have never been able to talk any righties into trying it. Their loss, eh?

Thanks again, Bob E
User avatar
pa blum
Level 1
Level 1
 
Posts: 13
Joined: Sat Dec 10, 2011 11:33 pm

Re: Mouse button changes not saving.

Postby Bob E on Thu Dec 15, 2011 11:03 pm

pa blum wrote:It works! Brilliant! Thanks, Bob E! I even fixed my keyboard delay at the same time.


Good deal! Glad that all worked out well for you. Hopefully the GUI problem will be fixed in Mint 12 LXDE, but if it isn't, you now know how to make it work!
User avatar
Bob E
Level 4
Level 4
 
Posts: 370
Joined: Sun May 01, 2011 9:45 am
Location: Directly above the center of the Earth.

Re: Mouse button changes not saving.

Postby Thomcat on Fri Dec 16, 2011 1:14 pm

What's the text for disabling the touchpad? Also for setting the acceleration from the default of 2 to 5? Thanks!
Thomcat
Level 1
Level 1
 
Posts: 10
Joined: Sat Dec 10, 2011 1:50 pm

Re: Mouse button changes not saving.

Postby Bob E on Fri Dec 16, 2011 8:51 pm

Thomcat wrote:What's the text for disabling the touchpad? Also for setting the acceleration from the default of 2 to 5? Thanks!

For disabling the touchpad, install gpointing-device-settings from Synaptic or in the terminal
Code: Select all
sudo apt-get install gpointing-device-settins
The annoying thing about this is it will not keep the settings after shutdown and reboot, and you have to press Alt+F2 and enter gpointing to run the GUI. But, it does turn off the touchpad.

As far as the acceleration, look at my first post here, and change AccFactor from 20 to 50.
User avatar
Bob E
Level 4
Level 4
 
Posts: 370
Joined: Sun May 01, 2011 9:45 am
Location: Directly above the center of the Earth.

Re: Mouse button changes not saving.

Postby pa blum on Fri Dec 16, 2011 9:35 pm

Thomcat wrote:What's the text for ... setting the acceleration from the default of 2 to 5?


Go into the regular "Keyboard and Mouse" dialog box and mess with the sliding settings to see what the min and max numbers are. You're not actually setting anything -- just watching numbers change. From that you can decide what text numbers you want to use in Tom E's editing routine. I got confusing results with the mouse acc numbers, but I think my changes to the keyboard delays made a difference. The goofy one is the mouse acc where the GUI goes from 0 to 10 and you will probably find a 20 already there!

I doubt that trying numbers over the apparent maximums will hurt anything but, despite being a try-to-blow-things-up kind of guy, I'm chicken to try numbers outside of the GUI's ranges. (But we won't mind if you try it. (heh, heh :wink: ))
User avatar
pa blum
Level 1
Level 1
 
Posts: 13
Joined: Sat Dec 10, 2011 11:33 pm

Re: Mouse button changes not saving.

Postby 2briancox on Tue Jan 03, 2012 1:51 am

I have the exact same problem of settings changes not being saved with my mouse. But I am trying to keep "Tap-to-Click" turned off for my touchpad. Also, I do not even have the /home/<username>/.conf/lxsession/ directory as described by Bob E. So I cannot find desktop.conf. Maybe that's my whole problem? Also, could I just create the file and directories? And if so, could I get the code that I need to set Tap-to-Click to off?
2briancox
Level 1
Level 1
 
Posts: 37
Joined: Tue Dec 07, 2010 12:58 pm
Location: Tacoma, WA

Re: Mouse button changes not saving.

Postby kumodo on Sun Apr 29, 2012 3:19 am

For those missing "desktop.conf", copy the config file from "/etc/xdg/lxsession/Mint-LXDE"

It will work.
kumodo
Level 1
Level 1
 
Posts: 1
Joined: Sun Apr 29, 2012 3:14 am

Linux Mint is funded by ads and donations.
 

Return to Others

Who is online

Users browsing this forum: No registered users and 1 guest