How to turn on Desktop effects in LXDE

Forums for the LXDE Edition
Forum rules
Before you post please read this

How to turn on Desktop effects in LXDE

Postby vinoman on Sat Dec 31, 2011 10:56 am

I'm running Mint 11 LXDE and have installed compiz and the compiz-manager but when I set up the scale effect, nothing changes. I also looked at drivers and my nvidia drivers are installed but not currently in use. Why? How do I turn on the desktop effects in LXDE?
Last edited by vinoman on Wed Jan 18, 2012 11:26 am, edited 2 times in total.
vinoman
Level 5
Level 5
 
Posts: 513
Joined: Wed Sep 05, 2007 8:46 am

Linux Mint is funded by ads and donations.
 

Re: How to turn on Desktop effects in LXDE

Postby sagirfahmid3 on Mon Jan 16, 2012 10:46 pm

Hmm..try this.
Terminal>"compiz --replace" and press enter

It works with openbox so it should work with compiz. Lemme know how it goes.

EDIT: I tried it myself and got some weird error. Sorry, but this probably wont work. For some reason, I can't delete this post =/
Last edited by sagirfahmid3 on Mon Jan 16, 2012 11:28 pm, edited 1 time in total.
User avatar
sagirfahmid3
Level 6
Level 6
 
Posts: 1054
Joined: Sun Sep 04, 2011 12:39 pm

Re: How to turn on Desktop effects in LXDE

Postby vinoman on Mon Jan 16, 2012 11:14 pm

sagirfahmid3 wrote:Hmm..try this.
Terminal>"compiz --replace" and press enter

It works with openbox so it should work with compiz. Lemme know how it goes.


I ran the command without the quotes. It worked while the terminal was up but it never completed the command so when I closed out the rebooted, compiz was off again. How do get the command to finish? I waited 5 minutes until I closed out the terminal.

I only effect that I like is Scale. Most of compiz is not worth the trouble.

Let me know if you have a better command to solve the problem. If not I'll just remove compiz and live without it. Thanks.
vinoman
Level 5
Level 5
 
Posts: 513
Joined: Wed Sep 05, 2007 8:46 am

Re: How to turn on Desktop effects in LXDE

Postby sagirfahmid3 on Tue Jan 17, 2012 1:06 pm

WOW! It worked?! Lucky guess LOL...
To make it permanent, add it to LXDE's autostart file.

Go to terminal and type "gksu pcmanfm"
Go to /etc/xdg/lxsession/Mint/ , right click on the "autostart" file and edit it with leafpad or gedit or whatever text editor.
Scroll down to the end of the autostart file and add "@compiz --replace" and save the file {ignore the quotation marks, don't include them}.
Logout and log back in to see if it works.
User avatar
sagirfahmid3
Level 6
Level 6
 
Posts: 1054
Joined: Sun Sep 04, 2011 12:39 pm

Re: How to turn on Desktop effects in LXDE [solved]

Postby vinoman on Tue Jan 17, 2012 3:02 pm

IT WORKS!! Thank you.

Why do you have to do that for compiz? is it because most people don't use compiz with LXDE?

Maybe when Mint 12 LXDE comes out you won't have to edits files to make it work.
vinoman
Level 5
Level 5
 
Posts: 513
Joined: Wed Sep 05, 2007 8:46 am

Re: How to turn on Desktop effects in LXDE

Postby sagirfahmid3 on Tue Jan 17, 2012 7:00 pm

It's because LXDE stands for Lightweight X11 Desktop Environment; the addition of Compiz doesn't exactly help make it lightweight. On top of that, Compiz has issues sometimes (like making the CPU go up to 100%) or making the computer freeze. I personally don't like Compiz all that much: I use Gnome with Openbox as the window manager and it's SO FAST!

If you want a lightweight compositor, you can always "sudo apt-get install xcompmgr" and then get Docky to finish off the set; Docky is a dock application.
Lemme know if interested. Compiz uses about 17MB RAM idle while xcompmgr uses less than 0.5MB.
User avatar
sagirfahmid3
Level 6
Level 6
 
Posts: 1054
Joined: Sun Sep 04, 2011 12:39 pm

Re: How to turn on Desktop effects in LXDE

Postby vinoman on Tue Jan 17, 2012 7:46 pm

Thanks for the info. I'm not crazy about compiz either, but I wanted to see if it works on LXDE and so far it has a nice feel to it and still fast. I'm running 2GB RAM w/AMD X2 4600+ CPU.

If later on I removed the @compiz --replace line does that turn off compiz? Or is it still running in the background whether using it or not?
vinoman
Level 5
Level 5
 
Posts: 513
Joined: Wed Sep 05, 2007 8:46 am

Re: How to turn on Desktop effects in LXDE

Postby sagirfahmid3 on Tue Jan 17, 2012 8:08 pm

If you removed @compiz --replace then it wont run in the background anymore since you disabled the autostart :P
User avatar
sagirfahmid3
Level 6
Level 6
 
Posts: 1054
Joined: Sun Sep 04, 2011 12:39 pm

Re: How to turn on Desktop effects in LXDE

Postby vinoman on Tue Jan 17, 2012 8:10 pm

sagirfahmid3 wrote:If you removed @compiz --replace then it wont run in the background anymore since you disabled the autostart :P


Good to know :)
vinoman
Level 5
Level 5
 
Posts: 513
Joined: Wed Sep 05, 2007 8:46 am

Re: How to turn on Desktop effects in LXDE

Postby vinoman on Wed Jan 18, 2012 11:29 am

this morning I booted up to a flickering desktop. all the icons were gone and you couldn't do much at all. I got into the file and erased the compix line and deleted all the compiz programs. I see now that Compiz doesn't go well with LXDE and Nvidia. :(

without compiz, Mint 11 LXDE works great.
vinoman
Level 5
Level 5
 
Posts: 513
Joined: Wed Sep 05, 2007 8:46 am

Re: How to turn on Desktop effects in LXDE

Postby sagirfahmid3 on Wed Jan 18, 2012 9:46 pm

Aw..sucks... :(
Anyways, here's a post you might be interested in:
viewtopic.php?f=42&t=84076

Edit: Some of the pictures got deleted, but you'll get it anyways.
User avatar
sagirfahmid3
Level 6
Level 6
 
Posts: 1054
Joined: Sun Sep 04, 2011 12:39 pm

Re: How to turn on Desktop effects in LXDE

Postby tpprynn on Mon Jan 23, 2012 8:19 pm

Xcompmgr is pretty good though, I prefer it to the distractions of Compiz. With this line added to /etc/xdg/lxsession/Mint-LXDE/autostart the LXDE desktop is brought to life and doesn't seem any longer like a compromise.

@xcompmgr -CcfF -I-.15 -O-.03 -D1 -t-1 -l-1 -r3 -o.32
tpprynn
Level 3
Level 3
 
Posts: 145
Joined: Fri May 27, 2011 7:09 pm

Re: How to turn on Desktop effects in LXDE

Postby vinoman on Tue Jan 24, 2012 8:44 am

tpprynn wrote:Xcompmgr is pretty good though, I prefer it to the distractions of Compiz. With this line added to /etc/xdg/lxsession/Mint-LXDE/autostart the LXDE desktop is brought to life and doesn't seem any longer like a compromise.

@xcompmgr -CcfF -I-.15 -O-.03 -D1 -t-1 -l-1 -r3 -o.32


Thanks. I installed Xcompmgr and added the line to the autostart file and rebooted. How do I control the features? The only desktop effect that I use is the Scale in compiz, does this one have something that shows all windows on the desktop in smaller size for viewing?
vinoman
Level 5
Level 5
 
Posts: 513
Joined: Wed Sep 05, 2007 8:46 am

Re: How to turn on Desktop effects in LXDE

Postby sagirfahmid3 on Tue Jan 24, 2012 9:50 am

Not that I know of...I just use xcompmgr for its compositing feature so that I can run Docky or Avant Window Navigator with the special effects turned on.
User avatar
sagirfahmid3
Level 6
Level 6
 
Posts: 1054
Joined: Sun Sep 04, 2011 12:39 pm

Re: How to turn on Desktop effects in LXDE

Postby sagirfahmid3 on Sat Feb 04, 2012 12:46 am

So, so I tried out Compiz on my LXDE and it works perfectly! I used "compiz --replace" in autostart. Using Emerald themer.
Looks good, eh?
Screenshot.png
Screenshot.png (349.78 KiB) Viewed 5542 times
User avatar
sagirfahmid3
Level 6
Level 6
 
Posts: 1054
Joined: Sun Sep 04, 2011 12:39 pm

Re: How to turn on Desktop effects in LXDE

Postby tpprynn on Sat Feb 04, 2012 1:49 pm

I might give that a go! I remember Knoppix being a distro where this odd combination of the light DE and the heavy effects were paired. On some machines it might even be perfect.
tpprynn
Level 3
Level 3
 
Posts: 145
Joined: Fri May 27, 2011 7:09 pm

Re: How to turn on Desktop effects in LXDE

Postby mmutoo on Sun Apr 01, 2012 7:16 pm

Hi everybody. The topic seems dead, but I have the same question. Can I have the scale effect (thumbnail of all running apps on the desktop) in LXDE with a lightweight compositor? I use E17 (mainly Bodhi) and it has the effect with very small footprint, without 3D enabled graphic card. It must be possible to have it on LXDE. Does anybody know what are the options for a compositor that supports scale?
mmutoo
Level 1
Level 1
 
Posts: 29
Joined: Mon Nov 07, 2011 8:30 pm

Solved

Postby mmutoo on Mon Apr 02, 2012 1:54 pm

This is especially for vinoman. Actually this trick only enables the expo effect for making thumbnails of running apps on the desktop. Here is what I did:

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
1. DEPENDENCIES:

Here is what you need to install before compiling skippy:

Code:
sudo apt-get install libxft-dev libxrender-dev libxcomposite-dev libxdamage-dev libxfixes-dev libxmu-dev
Depending what you already have installed, you may or may not need to install other packages.

You might need to install gcc as well: sudo apt-get install gcc


2. SOURCE:

You can get the skippy-xd source package here: http://thegraveyard.org/files/skippy-xd-0.5.0.tar.bz2

Extract it and open the directory containing the source files.



3. PATCH FILES:

This step is ONLY to compile skippy-xd without Xinerama support. If you want Xinerama support, skip this step.You need to edit the following files:

mainwin.c
mainwin.h
Makefile

If you don't want to edit them yourself, I have posted the patched files at the bottom. Also, try using them if you get errors with step 4.

Open mainwin.c with a text editor. Create a new line between line after line 69 and paste this in line 70:
Code:
int event_base;
Save the file.

Open mainwin.h with a text editor. Scroll down to line 58. Replace this section:

Code:
#ifdef XINERAMA
int xin_screens;
int event_base;
XineramaScreenInfo *xin_info, *xin_active;
#endif /* XINERAMA */
with this:
Code:
/* #ifdef XINERAMA
int xin_screens;
int event_base;
XineramaScreenInfo *xin_info, *xin_active;
#endif XINERAMA */
(You are just commenting this section out.) Save the file.

Open Makefile with a text editor. Put a # in front of lines 13 and 14 to comment them out. Save and exit.



4. COMPILE

Open a terminal and 'cd' to the folder containing the source files. Type 'make' to build skippy-xd. If you get any errors, do not proceed to the next step. If you can't resolve the errors, post them here and I will try to help.



5. INSTALL

If you didn't get any error messages with step 4, type 'sudo make install' to install skippy-xd. Now go back the the folder containing the source code. Copy the file 'skippy-xd.rc-default' to your home folder and rename it to '.skippy-xd.rc'. This file contains skippy-xd's settings. You may edit it to your liking. You can then launch skippy with this command:
Code:
skippy-xd
6. CONFIGURATION

The file "skippy-xd.rc-default" in the source tarball is the default config file. Copy it to ~/.skippy-xd.rc and edit to your liking. The options are explained in the file.

7. You already have a command assigned to the default key (F11). To fix this edit ~/.skippy-xd.rc and change F11 to another key (I used F7)

8. You could try regular skippy. It might be a little faster.

9. This step is to map a mouse gexture for calling skippy:

Install: xautomation and xautolock
Run: xautolock -locker "xte 'key Scroll_Lock'" -corners 0+00 -cornerdelay 1 &

This will launch xte (-locker “xte ‘key Scroll_Lock’”) when the mouse cursor has been in the upper right corner (-corners 0+00) for a full second (-cornerdelay 1). You can specify many more options; have a look at the very detailed man page for more info. Xautolock runs very light (80 kb on this computer), so it shouldn’t slow things down.

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

I have used the trick by:
http://ubuntuforums.org/showthread.php?t=846643
and
http://urukrama.wordpress.com/2008/05/2 ... n-openbox/

P.S. I still have problem making it autodtart. I don't know why it is not working when I put it in /etc/xdg/lxsession/Mint-LXDE/autostart.


P.S. 2 . Made it autostart by putting in ~/.config/autostart
mmutoo
Level 1
Level 1
 
Posts: 29
Joined: Mon Nov 07, 2011 8:30 pm

Re: How to turn on Desktop effects in LXDE

Postby veganpete on Tue Apr 24, 2012 6:27 am

Hi guys, new to mint, come from Ubuntu.

I've been looking for a solution and your thread is the closest I've found - how can I edit the autostart file in Mint 12 to add "compiz --replace" command please?

On Mint 12, theres no startup application or session editor and when I try to add the "compiz --replace" command to the autostart file using the tutorial in this thread (in LXDE, Mint 12), it says "Access Denied".

I tried "sudo" in the terminal and the same error occurs.

Thanks! :)

*...also tried lxsession-edit but there's no option to add a command :s for the time-being I'm clicking the fusion icon after boot/startup but it would be nice if I could learn how to make it automatic (I could add xscreensaver to the session then also etc).
veganpete
Level 1
Level 1
 
Posts: 21
Joined: Tue Apr 24, 2012 6:20 am

Linux Mint is funded by ads and donations.
 

Return to LXDE

Who is online

Users browsing this forum: No registered users and 3 guests