LM 12 LXDE Stable installation: No desktop, only a terminal

Forum rules
Before you post please read this

LXDE Live Welcome Screen is a Terminal

Postby JohnYate on Tue Mar 06, 2012 11:59 am

When I run the Linux Mint 12 LXDE cd 32bit rc disk, burned from the current iso, iso file and all individual files on the CD all fully checked against published or included md5sum values, and my PC boots with the CD, after the usual CD installation noise, and some splash screen appearance, I am left in a terminal session, and I quote the screen contents:

"Welcome to Linux Mint 12 LXDE (GNU/Linux 3.0.0-12-generic i686)

Welcome to Linux Mint
* Documentation: http://www.linuxmint.com

mint@mint ~$ "

where "mint@mint" is in green text color attribute, and "~$" is in blue, all the text being on black space that eats into the lightgray background.

This is a real terminal session in a directory to which I have some read, write and create access - e.g. I can do trivial things like
"echo Hello World>helloworld.txt"
and then
"cat helloworld.txt"
with the expected results.
Great, we've got unix, but how do I start the desktop ?
Is there somewhere I can go to type "X11" or something, and get on the the installation in the same way as with other versions of Linux Mint, do you think?
JohnYate
Level 1
Level 1
 
Posts: 10
Joined: Wed Feb 29, 2012 1:49 am

Linux Mint is funded by ads and donations.
 

Re: LXDE Live Welcome Screen is a Terminal

Postby Oscar799 on Tue Mar 06, 2012 2:14 pm

Moved here by moderator
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8852
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: LXDE Live Welcome Screen is a Terminal

Postby baptiste on Wed Mar 07, 2012 1:57 pm

have yout tried startx? that's the standard command to launch X11 (can be used if you don't have something like gdm installed)
but not sure it will go on well.

maybe you should add some kernel parameters at the boot menu. vga settings, forcing VESA? but I leave that as an exercise. :P
baptiste
Level 2
Level 2
 
Posts: 98
Joined: Sun Jan 22, 2012 12:25 am

Re: LXDE Live Welcome Screen is a Terminal

Postby JohnYate on Wed Mar 07, 2012 9:04 pm

Many thanks for your advice, Oscar and Baptiste both.
284 MB of memory and starting with an empty 80 GB disk, of which at least 3 GB can be a swap partition, says I'm still in the zone for LXDE - rather than Windows 8 !
After poring over the startx(1) man page, and not finding parameters I could relate to, I tried running startx in the terminal session, which was of course owned by the default live session user named 'mint', and got a verbose reply in stderr which included an "invalid parameter" error line for a value inherited from the system defaults.
There's no way I'm going to be up to fixing up boot parameters at this stage in my personal development, and anyway isn't this what we have distro's for? Though I must try hitting Tab in the boot menu session to see what modifications one can make as a 1-off...
Many forum respondents have been underwhelmed by the improvements in going from LXDE 11 TO LXDE 12 so maybe this isn't such a big deal.
I'll look out for updates to the Linux Mint LXDE 12 md5sum, and if it changes soon, try a new installation disk to see if they have fixed the live session desktop invocation. Meantime I'll follow the in-place update path suggested in the "Updates" tutorial, ignoring the down-sides of that approach as I've no real alternative - then maybe go for LXDE 13 if it happens/looks OK. Luckily, having only run the LXDE 12 CD as a live session but not been able to even start to install from it, I haven't messed up my installation.
And in continuing with LXDE 11, which is responding quite snappily as I write this, I am quite consciously following your suggested principle of
"Don't fix it if it ain't broken, don't break it if you can't fix it"
Best wishes, John Yate
JohnYate
Level 1
Level 1
 
Posts: 10
Joined: Wed Feb 29, 2012 1:49 am

Re: LXDE Live Welcome Screen is a Terminal

Postby JohnYate on Fri Mar 09, 2012 11:00 pm

Further update,
I've tried the disk on 2 PC's now - my original 384 MB memory linux machineone, and my default 3GB memory 64 bit processor WinXP box (usually running WinXP pro 32bit). With CD's burned from the (md5sum checked) ISO under both WinXP (using "Free ISO Burner") and under LinuxMint 11 LXDE (using linux commmands as per the instructions in the Linux Mind user manual).
Both disks appear to be the same, and in each case, the machine booting with them first displays the Linux Mint boot menu, (disk integrity check posssible at this stage) then the splash screen, and then after a lot of installation-CD groaning, all that's left is a linux terminal session in which I one is the special user mint@mint.
Trying to install Linux from this state would appear inadvisable.

This is quite different from other LM distributions, including LinuxMint 11 LXDE.
Is the terminal session a special characteristic of Release Candidate distrubutions perhaps?

As it's "only" a candidate for release, I'm hoping it's likely to change fairly soo - with the possibility that it might run properly on the hardware I have.
JohnYate
Level 1
Level 1
 
Posts: 10
Joined: Wed Feb 29, 2012 1:49 am

LM 12 LXDE Stable installation: No desktop, only a terminal

Postby mariku on Sun Mar 11, 2012 9:00 am

Hi all,

absolute Linux beginner here, not a computer newbie by any means though, and I did a lot of reading before and while trying to do this; also searched for this particular problem and possible solutions, but couldn't find anything so far.

So here goes:

NEC Versa E680
Pentium M 1.4 GHz
736 MB RAM
Intel 82852/82855 GM/GME Graphics Controller, 64MB
Current resolution 1024x768
Sound card: Realtek AC97 Audio
Wireless adapter: Intel PRO/Wireless LAN 2100 3B Mini PCI
currently XP Pro SP3

I was just trying to install Linux Mint 12 LXDE, which I thought would be a great starting point with Linux, on my XP laptop, a NEC Versa E680, but got stopped dead in my tracks early on:

The live cd desktop simply doesn't show up. Instead, I get a simple linux mint terminal, and nothing else. If you want more details: It is exactly the same behaviour as described in this thread here:

viewtopic.php?f=175&t=96451

except, this time, in my case, it's not the Linux Mint LXDE RC, but Linux Mint LXDE Stable; which is why I'm posting this in a new thread.

This is obviously not what should happen, and I would be very grateful for advice how to get past this so I can finally start to get productive with Linux Mint!

Cheers,

Matt
Last edited by mariku on Mon Mar 12, 2012 10:13 pm, edited 1 time in total.
mariku
Level 1
Level 1
 
Posts: 24
Joined: Sun Mar 11, 2012 8:37 am

Re: LXDE Live Welcome Screen is a Terminal

Postby mariku on Sun Mar 11, 2012 9:29 am

Hi there,

I have the exact same problem - except, it's not RC, but the stable release :(

Details here (new thread since different release; mods feel free to merge if you want to):

viewtopic.php?f=175&t=96898&p=553375#p553375

I'm really hoping that Linux Mint LXDE turns out to be something I can use to be productive, instead of having to spend lots of time looking after it.

Cheers,

Matt
mariku
Level 1
Level 1
 
Posts: 24
Joined: Sun Mar 11, 2012 8:37 am

Re: LM 12 LXDE Stable installation: No desktop, only a termi

Postby Oscar799 on Sun Mar 11, 2012 10:01 am

Threads merged
Image
"Don't fix it if it ain't broken,don't break it if you can't fix it" Husse
Registered Linux User #511789
User avatar
Oscar799
Level 18
Level 18
 
Posts: 8852
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: LM 12 LXDE Stable installation: No desktop, only a termi

Postby mariku on Sun Mar 11, 2012 6:22 pm

Hi again,

update: Had the opportunity to try it on a Compaq XP desktop computer, and it works without problems, with the same CD. So the CD is definitely not the problem.

I noticed two things:

1. The terminal appears after the message "configuring wireless" or something like that briefly shows, as thin white text on a black screen (while on the desktop computer, that same message disappears again after a few seconds, and the process continues until at some point the Mint desktop shows up).

2. The main obvious difference that I can see between the desktop and the laptop is that the laptop is not connected to the internet in any way.

Could it be that it only installs and shows the Mint desktop on computers that are connected to the internet?

If there is anything else I can do to help figure this out, please let me know... from what I've seen while playing around with the live cd in the desktop computer, Mint LXDE looks fantastic, and I really, really want it to work - but it needs to work on the laptop.

Any ideas?

Cheers,

Matt
mariku
Level 1
Level 1
 
Posts: 24
Joined: Sun Mar 11, 2012 8:37 am

Re: LM 12 LXDE Stable installation: No desktop, only a termi

Postby mariku on Sun Mar 11, 2012 8:31 pm

Hi again,

another update: It's not about internet availability to the computer. Connected the laptop to the internet (tested with windows xp before, connection works) and tried again, same result.

I really, REALLY want to use Mint LXDE on that machine!

Help! :( Please...

Matt
mariku
Level 1
Level 1
 
Posts: 24
Joined: Sun Mar 11, 2012 8:37 am

Re: LM 12 LXDE Stable installation: No desktop, only a termi

Postby Spartan Mindset on Sun Mar 11, 2012 8:34 pm

Had the same display failure on my ThinkPad. Solved it by hitting the tab button while on the initial Grub screen at boot and adding "resolution=1024x768" to the commands already pre-configured. I imagine adding your specific screen resolution will accomplish the same result.

Good luck!
Spartan Mindset
Level 1
Level 1
 
Posts: 5
Joined: Sun Mar 11, 2012 8:26 pm

Re: LM 12 LXDE Stable installation: No desktop, only a termi

Postby mariku on Mon Mar 12, 2012 1:51 am

Hi,

that sounds like a good lead, will try that out.

Err, since I'm so new to Linux, first I will do a search for "grub screen", hehe.

Will report back here if it worked.

Cheers,

Matt
mariku
Level 1
Level 1
 
Posts: 24
Joined: Sun Mar 11, 2012 8:37 am

Re: LM 12 LXDE Stable installation: No desktop, only a termi

Postby JohnYate on Mon Mar 12, 2012 2:06 am

a) Thank you other "only got a terminal" people, I feel quite validated !

b) The version number in the Welcome screen shown in my original posting looks suspiciously like that of the a stable release:
"Welcome to Linux Mint 12 LXDE (GNU/Linux 3.0.0-12-generic i686)", something that would possibly have been staring me in the face if only I had been looking out for it - and knowledgable about the release number naming convention;

c) Alas, of the two machines I tried, getting this result, the bigger and more capable one had a wired ethernet connection to my router, and would, I suspect, automatically connect to the router's network, as happens under Windows XP, so having a made network connection is not necessarily what made the difference for the one of your machines that did actually start the Linux Mint desktop;

d) I will definitely try to configure the boot loader to enter the display size - hoping that's the munu box that Windows has possibly ripped off, and which appears just as you start to boot and you are given a few seconds before it automatically selects the first option. I certainly didn't need to do this with the LXDE 11 installation.
JohnYate
Level 1
Level 1
 
Posts: 10
Joined: Wed Feb 29, 2012 1:49 am

Re: LM 12 LXDE Stable installation: No desktop, only a termi

Postby mariku on Mon Mar 12, 2012 2:52 am

Hi again,

unfortunately that didn't work for me.

This is what I did:

- Hit "tab" during grub screen (for newbies like me, that's the screen during installation where you can choose between Start Linux Mint, Start Linux Mint in compatibility mode, etc.)

- underneath the given options, now a line of code appears: "> /casper/vmlinuz file=/cdrom/preseed/mint.seed boot=casper initrd=/casper/initrd.lz splash --_"

- added my laptop's resolution that it uses in XP in this way: > /casper/vmlinuz file=/cdrom/preseed/mint.seed boot=casper initrd=/casper/initrd.lz splash resolution=1024*768 --

- hit enter to continue installation

Did I do it right?

Any more ideas...?

I have to say this makes me feel really stupid, but I don't think I am that stupid. If significantly more computer skills are required than I have - certainly no pro, but certainly far from beginner as well - then Mint simply is not the competition to Windows that it wants to be. At least not yet.

Cheers,

Matt
mariku
Level 1
Level 1
 
Posts: 24
Joined: Sun Mar 11, 2012 8:37 am

Re: LM 12 LXDE Stable installation: No desktop, only a termi

Postby Spartan Mindset on Mon Mar 12, 2012 1:01 pm

You don't want to use an * in your resolution, you want to use a lower case x.

Try: resolution=1024x768
Spartan Mindset
Level 1
Level 1
 
Posts: 5
Joined: Sun Mar 11, 2012 8:26 pm

Re: LM 12 LXDE Stable installation: No desktop, only a termi

Postby mariku on Mon Mar 12, 2012 9:23 pm

Hi,

thanks for the hint - it was a typo here in the thread, I did actually use "x".

I wish it was just that, that would be easy to fix :(

Matt
Last edited by mariku on Mon Mar 12, 2012 10:25 pm, edited 1 time in total.
mariku
Level 1
Level 1
 
Posts: 24
Joined: Sun Mar 11, 2012 8:37 am

Re: LM 12 LXDE Stable installation: No desktop, only a termi

Postby JohnYate on Mon Mar 12, 2012 10:00 pm

Thank you mariku for persevering to get the mod needed to start the LM LXDE 32bit RD disk, whether it was by digging in linux books or wheedling advice out of nearby experts. Showing how the syntax for the boot command works was crucial.

And to Spartan Mindset for spotting the need for the syntax correction (need "resolution=1024x768", not "resolution=1024*768").

To me you're a pair of heroes, because I'm typing this in a live session of Linux Mint LXDE 12 KXDE 32bit RC with my big (-ish) WinXP machine booted from the disk I already had, but with the necessary screen resolution clause inserted at boot start time, basically as set out by mariku.

As I suspected, LinuxMint detected the wired connection to the active home router and connected to it without any intervention from me. I can't belive I wont be able to do this sort of thing on my smaller machine, except that as it doesn't have a wired connection to the router I'll need to select a Wi-Fi connection and log in to it.

Because LXDE allows the lower resolution of 800*600, though many people nowadays have 1080p instead, it's inevitable that the distro won't be forcing a default resolution, even if 600x800 might seem like enough to get one started on the desktop.

But I feel it was an error on the part of the the developers to oversimplify the installation instructions by not mentioning the need to define the resolution, thereby leaving comparitive newcomers like myself and mariku to struggle. To the point that the installation simply would not work if one didn't set the resolution using GRUB !

Booting this way using the existing release candidate disk and then doing level 1 and 2 updates from it, looks like the supported installation route just for the moment, so I shouldn't need to do a further 700 Mb download to install LXDE 12.
JohnYate
Level 1
Level 1
 
Posts: 10
Joined: Wed Feb 29, 2012 1:49 am

Re: LM 12 LXDE Stable installation: No desktop, only a termi

Postby mariku on Mon Mar 12, 2012 10:24 pm

Hi there,

thanks heaps for your feedback everyone so far!

Unfortunately, it wasn't the typo, and it's still not working for me. I tried all possible ways to enter the resolution settings as described above, no joy. I even tried 800x600, same effect. The only thing it seems to do is that the mint@mint terminal takes up more or less space of the screen, in larger or smaller font size.

Is there anything I might still be doing wrong, syntax wise, or otherwise? For example, I tried to continue booting by pressing F10 as advised before, but that doesn't do anything on my laptop. Return does - but does it the same thing? Due to lack of any solid information, I'm just guessing around here.

As I suspected, LinuxMint detected the wired connection to the active home router and connected to it without any intervention from me. I can't belive I wont be able to do this sort of thing on my smaller machine, except that as it doesn't have a wired connection to the router I'll need to select a Wi-Fi connection and log in to it.


I don't understand, do you mean the machine needs to have internet to install properly?

Booting this way using the existing release candidate disk and then doing level 1 and 2 updates from it, looks like the supported installation route just for the moment, so I shouldn't need to do a further 700 Mb download to install LXDE 12.


Do you mean using the stable release is actually not working (well, for some hardware combinations at least), and in those cases, currently the only way to install 12 LXDE is to use the RC and then update?

If so, would you mind summarizing briefly how to do that update? Although I must admit that would already be allowing my operating system to dictate me to do more work than I think I should be forced to do, if it is to be something that I can actually do work with. It's not a good start for me and Mint, so to say, and it makes me worry into how many more road blocks like this I will run after I have managed to trick the installation into working.

This situation is extremely frustrating, so close and yet so far! It's like I can hear Mint laughing at me from the CD drive.

Anything else I can try?

By the way, this is the laptop setup:

NEC Versa E680
Pentium M 1.4 GHz
736 MB RAM
Intel 82852/82855 GM/GME Graphics Controller, 64MB
Current resolution 1024x768
Sound card: Realtek AC97 Audio
Wireless adapter: Intel PRO/Wireless LAN 2100 3B Mini PCI
currently XP Pro SP3

Cheers,

Matt
mariku
Level 1
Level 1
 
Posts: 24
Joined: Sun Mar 11, 2012 8:37 am

Re: LM 12 LXDE Stable installation: No desktop, only a termi

Postby Spartan Mindset on Mon Mar 12, 2012 10:57 pm

To JohnYate, you're welcome! Glad you're up and running.

To mariku, hang in there! I think you're close. I noticed your boot parameter entry was slightly different than mine. You moved those double hypens at the end. Not sure if that matters or not, but I'll post my exact entry in case you want to try it:

> /casper/vmlinuz file=/cdrom/preseed/mint.seed boot=casper initrd=/casper/initrd.lz splash --resolution=1024x768

As the OP noted this is not a networking issue. The live CD should load to the GUI without any connectivity whatsoever. This is an odd display issue that I haven't seen in years. If the above entry doesn't work for you, I'd suggest double-checking your display resolution with another live distro.
Spartan Mindset
Level 1
Level 1
 
Posts: 5
Joined: Sun Mar 11, 2012 8:26 pm

Re: LM 12 LXDE Stable installation: No desktop, only a termi

Postby mariku on Tue Mar 13, 2012 1:18 am

Aloah again,

thanks for taking the time and finding that possible issue with what I'm doing!

Unfortunately, that wasn't it either, the effect is still the same. :(

Also thanks for the encouragement - although it doesn't matter too much how close I am if I'm not actually there...

In the hope that someone may see something in them that my previous descriptions of the problem don't convey, please have a look at the following screenshots that I took of the mint terminal that appears. It does look odd, maybe someone can make sense of it.

Yes, I took those with a camera, off the laptop screen. Gives the word "screenshot" a totally new meaning!

Cheers,

Matt

k-DSC05010.JPG
I have no idea why it is creating this grey area.
k-DSC05010.JPG (36.11 KiB) Viewed 4840 times


k-DSC05013.JPG
k-DSC05013.JPG (67 KiB) Viewed 4840 times


k-DSC05015.JPG
k-DSC05015.JPG (56.43 KiB) Viewed 4840 times
mariku
Level 1
Level 1
 
Posts: 24
Joined: Sun Mar 11, 2012 8:37 am

Linux Mint is funded by ads and donations.
 
Next

Return to Others

Who is online

Users browsing this forum: No registered users and 2 guests