tapbutton3=1 no matter what

Forum rules
Before you post please read this

tapbutton3=1 no matter what

Postby swaaye on Fri Mar 16, 2012 8:30 pm

I like to setup tapbutton3=8, so triple tap is browser back. This is troublesome on a lot of Ubuntu-based distros unfortunately.

I have setup a 50-synaptics.conf with the proper options, and synclient reports tapbutton3=8, but actually functionality is always tapbutton3=1 (left click). I experimented with tapbutton2=8 and this does work, setting double tap to browser back. So it seems that for some reason tapbutton3 is not changing from being left click even though syncient reports that it is.

Any ideers?

This is my EeePC 900 running Mint 12 LXDE fully distro-updated.
swaaye
Level 1
Level 1
 
Posts: 5
Joined: Fri Nov 05, 2010 5:09 pm

Linux Mint is funded by ads and donations.
 

Re: tapbutton3=1 no matter what

Postby swaaye on Fri Mar 16, 2012 11:36 pm

Update:
It occurred to me that perhaps the kernel is at fault so I did some testing with various LiveCDs. It does appear that kernel 3.0.x.x has a bug with its synaptics module (or something related to it). Older and newer kernels work. I'm going to install the nearly-released Lubuntu 12.04 as it seems to work ok.
swaaye
Level 1
Level 1
 
Posts: 5
Joined: Fri Nov 05, 2010 5:09 pm

Re: tapbutton3=1 no matter what

Postby AlbertP on Sat Mar 17, 2012 7:12 am

You can just install a newer kernel on Mint 12.

viewtopic.php?f=42&t=40185

Also, an easier program to configure your touchpad is probably gpointing-device-settings, which is in the repository.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6520
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: tapbutton3=1 no matter what

Postby swaaye on Sat Mar 17, 2012 3:26 pm

Thanks for the tips.

Unfortunately I've discovered that the Intel X.org driver causes font corruption on GMA 900/950 on some hardware, including my EeePC 900. I've dropped way back to 10.04 LTS. There's a bug report on Launchpad going back over a year with discussion but they have yet to solve ths issue.
swaaye
Level 1
Level 1
 
Posts: 5
Joined: Fri Nov 05, 2010 5:09 pm


Return to Others

Who is online

Users browsing this forum: No registered users and 1 guest