Help ... GRUB put on the wrong drive!

Forums for the LXDE Edition
Forum rules
Before you post please read this

Help ... GRUB put on the wrong drive!

Postby FulciLives on Tue Mar 27, 2012 12:29 pm

Hello.

I recently installed Linux Mint 12 LXDE and the installer behaved in a very odd fashion.

I have 3 interal hard drives:

1.) 1TB boot drive with a Windows 7 Home Premium 64-Bit install
2.) 320GB (empty)
3.) 3TB drive for personal files.

Normally the BIOS is set to boot to the 1TB drive with the Win7 install but I like to install various versions of Linux from time to time. When I do this I go into the BIOS and change the boot order of my hard drives so the 320GB drive is the boot drive. I install Linux there and all other distros also put GRUB there as well (thus I don't "touch" my main drive with the Win7 install). Usually this GRUB has an option to boot my Win7 (so I don't have to change the BIOS again although when I'm done playing with Linux I usually end up changing the boot order back and then it is like nothing ever happened).

Well I did the above procedure while installing Linux Mint 12 LXDE but somehow it managed to install itself on the 320GB HDD yet put GRUB on my 1TB HDD with the Win7 install. This is NOT what I wanted!

What can I do to get rid of GRUB from the 1TB HDD so that drive just boots straight to Windows 7 ???
User avatar
FulciLives
Level 1
Level 1
 
Posts: 38
Joined: Fri Jun 22, 2007 2:34 am
Location: Pittsburgh, PA USA

Linux Mint is funded by ads and donations.
 

Re: Help ... GRUB put on the wrong drive!

Postby seppalta on Tue Mar 27, 2012 2:09 pm

My guess is you chose the "other", or whatever it is called, category when the installer asked you where you want to put the Linux system. In the next prompt you choose the partition for / and swap, and at the bottom of that screen is a special box with sda always designated for the boot loader. It is easy to overlook this. It needs to be changed to the 320GB partition, which is unlikely to get the sda designation since the windows partition (drive) probably already claimed it, being first installed. That is why Grub ended up with Windows. The easiest solution is to reinstall Linux. Also, choose "install beside Windows" and then pick the 320GB drive for the installation and everything is automatic. Finally, grub is very smart. When Linux is installed after Windows, do an "update" and Grub automatically finds all the other operating systems and will present them at boot to choose from. No need to change anything in bios. Finally, download and install "Startupmanager" from Synaptic. Use it to pick the default system to boot and time the choice screen gives you to choose.
seppalta
Level 4
Level 4
 
Posts: 390
Joined: Wed Jun 08, 2011 12:08 pm

Re: Help ... GRUB put on the wrong drive!

Postby FulciLives on Tue Mar 27, 2012 2:25 pm

seppalta wrote:My guess is you chose the "other", or whatever it is called, category when the installer asked you where you want to put the Linux system. In the next prompt you choose the partition for / and swap, and at the bottom of that screen is a special box with sda always designated for the boot loader. It is easy to overlook this. It needs to be changed to the 320GB partition, which is unlikely to get the sda designation since the windows partition (drive) probably already claimed it, being first installed. That is why Grub ended up with Windows. The easiest solution is to reinstall Linux. Also, choose "install beside Windows" and then pick the 320GB drive for the installation and everything is automatic. Finally, grub is very smart. When Linux is installed after Windows, do an "update" and Grub automatically finds all the other operating systems and will present them at boot to choose from. No need to change anything in bios. Finally, download and install "Startupmanager" from Synaptic. Use it to pick the default system to boot and time the choice screen gives you to choose.

Actually I picked the first option in the install, which as I recall, said something like, "Install along Win7"

Other distros I've installed recently seem to have the same option BUT they put GRUB on the 320GB drive (along with my Linux install) and leave my 1TB drive alone (remember I change the BIOS before installing any Linux so that my 320GB drive is the boot drive instead of my 1TB Win7 drive). However by choosing that option the GRUB on the 320GB HDD does have the option to boot Win7 on the other HDD.

Anyway ...

In the case of Linux Mint 12 LXDE ... when I picked that first option ... it just started installing. There were no options at all. I was like "NO NO NO !!!"
Again to be clear: There was no "Are you sure you want to install" let alone any options as to where to install anything. It just started up right away. Very scary LOL

I've been playing with a lot of distros lately (including Ubuntu 12.04 Beta 1) and none of them acted like this during the install process.

To be clear GRUB works now (once switching the BIOS back to boot from the 1TB HDD) but ... sigh ... I didn't want it there and want it gone gone gone.
User avatar
FulciLives
Level 1
Level 1
 
Posts: 38
Joined: Fri Jun 22, 2007 2:34 am
Location: Pittsburgh, PA USA

Re: Help ... GRUB put on the wrong drive!

Postby Kevin108 on Tue Mar 27, 2012 3:48 pm

You need to figure out which drive is which. You can use Disk Utility to do so. Once you know the name of the drive you want grub on, open the terminal and run (for example) :

sudo grub-install /dev/sdb
Linux Mint 14 on a P4 3.0 GHz HT with 2 GB RAM and nVidia 7300.
I call my system Serenity. It's an old heap but a little love seems to
keep it going. | Kevin108.com | LiCo #548574 |
User avatar
Kevin108
Level 4
Level 4
 
Posts: 316
Joined: Fri Nov 18, 2011 11:07 am
Location: Virginia Beach, VA

Re: Help ... GRUB put on the wrong drive!

Postby HughT on Tue Mar 27, 2012 4:05 pm

Hi FulciLives, I agree with Kevin108. You can install grub on the 320 GB drive using a live CD.
Code: Select all
sudo mount /dev/sdXY /mnt

replace X and Y with the appropriate drive and partition for Mint
Code: Select all
sudo grub-install --root-directory=/mnt /dev/sdX
note - there's a gap between =/mnt and /dev, and no partition number after sdX
re-boot into Mint then
Code: Select all
sudo update-grub


I believe that you'll still have to remove grub from the Windows drive using a Windows disk.
hope this helps, regards
Please Edit your post title and add [SOLVED] once your question is resolved.
HughT
Level 5
Level 5
 
Posts: 628
Joined: Thu Oct 20, 2011 1:54 pm
Location: England

Re: Help ... GRUB put on the wrong drive!

Postby oldfart on Sat Mar 31, 2012 5:04 pm

I don't think any of the answers you got are the correct one so I am throwing this out.

Hopefully you still have a computer that has internet access. Do a search for the "ultimate boot disk". This disk should allow you to boot into windows. Then from the command line input fdisk /mbr. That should allow you to boot into windows again.

But my advice is don't do that. Stop using training wheels and use linux all the time. In other words stop playing with linux and use linux. If you had been doing that you wouldn't have needed to ask this question in the first place.
oldfart
Level 1
Level 1
 
Posts: 6
Joined: Tue Mar 27, 2012 8:09 am

Re: Help ... GRUB put on the wrong drive!

Postby Kevin108 on Sat Mar 31, 2012 5:53 pm

Why do you disagree with my post? I have an IDE drive I keep my ol' reliable Mint 11 install on (/dev/sda) then I have a dying 500 GB SATA drive (/dev/sdb) I use to test other versions and distros. When I install something new, I let it install GRUB to sdb. I boot into Mint 11 and use GRUB Customizer to clean up the menu so it doesn't confuse my fiance, then I run sudo grub-install /dev/sbd to copy my optimized GRUB menu (complete with one of our engagement photos) to the SATA drive, which is what I have BIOS set to boot from.
Linux Mint 14 on a P4 3.0 GHz HT with 2 GB RAM and nVidia 7300.
I call my system Serenity. It's an old heap but a little love seems to
keep it going. | Kevin108.com | LiCo #548574 |
User avatar
Kevin108
Level 4
Level 4
 
Posts: 316
Joined: Fri Nov 18, 2011 11:07 am
Location: Virginia Beach, VA

Re: Help ... GRUB put on the wrong drive!

Postby boosted on Sat Mar 31, 2012 7:04 pm

If you have the Windows7 disk, boot from it and go into recovery area - dos prompt.
The command you want is 'bootsect /nt60 SYS /mbr'
http://www.sevenforums.com/tutorials/20864-mbr-restore-windows-7-master-boot-record.html

I would recommend using the manual option to setup your drive. As your've seen not all distributions give you the option
to select the drive for the boot loader.
boosted
Level 1
Level 1
 
Posts: 3
Joined: Wed Sep 14, 2011 7:05 pm

Re: Help ... GRUB put on the wrong drive!

Postby Zion on Wed Apr 04, 2012 1:19 pm

FulciLives wrote:Hello.

I recently installed Linux Mint 12 LXDE and the installer behaved in a very odd fashion.

I have 3 interal hard drives:

1.) 1TB boot drive with a Windows 7 Home Premium 64-Bit install
2.) 320GB (empty)
3.) 3TB drive for personal files.
Well I did the above procedure while installing Linux Mint 12 LXDE but somehow it managed to install itself on the 320GB HDD yet put GRUB on my 1TB HDD with the Win7 install. This is NOT what I wanted!
What can I do to get rid of GRUB from the 1TB HDD so that drive just boots straight to Windows 7 ???


Same thing happened to me yesterday I was installing Linux Mint 12 LXDE on my second HDD ,but it seems installer put GRUB on my first HDD (where is my Windows 7 all my data) .I´ll try to use windows 7 DVD tommorow and repair boot.

EDIT:

I used this two commands
Code: Select all
sudo grub-install /dev/sdb

Code: Select all
sudo update-grub

and got access to my Windows 7 HDD,even though its thru GRUB I´m happy my data is here.
Huge thanks goes to all users (and to users above me for those commands) who helped me yesterday on IRC.
Zion
Level 1
Level 1
 
Posts: 1
Joined: Wed Apr 04, 2012 1:07 pm

Re: Help ... GRUB put on the wrong drive!

Postby FulciLives on Wed Apr 04, 2012 7:20 pm

Thanks I got it to work ... at least in so far as getting it onto the right HDD.

Now I guess I need to use my Windows install disc to get rid of it on the other HDD.

Thanks for the help!
User avatar
FulciLives
Level 1
Level 1
 
Posts: 38
Joined: Fri Jun 22, 2007 2:34 am
Location: Pittsburgh, PA USA

Re: Help ... GRUB put on the wrong drive!

Postby FulciLives on Thu Apr 05, 2012 4:06 pm

Actually is there a way to edit GRUB so it only points to my Windows install ?
User avatar
FulciLives
Level 1
Level 1
 
Posts: 38
Joined: Fri Jun 22, 2007 2:34 am
Location: Pittsburgh, PA USA

Re: Help ... GRUB put on the wrong drive!

Postby Kevin108 on Thu Apr 19, 2012 10:21 pm

Are you trying to make Windows boot by default?
Linux Mint 14 on a P4 3.0 GHz HT with 2 GB RAM and nVidia 7300.
I call my system Serenity. It's an old heap but a little love seems to
keep it going. | Kevin108.com | LiCo #548574 |
User avatar
Kevin108
Level 4
Level 4
 
Posts: 316
Joined: Fri Nov 18, 2011 11:07 am
Location: Virginia Beach, VA

Re: Help ... GRUB put on the wrong drive!

Postby FulciLives on Fri Apr 20, 2012 1:12 am

Kevin108 wrote:Are you trying to make Windows boot by default?

Is it possible to edit GRUB so it only looks for and shows my Windows install (and of course boots to it by default)?
User avatar
FulciLives
Level 1
Level 1
 
Posts: 38
Joined: Fri Jun 22, 2007 2:34 am
Location: Pittsburgh, PA USA

Re: Help ... GRUB put on the wrong drive!

Postby wayne128 on Fri Apr 20, 2012 1:41 am

What can I do to get rid of GRUB from the 1TB HDD so that drive just boots straight to Windows 7 ???


To be clear GRUB works now (once switching the BIOS back to boot from the 1TB HDD) but ... sigh ... I didn't want it there and want it gone gone gone.

Is it possible to edit GRUB so it only looks for and shows my Windows install (and of course boots to it by default)?


From reading your posts, I think all you want is no other boot loader else except Win7 on your 1TB drive.

You do not have any problem to boot into Win7 drive, I think you did it by setting bios to boot from 1TB drive. but then you get grub menu :evil:

Well , nevermind, this kind of things happen when you are constantly 'playing' with new Linux OS...

Of course they are ways to get around.
Here is what I would suggest.. do at your own risk :lol: :lol:
1. boot comp, go to bios, select win7 1TB drive
2. it should boot and run win7
3. goto http://neosmart.net/EasyBCD/
download EasyBCD, install it, run it in win7, add entry , select grub2, put in your whatever name for you to boot other drive that has lots of linux.
4. inside the EasyBCD, there is a way to install boot loader to MBR, I cannot remember how it look like, anyway, you choose that, let win7 take over MBR.

EDIT, watch this video, MBR is somewhere after 8minutes
http://www.youtube.com/watch?v=ntTRdkkG ... re=related

5. reboot computer, see what happen... do at your own risk :lol: :lol:
wayne128
Level 9
Level 9
 
Posts: 2810
Joined: Tue Jul 13, 2010 12:15 am

Re: Help ... GRUB put on the wrong drive!

Postby Kevin108 on Fri Apr 20, 2012 9:52 am

Not sure on Windows 7 but in XP you would boot from the CD, load the recovery console and run FIXMBR at the command line. That would overwrite Grub with Windows standard stuff.
Linux Mint 14 on a P4 3.0 GHz HT with 2 GB RAM and nVidia 7300.
I call my system Serenity. It's an old heap but a little love seems to
keep it going. | Kevin108.com | LiCo #548574 |
User avatar
Kevin108
Level 4
Level 4
 
Posts: 316
Joined: Fri Nov 18, 2011 11:07 am
Location: Virginia Beach, VA

Linux Mint is funded by ads and donations.
 

Return to LXDE

Who is online

Users browsing this forum: No registered users and 6 guests