Blank icons infesting my panel

Forums for the LXDE Edition
Forum rules
Before you post please read this

Blank icons infesting my panel

Postby ericfoxx on Wed Apr 11, 2012 10:21 pm

I just installed Mint 12 LXDE on an ASUS eee pc, and I'm loving it. However, a growing number of blank icons are appearing in the panel (not program icons, but what I would in Windows call the system tray icons). Here is what it looks like (follow the link if it is cropped):
Image
and here are my system specs:

System: Host Hematite Kernel 3.0.0-12-generic i686 (32 bit) Desktop LXDE (Openbox 3.5.0) Distro Linux Mint 12 LXDE
Machine: System ASUSTeK (portable) product 1005HA version x.x
Mobo ASUSTeK model 1005HA version x.xx Bios American Megatrends version 0402 date 05/12/2009
CPU: Single core Intel Atom CPU N270 (-HT-) cache 512 KB flags (nx sse sse2 sse3 ssse3)
Clock Speeds: (1) 800.00 MHz (2) 800.00 MHz
Graphics: Card: Intel Mobile 945GME Express Integrated Graphics Controller
X.Org 1.10.4 drivers intel unloaded: fbdev,vesa Resolution 1024x600@60.0hz
GLX Renderer Mesa DRI Intel 945GME x86/MMX/SSE2 GLX Version 1.4 Mesa 7.11
Audio: Card Intel N10/ICH 7 Family High Definition Audio Controller driver HDA Intel Sound: ALSA v: 1.0.24
Network: Card-1 Atheros AR8132 Fast Ethernet driver atl1c
IF: eth0 state: down speed: 4294967295 Mbps duplex: full mac: 00:26:18:2b:cc:bf
Card-2 Atheros AR9285 Wireless Network Adapter (PCI-Express) driver ath9k
IF: wlan0 state: up mac: 00:25:d3:09:c1:c5
Drives: HDD Total Size: 160.0GB (2.4% used) 1: /dev/sda Hitachi_HTS54321 160.0GB
Partition: ID:/ size: 146G used: 3.7G (3%) fs: ext4 ID:swap-1 size: 1.06GB used: 0.03GB (3%) fs: swap
Sensors: Error: You do not have the sensors app installed.
Info: Processes 127 Uptime 23:20 Memory 258.9/993.7MB Client Shell inxi 1.7.7

I searched for this problem on here, but didn't find anything. Anyone else have this problem?
ericfoxx
Level 1
Level 1
 
Posts: 3
Joined: Wed Apr 11, 2012 9:58 pm

Linux Mint is funded by ads and donations.
 

Re: Blank icons infesting my panel

Postby shengchieh on Wed Apr 11, 2012 10:47 pm

Will it close if you right-click the icons -> close window?

Btw, some programs need to be quited, not just closed. For some programs (e.g., skype), close will only close the window, not shutdown the program.

Sheng-Chieh
shengchieh
Level 4
Level 4
 
Posts: 218
Joined: Sat Mar 01, 2008 1:25 am

Re: Blank icons infesting my panel

Postby ericfoxx on Thu Apr 12, 2012 8:40 am

Strangely, they aren't icons, just blank, non-interactive panel space between the icons for volume, network, etc.
ericfoxx
Level 1
Level 1
 
Posts: 3
Joined: Wed Apr 11, 2012 9:58 pm

Re: Blank icons infesting my panel

Postby caribriz on Thu Apr 12, 2012 5:09 pm

I think I had a similar problem and my panel looked like yours.
I added some icons in the panel by adding the Application launch bar and put in some spacers.
This is how it looks now - the icons no longer "drift" into the middle with varying spaces between them. They "stick" to where I want them on the right.
Screenshot panel.png
Screenshot panel.png (20.16 KiB) Viewed 1472 times


This is the order I added spacers in Panel Preferences. I also ticked the "stretch" box next to Task Bar (Window List) :
Screenshot dialog.png
Screenshot dialog.png (101.75 KiB) Viewed 1472 times


caribriz
Image
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 13 Cinnamon)
caribriz
Level 5
Level 5
 
Posts: 789
Joined: Mon Nov 28, 2011 7:43 am

Re: Blank icons infesting my panel

Postby ericfoxx on Fri Apr 13, 2012 10:28 am

Thanks, caribriz! I tried stretching things as you suggested, but it just added strange bands of blank to the elements in the panel. So, I tried shifting around their order and finally just removed the system tray from the panel. When I added it back, the blank "ghost icons" (as I'm now calling them. Tell your friends!) were gone. But, they are returning one by one every time I unlock my computer after it goes to screensaver. I think that's the root cause, and I have a workaround now: remove and add the systray to clear out the ghosts.
ericfoxx
Level 1
Level 1
 
Posts: 3
Joined: Wed Apr 11, 2012 9:58 pm

Re: Blank icons infesting my panel

Postby caribriz on Fri Apr 13, 2012 4:43 pm

mmm ... weird :?
I haven't run into that problem.
It's good you figured out a workaround ... hopefully someone will come up with an idea for a more permanent solution,
and get rid of those "ghost icons" :twisted:

You could also try posting the problem on the LXDE forum as well - never know ....
http://forum.lxde.org/

Good luck :)
caribriz
Image
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 13 Cinnamon)
caribriz
Level 5
Level 5
 
Posts: 789
Joined: Mon Nov 28, 2011 7:43 am

Re: Blank icons infesting my panel

Postby jcgr11 on Sat Apr 14, 2012 10:29 am

Here's the discussion thread from the LXDE forums (I think it's the same as your problem):
http://forum.lxde.org/viewtopic.php?f=21&t=31432

It seems it aint solved yet.

----

I used to have problems with empty spaces on the system tray too...
but ever since I disabled a lot of startup applications (that would show up on the system tray),
I dont have empty spaces anymore.
Right now, I only have network and battery on my system tray... no dropbox, no update manager, no bluetooth... etc).
Maybe it's related, maybe it's not... but if it is, maybe it's because I dont have a lot of stuff on my system tray...
jcgr11
Level 1
Level 1
 
Posts: 4
Joined: Sat Feb 11, 2012 12:01 am

Linux Mint is funded by ads and donations.
 

Return to LXDE

Who is online

Users browsing this forum: No registered users and 4 guests