Power management is pathetic

Forum rules
Before you post please read this

Power management is pathetic

Postby c-m on Tue Apr 17, 2012 5:01 am

I'm running LXDE Mint 12 on my netbook and having a big issue with power saving/power management. Basically it's just pathetic.

When on battery, there is no option to shut down the laptop after being left for a certain time. It can be set to go to sleep (say after 15mins), yet every time this has happened, whenever I come back to the computer the batter is dead, and needs recharging.

This is putting many more cycles through my battery unnecessarily.

Is there no decent power management function for LXDE at all?

As a netbook it's a well known chip-set and well supported in linux, so there really isn't any excuse.

I'm mildly annoyed :wink:
c-m
Level 3
Level 3
 
Posts: 114
Joined: Mon Aug 24, 2009 2:01 pm

Linux Mint is funded by ads and donations.
 

Re: Power management is pathetic

Postby wayne128 on Tue Apr 17, 2012 5:06 am

I'm mildly annoyed :wink:


Try jupiter :mrgreen:

in doubt, try fuduntu , which has jupiter already installed.

in some of my earlier tests, I recall:
1. Mint10 run reasonably well on battery..
it is warm compare to win7 ( always cool and battery long lasting)
2. Mint11 cook. 10+ degree more, cannot put on the lap
3. tested with jupiter plus kernel argument to bring down temp, yet it is warm to hot
4. run fuduntu with jupiter, run as cool as ( slightly warmer to) win7.

never tested any Mint12 on this laptop.
wayne128
Level 10
Level 10
 
Posts: 3322
Joined: Tue Jul 13, 2010 12:15 am

Re: Power management is pathetic

Postby c-m on Tue Apr 17, 2012 5:11 am

Thanks, will take a look.

Battery life from the default 3 cell battery is just over 3 hours in Mint 12 which is pretty good considering it's about 3 years old.
c-m
Level 3
Level 3
 
Posts: 114
Joined: Mon Aug 24, 2009 2:01 pm

Re: Power management is pathetic

Postby nunol on Tue Apr 17, 2012 7:37 am

Here are some ideas:
- install gnome-power-manager or xfce4-power manager.
- install laptop-mode-tools (config: /etc/laptop-mode/laptop-mode.conf and /etc/laptop-mode/conf.d/). Here are some configs: http://crunchbanglinux.org/forums/topic ... or-debian/
- the Jupiter ppa
- Make sure CPU Frequency Scaling is working
- etc
User avatar
nunol
Level 9
Level 9
 
Posts: 2664
Joined: Sun Mar 06, 2011 9:25 pm
Location: Portugal

Re: Power management is pathetic

Postby NarcT on Tue Apr 17, 2012 10:06 pm

I configured my laptop to always be in powersave mode and increased my battery life greatly. You could try this by changing the pm-utils scripts to never turn off. I wrote a tutorial to help. Good luck!

viewtopic.php?f=42&t=99933
NarcT
Level 1
Level 1
 
Posts: 4
Joined: Tue Apr 17, 2012 9:37 pm

Re: Power management is pathetic

Postby KBD47 on Tue Apr 17, 2012 11:22 pm

Run top in a terminal and make sure you don't have a udev problem, udev will cause your cpu to run at 100% this is an issue for some laptops:
http://areyoueye.net/?p=143
It also affects my D255E aspire one. Very hard on the battery.
KBD47
KBD47
Level 6
Level 6
 
Posts: 1025
Joined: Fri Jul 29, 2011 12:03 am


Return to Others

Who is online

Users browsing this forum: No registered users and 0 guests